File python-ordereddict.spec of Package python-ordereddict
#
# spec file for package python-ordereddict
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
#
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: python-ordereddict
Version: 1.1
Release: 0
Url: http://pypi.python.org/pypi/ordereddict/
Summary: A drop-in substitute for Py2.7's new collections.OrderedDict
License: MIT
Group: Development/Languages/Python
Source: http://pypi.python.org/packages/source/o/ordereddict/ordereddict-%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildRequires: python-devel
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%else
BuildArch: noarch
%endif
%description
Drop-in substitute for Py2.7's new collections.OrderedDict. The recipe has big-oh
performance that matches regular dictionaries (amortized O(1)
insertion/deletion/lookup and O(n) iteration/repr/copy/equality_testing).
Originally based on http://code.activestate.com/recipes/576693/
%prep
%setup -q -n ordereddict-%{version}
%build
python setup.py build
%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
%files
%defattr(-,root,root,-)
%doc LICENSE
%{python_sitelib}/*
%changelog