File python-oslo.middleware.spec of Package python-oslo.middleware

#
# spec file for package python-oslo.middleware
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


Name:           python-oslo.middleware
Version:        6.1.0
Release:        0
Summary:        OpenStack oslo.middleware library
License:        Apache-2.0
Group:          Development/Languages/Python
URL:            https://docs.openstack.org/oslo.middleware
Source0:        https://files.pythonhosted.org/packages/source/o/oslo.middleware/oslo.middleware-6.1.0.tar.gz
BuildRequires:  openstack-macros
BuildRequires:  python3-Jinja2
BuildRequires:  python3-WebOb
BuildRequires:  python3-bcrypt
BuildRequires:  python3-debtcollector
BuildRequires:  python3-devel
BuildRequires:  python3-fixtures
BuildRequires:  python3-oslo.config
BuildRequires:  python3-oslo.context
BuildRequires:  python3-oslo.i18n
BuildRequires:  python3-oslo.serialization
BuildRequires:  python3-oslo.utils
BuildRequires:  python3-oslotest
BuildRequires:  python3-pbr
BuildRequires:  python3-statsd
BuildRequires:  python3-stestr
BuildRequires:  python3-stevedore
BuildRequires:  python3-testtools
BuildArch:      noarch

%description
Oslo middleware library includes components that can be injected into wsgi
pipelines to intercept request/response flows. The base class can be enhanced
with functionality like add/delete/modification of http headers and support
for limiting size/connection etc.

%package -n python3-oslo.middleware
Summary:        OpenStack oslo.middleware library
Requires:       python3-Jinja2
Requires:       python3-WebOb
Requires:       python3-bcrypt
Requires:       python3-debtcollector
Requires:       python3-oslo.config
Requires:       python3-oslo.context
Requires:       python3-oslo.i18n
Requires:       python3-oslo.serialization
Requires:       python3-oslo.utils
Requires:       python3-statsd
Requires:       python3-stevedore

%description -n python3-oslo.middleware
Oslo middleware library includes components that can be injected into wsgi
pipelines to intercept request/response flows. The base class can be enhanced
with functionality like add/delete/modification of http headers and support
for limiting size/connection etc.

This package contains the Python 3.x module.

%package -n python3-oslo.middleware-doc
Summary:        Documentation for OpenStack middleware library
BuildRequires:  python3-Sphinx
BuildRequires:  python3-openstackdocstheme

%description -n python3-oslo.middleware-doc
Oslo middleware library includes components that can be injected into wsgi
pipelines to intercept request/response flows. The base class can be enhanced
with functionality like add/delete/modification of http headers and support
for limiting size/connection etc.
This package contains the documentation.

%prep
%autosetup -p1 -n oslo.middleware-6.1.0
%py_req_cleanup

%build
%py3_build

# generate html docs
PBR_VERSION=%{version} %sphinx_build -b html doc/source doc/build/html
# remove the sphinx-build leftovers
rm -rf doc/build/html/.{doctrees,buildinfo}

%install
%py3_install

%check
%{openstack_stestr_run}

%files -n python3-oslo.middleware
%license LICENSE
%doc README.rst ChangeLog
%{python3_sitelib}/oslo_middleware
%{python3_sitelib}/*.egg-info

%files -n python3-oslo.middleware-doc
%license LICENSE
%doc doc/build/html

%changelog
openSUSE Build Service is sponsored by