File python-oslo.upgradecheck.spec of Package python-oslo.upgradecheck

#
# spec file for package python-oslo.upgradecheck
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


Name:           python-oslo.upgradecheck
Version:        2.3.0
Release:        0
Epoch:          0
Summary:        Common code for writing OpenStack upgrade checks
License:        Apache-2.0
Group:          Development/Languages/Python
URL:            https://docs.openstack.org/oslo.upgradecheck
Source0:        https://files.pythonhosted.org/packages/source/o/oslo.upgradecheck/oslo.upgradecheck-2.3.0.tar.gz
BuildRequires:  fdupes
BuildRequires:  openstack-macros
BuildRequires:  python3-Babel
BuildRequires:  python3-PrettyTable
BuildRequires:  python3-oslo.config
BuildRequires:  python3-oslo.i18n
BuildRequires:  python3-oslo.policy
BuildRequires:  python3-oslo.serialization
BuildRequires:  python3-oslo.utils
BuildRequires:  python3-oslotest
BuildRequires:  python3-stestr
BuildArch:      noarch

%description
This project contains the common code necessary for writing upgrade checks
in OpenStack projects. It includes a module (oslo_upgradecheck.upgradecheck)
for the common code as well as an example (oslo_upgradecheck.__main__) of
integrating that code into a project.

%package -n python3-oslo.upgradecheck
Summary:        Common code for writing OpenStack upgrade checks
Requires:       python3-Babel
Requires:       python3-PrettyTable
Requires:       python3-oslo.config
Requires:       python3-oslo.i18n
Requires:       python3-oslo.policy
Requires:       python3-oslo.utils

%description -n python3-oslo.upgradecheck
This project contains the common code necessary for writing upgrade checks
in OpenStack projects. It includes a module (oslo_upgradecheck.upgradecheck)
for the common code as well as an example (oslo_upgradecheck.__main__) of
integrating that code into a project.

This package contains the Python 3.x module.

%package -n python-oslo.upgradecheck-doc
Summary:        Common code for writing OpenStack upgrade checks
BuildRequires:  python3-Sphinx
BuildRequires:  python3-openstackdocstheme

%description -n python-oslo.upgradecheck-doc
Documentation for the oslo.upgradecheck library.

%prep
%autosetup -p1 -n oslo.upgradecheck-2.3.0
%py_req_cleanup

%build
%{py3_build}

PBR_VERSION=2.3.0 %sphinx_build -b html doc/source doc/build/html
# remove the sphinx-build leftovers
rm -rf doc/build/html/.{doctrees,buildinfo}
%fdupes doc/build/html/

%install
%{py3_install}

%check
export PYTHONPATH=`pwd`
%{openstack_stestr_run}

%files -n python3-oslo.upgradecheck
%license LICENSE
%{python3_sitelib}/oslo_upgradecheck
%{python3_sitelib}/*.egg-info

%files -n python-oslo.upgradecheck-doc
%doc doc/build/html README.rst
%license LICENSE

%changelog
openSUSE Build Service is sponsored by