File python-metaextract.spec of Package python-metaextract
#
# spec file for package python-metaextract
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: python-metaextract
Version: 1.0.9
Release: 0
Summary: get metadata for python modules
License: Apache-2.0
URL: http://github.com/toabctl/metaextract
Source: https://files.pythonhosted.org/packages/source/m/metaextract/metaextract-%{version}.tar.gz
BuildRequires: python-rpm-macros
BuildRequires: %{python_module pip}
BuildRequires: %{python_module setuptools}
BuildRequires: %{python_module wheel}
# SECTION test requirements
BuildRequires: %{python_module flake8}
BuildRequires: %{python_module pytest}
# /SECTION
BuildRequires: fdupes
Requires(post): update-alternatives
Requires(postun):update-alternatives
BuildArch: noarch
%python_subpackages
%description
get metadata for python modules foo bar
%prep
%autosetup -p1 -n metaextract-%{version}
%build
%pyproject_wheel
%install
%pyproject_install
%python_clone -a %{buildroot}%{_bindir}/metaextract
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%post
%python_install_alternative metaextract
%postun
%python_uninstall_alternative metaextract
%files %{python_files}
%doc README.rst
%license LICENSE
%python_alternative %{_bindir}/metaextract
%{python_sitelib}/metaextract
%{python_sitelib}/metaextract-%{version}.dist-info
%changelog