File pypdf.spec of Package pypdf

#
#
#

%define _name pyPdf
%define version 1.11
%define unmangled_version 1.11
%define release 1

Summary:    PDF toolkit
Name:       pypdf
Version:    %{version}
Release:    %{release}
Source0:    %{_name}-%{unmangled_version}.tar.gz
License:    BSD (modified)
Group:      Development/Libraries/Python
BuildRoot:  %{_tmppath}/%{name}-%{version}-%{release}-buildroot
Prefix:     %{_prefix}
BuildRequires: python-devel python-setuptools
BuildArch:  noarch
Vendor:     Mathieu Fenniak <biziqe@mathieu.fenniak.net>
Url:        http://pybrary.net/pyPdf/

%description

A Pure-Python library built as a PDF toolkit.  It is capable of:
    
- extracting document information (title, author, ...),
- splitting documents page by page,
- merging documents page by page,
- cropping pages,
- merging multiple pages into a single page,
- encrypting and decrypting PDF files.

By being Pure-Python, it should run on any Python platform without any
dependencies on external libraries.  It can also work entirely on StringIO
objects rather than file streams, allowing for PDF manipulation in memory.
It is therefore a useful tool for websites that manage or manipulate PDFs.


%prep
%setup -n %{_name}-%{unmangled_version}

%build
python setup.py build

%install
python setup.py install --root=$RPM_BUILD_ROOT --prefix=%{_prefix} --record=INSTALLED_FILES

%clean
rm -rf $RPM_BUILD_ROOT

%files -f INSTALLED_FILES
%defattr(-,root,root)
%doc README CHANGELOG

%changelog
openSUSE Build Service is sponsored by