File elisa.spec of Package elisa
#
# spec file for package elisa
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: elisa
Version: 0.3.80
Release: 0
Summary: Simple and nice music player
# FIXME: Select a correct license from https://github.com/openSUSE/spec-cleaner#spdx-licenses
License: LGPL-3.0
# FIXME: use correct group, see "https://en.opensuse.org/openSUSE:Package_group_guidelines"
Group: Productivity/Multimedia/Sound/Players
Url: https://community.kde.org/Elisa
Source: elisa-%{version}.tar.gz
BuildRequires: pkgconfig(Qt5Core) >= 5.10.0
BuildRequires: pkgconfig(Qt5Network) >= 5.10.0
BuildRequires: pkgconfig(Qt5Qml) >= 5.10.0
BuildRequires: pkgconfig(Qt5Sql) >= 5.10.0
BuildRequires: pkgconfig(Qt5Multimedia) >= 5.10.0
BuildRequires: pkgconfig(Qt5Svg) >= 5.10.0
BuildRequires: pkgconfig(Qt5Gui) >= 5.10.0
BuildRequires: pkgconfig(Qt5Widgets) >= 5.10.0
BuildRequires: pkgconfig(Qt5Concurrent) >= 5.10.0
BuildRequires: pkgconfig(Qt5QuickControls2) >= 5.10.0
#BuildRequires: pkgconfig(gettext)
#BuildRequires: pkgconfig(python-interp)
BuildRequires: cmake(KF5I18n) >= 5.45.0
BuildRequires: cmake(KF5IconThemes) >= 5.45.0
#BuildRequires: pkgconfig(ECM) >= 1.6.0
BuildRequires: cmake(KF5Config) >= 5.45.0
BuildRequires: cmake(KF5KCMUtils) >= 5.45.0
BuildRequires: cmake(KF5KIO) >= 5.45.0
# optionals 1
BuildRequires: pkgconfig(Qt5Quick) >= 5.8.0
BuildRequires: pkgconfig(Qt5Test) >= 5.8.0
BuildRequires: pkgconfig(Qt5DBus) >= 5.8.0
BuildRequires: cmake(KF5Declarative) >= 5.45.0
BuildRequires: cmake(KF5CoreAddons) >= 5.45.0
BuildRequires: cmake(KF5DocTools) >= 5.45.0
BuildRequires: cmake(KF5XmlGui) >= 5.45.0
BuildRequires: cmake(KF5Crash) >= 5.45.0
BuildRequires: cmake(KF5DBusAddons) >= 5.45.0
# optionals 2
#BuildRequires: pkgconfig(Qt5AndroidExtras) >= 5.8.0
BuildRequires: cmake(KF5Baloo) >= 5.32.0
BuildRequires: cmake(KF5FileMetaData) >= 5.45.0
#BuildRequires: pkgconfig(UPNPQT)
BuildRequires: update-desktop-files
#libvlc
BuildRequires: pkgconfig(libvlc)
BuildRequires: cmake(KF5Kirigami2)
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
Elisa is a simple music player aiming to provide a nice experience for its users.
#package devel
#Summary: Development files for Elisa — Simple and nice music player
#Group: Development/Libraries/KDE
#Requires: #{name} = #{version}
#description devel
#Development files for Elisa.
#Elisa is a simple music player aiming to provide a nice experience for its users.
%prep
%setup -q -n elisa-%{version}
%build
%cmake_kf5 -d build
%make_jobs
%install
%kf5_makeinstall -C build
%suse_update_desktop_file -r org.kde.elisa Qt KDE AudioVideo Audio Player
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
#%license LICENSE*
%{_kf5_applicationsdir}/org.kde.elisa.desktop
%{_kf5_bindir}/elisa
#dir %{_kf5_plugindir}/kcms/
#{_kf5_plugindir}/kcms/kcm_elisa_local_file.so
%{_kf5_iconsdir}/??color/*/apps/elisa.??g
#{_kf5_servicesdir}/kcm_elisa_local_file.desktop
%{_kf5_sharedir}/dbus-1/services/org.kde.elisa.service
#dir %{_kf5_sharedir}/kpackage/
#dir %{_kf5_sharedir}/kpackage/kcms/
#{_kf5_sharedir}/kpackage/kcms/kcm_elisa_local_file/
%{_kf5_appstreamdir}/org.kde.elisa.appdata.xml
%dir %{_kf5_libdir}/elisa
%{_kf5_libdir}/elisa/libelisaLib.so.*
%{_kf5_libdir}/qt5/qml/
%{_kf5_sharedir}/qlogging-categories5
%doc %lang(en) %{_kf5_htmldir}/en/elisa/
#files devel
#dir 3{_kf5_libdir}/elisa
#{_kf5_libdir}/elisa/libelisaLib.so
%changelog