File tine20.spec of Package tine20

#
# spec file for package tine20
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
# Copyright (c) 2010,2016 Weberhofer GmbH, Austria
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%define apc_compatible %(php -v 2>/dev/null | grep -q -E '^PHP (5\.2|5\.3|5\.4)' && echo 1 || echo 0)
#
%{!?pear_phpdir: %{expand: %%global pear_phpdir     %(pear config-get php_dir 2> /dev/null) } }
%define		tine_base     %{_datadir}/tine20
%define		tine_var      %{_localstatedir}/lib/tine20
# directories contained in tine20-base
%define         tinebase_dirs "Addressbook Admin Setup Tinebase Zend fonts images library themes vendor"
%if 0%{?suse_version}
%define        apache_conf        %{_sysconfdir}/apache2
%define        apacheuser        wwwrun
%define        apachegroup        www
BuildRequires:  cron
%else
%define        apache_conf        %{_sysconfdir}/httpd
%define        apacheuser         apache
%define        apachegroup        apache
BuildRequires:  crontabs
%endif
Name:           tine20
Version:        2016.03.2
Release:        0
Summary:        Open Source Groupware and CRM
License:        AGPL-3.0 and GPL-3.0 and LGPL-2.0 and BSD-2-Clause
Group:          System/Libraries
Url:            http://www.tine20.org/
Source0:        https://packages.tine20.org/source/%{version}/tine20-allinone_%{version}.tar.bz2
Source1:        https://packages.tine20.org/source/%{version}/tine20-courses_%{version}.tar.bz2
Source2:        https://packages.tine20.org/source/%{version}/tine20-expressomail_%{version}.tar.bz2
Source3:        https://packages.tine20.org/source/%{version}/tine20-humanresources_%{version}.tar.bz2
Source4:        https://packages.tine20.org/source/%{version}/tine20-inventory_%{version}.tar.bz2
Source5:        https://packages.tine20.org/source/%{version}/tine20-projects_%{version}.tar.bz2
Source6:        https://packages.tine20.org/source/%{version}/tine20-requesttracker_%{version}.tar.bz2
Source7:        https://packages.tine20.org/source/%{version}/tine20-simplefaq_%{version}.tar.bz2
Source8:        https://packages.tine20.org/source/%{version}/tine20-sipgate_%{version}.tar.bz2
Source9:        https://packages.tine20.org/source/%{version}/tine20-voip_%{version}.tar.bz2
Source10:       https://packages.tine20.org/source/%{version}/tine20-voipmanager_%{version}.tar.bz2
Source100:      tine20-admin.sh
Source101:      tine20-asyncrunner.sh
Source104:      tine20.cron
Source110:      README.DISTRIBUTION
Source120:      find_php_files.sh
# fix ical import
Patch100:       tine20-ical-import.patch
# fix language detection
Patch104:       tine20-translation.patch
BuildRequires:  curl
BuildRequires:  php5-ZendFramework
BuildRequires:  php5-pear-htmlpurifier
BuildRequires:  php5-pear-phpexcel >= 1.7.8
Requires:       php5-ZendFramework >= 1.12.17
Requires:       php5-ZendFramework-captcha
Requires:       php5-ZendFramework-dojo
Requires:       php5-ZendFramework-pdf
Requires:       tine20-activesync = %{version}
Requires:       tine20-base = %{version}
Requires:       tine20-calendar = %{version}
Requires:       tine20-crm = %{version}
Requires:       tine20-felamimail = %{version}
Requires:       tine20-filemanager = %{version}
Requires:       tine20-projects = %{version}
Requires:       tine20-sales = %{version}
Requires:       tine20-tasks = %{version}
Requires:       tine20-timetracker = %{version}
# Tine20 is now using the default Zend-Framework. Therefore the old Framework can be removed.
# This Provides/Obsoletes lines should be removed in 2017
Obsoletes:      tine20-base-ZendFramework < 1.12
Provides:       tine20-base-ZendFramework = 1.12
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildArch:      noarch
%if 0%?suse_version >= 1010
Recommends:     php5-ZendFramework-cache-backend-memcached
%endif
%if %{apc_compatible}
Requires:       php5-ZendFramework-cache-backend-apc
%endif
%if 0%{?suse_version} > 1020
BuildRequires:  fdupes
%endif

%description
Tine 2.0 is an open source project, which combines groupware, CRM and ERP
into one system and is therefore useful for the the whole company, from
field staff to back office members.

Thanks to their consistent orientation to the users needs, Tine 2.0 makes
business collaboration easier and more enjoyable. Synergies, which the whole
company profits from,  are being created through its deft linkage between and
among the different components, and the collective work on one master data
source.

This package provides a typical tine20 installation of the most common modules.

Tine 2.0 includes address book, calendar, email, tasks, time tracking and
CRM. Intelligent functions and links make collaboration in Tine 2.0 a true
pleasure and include:

  * Synchronising mobile telephones
  * VoiP integration
  * Flexible assigning of authorisation rights
  * Dynamic lists
  * Search functions
  * History
  * PDF export

%package base
Summary:        Tine's core, admin and addressbook module
License:        AGPL-3.0 and GPL-3.0 and BSD-2-Clause and LGPL-2.0
Group:          System/Libraries
Url:            http://www.tine20.org/
Requires:       php5 >= 5.3.7
Requires:       php5-calendar
Requires:       php5-fileinfo
Requires:       php5-gd
Requires:       php5-hash
Requires:       php5-iconv
Requires:       php5-intl
Requires:       php5-json
Requires:       php5-mcrypt
Requires:       php5-mysql
Requires:       php5-pear-htmlpurifier >= 4.3.0
Requires:       php5-pear-phpexcel >= 1.7.8
Requires:       php5-zip
%if 0%{?suse_version}
Requires:       apache2
Requires:       cron
%if 0%{?sles_version} > 9
Suggests:       php5-APC
Suggests:       php5-pecl-memcache
%endif
%if 0%{?suse_version} > 1000
Suggests:       php5-ldap
Suggests:       php5-mysql
%endif
%else
Requires:       crontabs
Requires:       httpd
Requires:       vixie-cron
%endif

%description base
This packages contains the core librarys of Tine 2.0 and the addressbook module.
Installing this package enables you to manage user accounts and contacts. Also
provides integration with openstreet map.

%package activesync
Summary:        Module to share calendar and contacts via Active-Sync
License:        AGPL-3.0
Group:          System/Libraries
Url:            http://www.tine20.org/
Requires:       tine20-base = %{version}
Requires(pre):  /bin/sh
Requires(pre):  curl

%description activesync
This package allows a simple installation procedure for the
Tine20 ActiveSync-Components. ActiveSync allows you to
synchronize contacts, event, tasks and emails with your mobile phone.

The distribution of the Tine 2.0 ActiveSync module in or to
the United States of America is prohibited due to patent issues.

This package does not contain any files concerned by the above
mentioned patent issues. Only a installer for the module is included.

%package calendar
Summary:        Calendar module
License:        AGPL-3.0
Group:          System/Libraries
Url:            http://www.tine20.org/
Requires:       tine20-base = %{version}

%description calendar
This package contains the calendar module of Tine 2.0. Installing this package
enables you to schedule events for your self and other Tine 2.0 users.

%package courses
Summary:        Courses module
License:        AGPL-3.0
Group:          System/Libraries
Url:            http://www.tine20.org/
Requires:       tine20-base = %{version}

%description courses
This package contains the tine20 courses module.

%package crm
Summary:        Customer-Relationship-Management module
License:        AGPL-3.0
Group:          System/Libraries
Url:            http://www.tine20.org/
Requires:       tine20-base = %{version}
Requires:       tine20-sales
Requires:       tine20-tasks

%description crm
This package contains the CRM module of Tine 2.0. Installing this package
enables you to manage leads. Typically used by sales people.

%package expressomail
Summary:        Alternative EMail Module
License:        AGPL-3.0
Group:          System/Libraries
Url:            http://www.tine20.org/
Requires:       tine20-base = %{version}

%description expressomail
Expressomail is an application derived from Felamimail. Backend has been
changed to access directly IMAP, without database cache.

%package felamimail
Summary:        EMail Module
License:        AGPL-3.0
Group:          System/Libraries
Url:            http://www.tine20.org/
Requires:       tine20-base = %{version}

%description felamimail
This package contains the email module of Tine 2.0. Installing this package
enables you to read emails stored on a imap server. You can read emails on
multiple imap servers.

%package filemanager
Summary:        Filemanager Module
License:        AGPL-3.0
Group:          System/Libraries
Url:            http://www.tine20.org/
Requires:       tine20-base = %{version}

%description filemanager
This package contains the filemanager module of Tine 2.0. Installing this package
enables you to store files on your webserver.

%package humanresources
Summary:        Humanresources Module
License:        AGPL-3.0
Group:          System/Libraries
Url:            http://www.tine20.org/
Requires:       tine20-base = %{version}
Requires:       tine20-calendar
Requires:       tine20-sales

%description humanresources
Help to allocate the working time and free time (vacation, sickness) of
employees. Current features:
* create a (shared) feast calender: every day having an event in this
  calendar could not be used as free time day because it is already a free day.
* create employee records, define how they are working (contract with
  working-time-model, vacation days, feast-calendar).
* book free days or sickness days.

%package inventory
Summary:        Inventory Module
License:        AGPL-3.0
Group:          System/Libraries
Url:            http://www.tine20.org/
Requires:       tine20-base = %{version}

%description inventory
This package contains the inventory module.

%package phone
Summary:        Telephone Module
License:        AGPL-3.0
Group:          System/Libraries
Url:            http://www.tine20.org/
Requires:       tine20-base = %{version}
Requires:       tine20-voipmanager

%description phone
This package contains the telephone module.

%package projects
Summary:        Project-Management Module
License:        AGPL-3.0
Group:          System/Libraries
Url:            http://www.tine20.org/
Requires:       tine20-base = %{version}

%description projects
This package contains the projects module of Tine 2.0.

%package requesttracker
Summary:        Request-Tracker Module
License:        AGPL-3.0
Group:          System/Libraries
Url:            http://www.tine20.org/
Requires:       tine20-base = %{version}

%description requesttracker
This package contains the request-tracker module.

%package sales
Summary:        Sales Module
License:        AGPL-3.0
Group:          System/Libraries
Url:            http://www.tine20.org/
Requires:       tine20-base = %{version}

%description sales
This package contains the sales module of Tine 2.0. Installing this package
enables you to manage products and orders. This package has only very limited
functionality, because it's integrated into other modules (for example the CRM
module)

%package simplefaq
Summary:        Simple-FAQ Module
License:        AGPL-3.0
Group:          System/Libraries
Url:            http://www.tine20.org/
Requires:       tine20-base = %{version}

%description simplefaq
This package contains the Simple-FAQ module.

%package sipgate
Summary:        SIPgate Module
License:        AGPL-3.0
Group:          System/Libraries
Url:            http://www.tine20.org/
Requires:       tine20-base = %{version}

%description sipgate
This package contains the SIPgate module.

%package tasks
Summary:        Tasks Module
License:        AGPL-3.0
Group:          System/Libraries
Url:            http://www.tine20.org/
Requires:       tine20-base = %{version}

%description tasks
This package contains the Tasks module.

%package timetracker
Summary:        Time-Tracker Module
License:        AGPL-3.0
Group:          System/Libraries
Url:            http://www.tine20.org/
Requires:       tine20-base = %{version}

%description timetracker
This package contains the tasks module of Tine 2.0. Installing this package
enables you to manage tasks.

%package voipmanager
Summary:        VoIP-Manager Module
License:        AGPL-3.0
Group:          System/Libraries
Url:            http://www.tine20.org/
Requires:       tine20-base = %{version}

%description voipmanager
This package contains the VoIP-Manager module.

%prep
%setup -q -c %{name}-%{version} -T
%setup -q -D -a 0
%setup -q -D -a 1
%setup -q -D -a 2
%setup -q -D -a 3
%setup -q -D -a 4
%setup -q -D -a 5
%setup -q -D -a 6
%setup -q -D -a 7
%setup -q -D -a 8
%setup -q -D -a 9
%setup -q -D -a 10

%patch100 -p1
%patch104 -p1

find . -regex '.*\.po[t]*$' -exec rm -f {} \;

find . -type d -exec chmod 0755 {} \;
find . -type f -exec chmod 0644 {} \;

rm vendor/sabre/vobject/.travis.yml \
	vendor/sabre/dav/.travis.yml \
	vendor/ezyang/htmlpurifier/.gitattributes

# remove and symlink
rm -rf vendor/ezyang/htmlpurifier/library/* \
	vendor/codeplex/phpexcel/* \
	vendor/zendframework/zendframework1/library/Zend


# remove documentation and tests from new zendframework
rm -rf vendor/zendframework/zendframework1/demos

# remove example config
rm -f config.inc.php.dist

%build

%install
%if 0%{?suse_version} == 1110
export NO_BRP_CHECK_BYTECODE_VERSION=true
%endif

install -d -m 0755 %{buildroot}%{tine_base}
# install files for the base package and symlink duplicates
for F in %{tinebase_dirs} ; do
	cp -a $F %{buildroot}%{tine_base}
done
%if 0%{?suse_version} > 1020
%fdupes -s %{buildroot}%{tine_base}
%endif

# install all other files /do not overwrite)
for FILE in * ; do
	if ! [[ %{tinebase_dirs} =~ "$FILE" ]] ; then
		cp -a "$FILE" %{buildroot}%{tine_base}
	fi
done

pushd %{buildroot}%{tine_base}

# move documentation
# LICENSE and PRIVACY files should stay in the base directory,
# because they are needed during the setup-process
install -d -m 0755 %{buildroot}%{_docdir}/%{name}
for F in RELEASENOTES README ; do
	mv $F %{buildroot}%{_docdir}/%{name}/
done

install -m 0644 %{SOURCE110} %{buildroot}%{_docdir}/%{name}/

# remove this file from the docs
rm -rf docs

# remove duplicates
%if 0%{?suse_version} > 1020
for DIR in `ls -d **/` ; do
	if ! [[ %{tinebase_dirs} =~ "$DIR" ]] ; then
		%fdupes -s %{buildroot}%{tine_base}/$DIR
	fi
done
%endif

# link external libraries
for f in `ls %{_datadir}/php5/PEAR/HTMLPurifier*.php` ; do
	ln -s "$f" vendor/ezyang/htmlpurifier/library/
done
ln -s %{_datadir}/php5/PEAR/HTMLPurifier vendor/ezyang/htmlpurifier/library/
ln -s %{_datadir}/php5/PEAR/PHPExcel.php vendor/codeplex/phpexcel/
ln -s %{_datadir}/php5/PEAR/PHPExcel vendor/codeplex/phpexcel/
ln -s %{_datadir}/php5/Zend vendor/zendframework/zendframework1/library/

# install admintools
install -d -m 0755 %{buildroot}%{_bindir}
install -m 0750 %{SOURCE100} %{buildroot}%{_bindir}/tine20-admin
install -m 0755 %{SOURCE101} %{buildroot}%{_bindir}/tine20-asyncrunner.sh

# install cronjobs
install -d -m 0755 %{buildroot}%{_sysconfdir}/cron.d
install -m 0644 %{SOURCE104} %{buildroot}%{_sysconfdir}/cron.d/tine20

# create configurations
install -d -m 0755 %{buildroot}%{apache_conf}/conf.d
%{buildroot}%{_bindir}/tine20-admin install "%{tine_var}" --prefix %{buildroot} \
	> %{buildroot}%{apache_conf}/conf.d/tine20.conf
sed -i %{buildroot}%{apache_conf}/conf.d/tine20.conf -e 's/^\t//'
popd

# collect the language files
install -m 0755 %{SOURCE120} %{buildroot}%{_bindir}find_php_files
%{buildroot}%{_bindir}find_php_files %{buildroot} base \
	"%{tine_base}/Addressbook" "%{tine_base}/Admin" \
	"%{tine_base}/CoreData" \
	"%{tine_base}/Setup" "%{tine_base}/Tinebase"
for DIR in ActiveSync Calendar Courses Crm Expressomail Felamimail Filemanager HumanResources \
	Inventory Phone Projects \
        RequestTracker Sales SimpleFAQ Sipgate Tasks Timetracker Voipmanager ; do
	%{buildroot}%{_bindir}find_php_files %{buildroot} "$DIR" "%{tine_base}/$DIR"
done
rm -f %{buildroot}%{_bindir}find_php_files

#Addressbook Admin Setup Tinebase

%pre base
# delete the old %{tine_base}/vendor/zendframework/zendframework1/library/Zend directory:
# rpm is not able to change it to a symlink
if ( [ -d %{tine_base}/vendor/zendframework/zendframework1/library/Zend ] && \
	! [ -L %{tine_base}/vendor/zendframework/zendframework1/library/Zend ] ) ; then
	rm -rf %{tine_base}/vendor/zendframework/zendframework1/library/Zend
fi

%post base
[ $1 -eq 1 ] && %{_bindir}/tine20-admin addremove || %{_bindir}/tine20-admin update

%post activesync
[ $1 -eq 1 ] && %{_bindir}/tine20-admin addremove || %{_bindir}/tine20-admin update

%postun activesync
[ $1 -eq 0 -a -x %{_bindir}/tine20-admin ] && %{_bindir}/tine20-admin addremove || exit 0

%post calendar
[ $1 -eq 1 ] && %{_bindir}/tine20-admin addremove || %{_bindir}/tine20-admin update

%postun calendar
[ $1 -eq 0 -a -x %{_bindir}/tine20-admin ] && %{_bindir}/tine20-admin addremove || exit 0

%post courses
[ $1 -eq 1 ] && %{_bindir}/tine20-admin addremove || %{_bindir}/tine20-admin update

%postun courses
[ $1 -eq 0 -a -x %{_bindir}/tine20-admin ] && %{_bindir}/tine20-admin addremove || exit 0

%post crm
[ $1 -eq 1 ] && %{_bindir}/tine20-admin addremove || %{_bindir}/tine20-admin update

%postun crm
[ $1 -eq 0 -a -x %{_bindir}/tine20-admin ] && %{_bindir}/tine20-admin addremove || exit 0

%post expressomail
[ $1 -eq 1 ] && %{_bindir}/tine20-admin addremove || %{_bindir}/tine20-admin update

%postun expressomail
[ $1 -eq 0 -a -x %{_bindir}/tine20-admin ] && %{_bindir}/tine20-admin addremove || exit 0

%post felamimail
[ $1 -eq 1 ] && %{_bindir}/tine20-admin addremove || %{_bindir}/tine20-admin update

%postun felamimail
[ $1 -eq 0 -a -x %{_bindir}/tine20-admin ] && %{_bindir}/tine20-admin addremove || exit 0

%post filemanager
[ $1 -eq 1 ] && %{_bindir}/tine20-admin addremove || %{_bindir}/tine20-admin update

%postun filemanager
[ $1 -eq 0 -a -x %{_bindir}/tine20-admin ] && %{_bindir}/tine20-admin addremove || exit 0

%post humanresources
[ $1 -eq 1 ] && %{_bindir}/tine20-admin addremove || %{_bindir}/tine20-admin update

%postun humanresources
[ $1 -eq 0 -a -x %{_bindir}/tine20-admin ] && %{_bindir}/tine20-admin addremove || exit 0

%post inventory
[ $1 -eq 1 ] && %{_bindir}/tine20-admin addremove || %{_bindir}/tine20-admin update

%postun inventory
[ $1 -eq 0 -a -x %{_bindir}/tine20-admin ] && %{_bindir}/tine20-admin addremove || exit 0

%post phone
[ $1 -eq 1 ] && %{_bindir}/tine20-admin addremove || %{_bindir}/tine20-admin update

%postun phone
[ $1 -eq 0 -a -x %{_bindir}/tine20-admin ] && %{_bindir}/tine20-admin addremove || exit 0

%post projects
[ $1 -eq 1 ] && %{_bindir}/tine20-admin addremove || %{_bindir}/tine20-admin update

%postun projects
[ $1 -eq 0 -a -x %{_bindir}/tine20-admin ] && %{_bindir}/tine20-admin addremove || exit 0

%post requesttracker
[ $1 -eq 1 ] && %{_bindir}/tine20-admin addremove || %{_bindir}/tine20-admin update

%postun requesttracker
[ $1 -eq 0 -a -x %{_bindir}/tine20-admin ] && %{_bindir}/tine20-admin addremove || exit 0

%post sales
[ $1 -eq 1 ] && %{_bindir}/tine20-admin addremove || %{_bindir}/tine20-admin update

%postun sales
[ $1 -eq 0 -a -x %{_bindir}/tine20-admin ] && %{_bindir}/tine20-admin addremove || exit 0

%post simplefaq
[ $1 -eq 1 ] && %{_bindir}/tine20-admin addremove || %{_bindir}/tine20-admin update

%postun simplefaq
[ $1 -eq 0 -a -x %{_bindir}/tine20-admin ] && %{_bindir}/tine20-admin addremove || exit 0

%post sipgate
[ $1 -eq 1 ] && %{_bindir}/tine20-admin addremove || %{_bindir}/tine20-admin update

%postun sipgate
[ $1 -eq 0 -a -x %{_bindir}/tine20-admin ] && %{_bindir}/tine20-admin addremove || exit 0

%post tasks
[ $1 -eq 1 ] && %{_bindir}/tine20-admin addremove || %{_bindir}/tine20-admin update

%postun tasks
[ $1 -eq 0 -a -x %{_bindir}/tine20-admin ] && %{_bindir}/tine20-admin addremove || exit 0

%post timetracker
[ $1 -eq 1 ] && %{_bindir}/tine20-admin addremove || %{_bindir}/tine20-admin update

%postun timetracker
[ $1 -eq 0 -a -x %{_bindir}/tine20-admin ] && %{_bindir}/tine20-admin addremove || exit 0

%post voipmanager
[ $1 -eq 1 ] && %{_bindir}/tine20-admin addremove || %{_bindir}/tine20-admin update

%postun voipmanager
[ $1 -eq 0 -a -x %{_bindir}/tine20-admin ] && %{_bindir}/tine20-admin addremove || exit 0

%files
%defattr(0644, root, root, 0755)
%dir %{tine_base}

%files base -f base.lang
%defattr(0644, root, root, 0755)
%dir %{tine_base}
%{tine_base}/favicon.ico
%{tine_base}/CREDITS
%{tine_base}/LICENSE
%{tine_base}/PRIVACY
#
%{tine_base}/fonts
%{tine_base}/images
%{tine_base}/library
%{tine_base}/themes
%{tine_base}/vendor
%{tine_base}/Zend
%exclude %{tine_base}/vendor/sabre/**/bin
#%%{tine_base}/chrome_web_app.json
%{tine_base}/[^lt]*.php
%attr(0744, root, root) %{tine_base}/langHelper.php
%attr(0744, root, root) %{tine_base}/tine20.php

%doc %{_docdir}/%{name}

%dir %{apache_conf}
%dir %{apache_conf}/conf.d
%config(noreplace) %{apache_conf}/conf.d/%{name}.conf

%config(noreplace) %{_sysconfdir}/cron.d/tine20

%dir %{tine_var}
%dir %{tine_var}/webroot
%{tine_var}/webroot/favicon.ico
%{tine_var}/webroot/CREDITS
%{tine_var}/webroot/LICENSE
%{tine_var}/webroot/PRIVACY
#
%{tine_var}/webroot/Addressbook
%{tine_var}/webroot/Admin
%{tine_var}/webroot/CoreData
%{tine_var}/webroot/Setup
%{tine_var}/webroot/Tinebase
%{tine_var}/webroot/fonts
%{tine_var}/webroot/images
%{tine_var}/webroot/library
%{tine_var}/webroot/themes
%{tine_var}/webroot/vendor
%{tine_var}/webroot/Zend
%{tine_var}/webroot/[^c]*.php
#%#{tine_var}/webroot/chrome_web_app.json
%config(noreplace) %{tine_var}/webroot/config.inc.php

%defattr(0644, %{apacheuser}, %{apachegroup}, 0755)
%dir %{tine_var}/files
%dir %{tine_var}/session
%dir %{tine_var}/tmp
%dir %{tine_var}/log

%defattr(- , root, root, 0755)
%attr(0750,root,root) %{_bindir}/tine20-admin
%attr(0755,root,root) %{_bindir}/tine20-asyncrunner.sh

%files activesync -f ActiveSync.lang
%defattr(0644, root, root, 0755)
%{tine_var}/webroot/ActiveSync

%files calendar -f Calendar.lang
%defattr(0644, root, root, 0755)
%{tine_var}/webroot/Calendar

%files courses -f Courses.lang
%defattr(0644, root, root, 0755)
%{tine_var}/webroot/Courses

%files crm -f Crm.lang
%defattr(0644, root, root, 0755)
%{tine_var}/webroot/Crm

%files expressomail -f Expressomail.lang
%defattr(0644, root, root, 0755)
%{tine_var}/webroot/Expressomail

%files felamimail -f Felamimail.lang
%defattr(0644, root, root, 0755)
%{tine_var}/webroot/Felamimail

%files filemanager -f Filemanager.lang
%defattr(0644, root, root, 0755)
%{tine_var}/webroot/Filemanager

%files humanresources -f HumanResources.lang
%defattr(0644, root, root, 0755)
%{tine_var}/webroot/HumanResources

%files inventory -f Inventory.lang
%defattr(0644, root, root, 0755)
%{tine_var}/webroot/Inventory

%files phone -f Phone.lang
%defattr(0644, root, root, 0755)
%{tine_var}/webroot/Phone

%files projects -f Projects.lang
%defattr(0644, root, root, 0755)
%{tine_var}/webroot/Projects

%files requesttracker -f RequestTracker.lang
%defattr(0644, root, root, 0755)
%{tine_var}/webroot/RequestTracker

%files sales -f Sales.lang
%defattr(0644, root, root, 0755)
%{tine_var}/webroot/Sales

%files simplefaq -f SimpleFAQ.lang
%defattr(0644, root, root, 0755)
%{tine_var}/webroot/SimpleFAQ

%files sipgate -f Sipgate.lang
%defattr(0644, root, root, 0755)
%{tine_var}/webroot/Sipgate

%files tasks -f Tasks.lang
%defattr(0644, root, root, 0755)
%{tine_var}/webroot/Tasks

%files timetracker -f Timetracker.lang
%defattr(0644, root, root, 0755)
%{tine_var}/webroot/Timetracker

%files voipmanager -f Voipmanager.lang
%defattr(0644, root, root, 0755)
%{tine_var}/webroot/Voipmanager

%changelog
openSUSE Build Service is sponsored by