File python-botocore.spec of Package python-botocore

#
# spec file for package python-botocore
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%{?!python_module:%define python_module() python-%{**} python3-%{**}}
Name:           python-botocore
Version:        1.10.17
Release:        0
Summary:        Python interface for AWS
License:        Apache-2.0
Group:          Development/Languages/Python
Url:            https://github.com/boto/botocore
Source:         https://files.pythonhosted.org/packages/source/b/botocore/botocore-%{version}.tar.gz
# PATCH-FIX-OPENSUSE fix_tests.patch -- fix tests with removed vendored packages
Patch0:         fix_tests.patch
BuildRequires:  %{python_module devel}
BuildRequires:  %{python_module docutils >= 0.10}
BuildRequires:  %{python_module jmespath < 1.0.0}
BuildRequires:  %{python_module jmespath >= 0.7.1}
BuildRequires:  %{python_module python-dateutil <= 3.0.0}
BuildRequires:  %{python_module python-dateutil >= 2.1}
BuildRequires:  %{python_module setuptools}
BuildRequires:  fdupes
BuildRequires:  python-rpm-macros
Requires:       python-docutils >= 0.10
Requires:       python-jmespath < 1.0.0
Requires:       python-jmespath >= 0.7.1
Requires:       python-python-dateutil <= 3.0.0
Requires:       python-python-dateutil >= 2.1
Requires:       python-requests
Requires:       python-six
BuildArch:      noarch
# SECTION Testing requirements
BuildRequires:  %{python_module mock}
BuildRequires:  %{python_module nose}
BuildRequires:  %{python_module requests}
BuildRequires:  %{python_module six}
BuildRequires:  python-unittest2
# /SECTION
%python_subpackages

%description
A low-level interface to a growing number of Amazon Web Services.

%prep
%setup -q -n botocore-%{version}
%patch0 -p1
# remove requests and six
rm -r botocore/vendored/
# fix all imports:
sed -i 's/from botocore\.vendored //' botocore/*.py tests/unit/*.py
sed -i 's/botocore\.vendored\.//' botocore/*.py tests/unit/*.py tests/unit/auth/*.py

%build
%python_build

%install
%python_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
# just for compat sake symlink the bundles as other pkgs import it :/
%python_expand mkdir -p %{buildroot}%{$python_sitelib}/botocore/vendored
%python_expand ln -s %{$python_sitelib}/six.py %{buildroot}%{$python_sitelib}/botocore/vendored/six.py
%python_expand ln -s %{$python_sitelib}/requests %{buildroot}%{$python_sitelib}/botocore/vendored/requests

%check
%python_expand nosetests-%{$python_bin_suffix} tests/unit

%files %{python_files}
%doc README.rst
%license LICENSE.txt
# these are just symlinks, nothing bundled
%{python_sitelib}/botocore/vendored/*
%{python_sitelib}/botocore/
%{python_sitelib}/botocore-%{version}-py%{py_ver}.egg-info

%changelog
openSUSE Build Service is sponsored by