File udisks2.spec of Package udisks2
#
# spec file for package udisks2
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%{!?_udevrulesdir: %global _udevrulesdir %(pkg-config --variable=udevdir udev)/rules.d}
Name: udisks2
Summary: Disk Manager
License: GPL-2.0+
Group: System Environment/Daemons
Version: 2.6.5
Release: 0
Url: https://github.com/storaged-project/udisks
Source0: https://github.com/storaged-project/udisks/releases/download/udisks-%{version}/udisks-%{version}.tar.bz2
Patch1: 0001-Bug-63849-try-to-mount-filesystems-as-user-first.patch
Patch2: 0001-Introduce-new-build-dependency-on-libblkid.patch
Patch3: 0002-Probe-media-that-hasn-t-been-probed-by-udev-yet.patch
Patch4: fix_build.patch
# Needed to build the man pages
BuildRequires: chrpath
BuildRequires: docbook-xsl-stylesheets
BuildRequires: gnome-common
BuildRequires: gobject-introspection-devel
BuildRequires: gtk-doc
BuildRequires: intltool
BuildRequires: libacl-devel
BuildRequires: libgudev-1_0-devel
BuildRequires: xsltproc
BuildRequires: pkgconfig(blkid)
BuildRequires: pkgconfig(glib-2.0) >= 2.31.13
BuildRequires: pkgconfig(libatasmart) >= 0.17
BuildRequires: pkgconfig(polkit-agent-1) >= 0.92
BuildRequires: pkgconfig(polkit-gobject-1) >= 0.92
BuildRequires: pkgconfig(systemd)
BuildRequires: pkgconfig(udev)
# Needed to pull in the system bus daemon
Requires: dbus-1
# We need at least this version for bugfixes/features etc.
Requires: libatasmart4
# For mount, umount, mkswap
Requires: util-linux
# sgdisk is called by udisksd to modify the partition tables... thus a needed tool.
Requires: gptfdisk
# For LUKS devices
Requires: cryptsetup
# For ejecting removable disks
Requires: eject
Requires: libudisks2-0 = %{version}
Recommends: %{name}-lang
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%{?systemd_requires}
# For /proc/self/mountinfo, only available in 2.6.26 or higher
Conflicts: kernel < 2.6.26
# Upstream First - Policy:
# Never add any patches to this package without the upstream commit id
# in the patch. Any patches added here without a very good reason to make
# an exception will be silently removed with the next version update.
%description
The Udisks project provides a daemon, tools and libraries to access and
manipulate disks, storage devices and technologies.
%package -n libudisks2-0
Summary: Dynamic library to access the udisksd daemon
License: LGPL-2.1+
Group: System/Libraries
Recommends: %{name} = %{version}
%description -n libudisks2-0
This package contains the dynamic library, which provides
access to the udisksd daemon.
%package -n typelib-1_0-UDisks-2_0
Summary: UDisks Client Library, version 2 -- Introspection bindings
License: LGPL-2.1+
Group: System/Libraries
%description -n typelib-1_0-UDisks-2_0
udisks provides a daemon, D-Bus API and command line tools
for managing disks and storage devices.
This package provides the GObject Introspection bindings for
the UDisks client library.
%package devel
Summary: Development files for lib%{name}
License: LGPL-2.1+
Group: Development/Libraries/C and C++
Requires: libudisks2-0 = %{version}
%description devel
This package contains the development files for the library lib%{name}, a
dynamic library, which provides access to the udisksd daemon.
%lang_package
%prep
%setup -q -n udisks-%{version}
%patch1 -p1
%patch2 -p1
%patch3 -p1
#%patch4 -p0
%build
autoreconf
%configure \
--sysconfdir=/etc \
--enable-gtk-doc
make %{?_smp_mflags}
%install
make install DESTDIR=%{buildroot}
find %{buildroot} -name \*.la -o -name \*.a | xargs rm
chrpath --delete %{buildroot}/%{_sbindir}/umount.udisks2
chrpath --delete %{buildroot}/%{_bindir}/udisksctl
chrpath --delete %{buildroot}/%{_libexecdir}/udisks2/udisksd
%find_lang udisks2
#we don't want to load storaged modules
rm -r %{buildroot}/etc/udisks2
%pre
%service_add_pre udisks2.service
%post -n %{name}
%{?udev_rules_update:%udev_rules_update}
%service_add_post udisks2.service
%post -n libudisks2-0 -p /sbin/ldconfig
%preun
%service_del_preun udisks2.service
%postun
%service_del_postun udisks2.service
%postun -n libudisks2-0 -p /sbin/ldconfig
%files
%defattr(-,root,root,-)
%doc README.md AUTHORS NEWS HACKING COPYING
%dir %{_libexecdir}/udisks2
%{_libexecdir}/udisks2/udisksd
%config %{_sysconfdir}/dbus-1/system.d/org.freedesktop.UDisks2.conf
%{_datadir}/bash-completion/completions/udisksctl
%{_unitdir}/udisks2.service
%dir %{_udevrulesdir}
%{_udevrulesdir}/80-udisks2.rules
%{_sbindir}/umount.udisks2
%dir %{_libexecdir}/udisks2
%{_libexecdir}/udisks2/udisksd
%{_bindir}/udisksctl
%{_mandir}/man1/udisksctl.1*
%{_mandir}/man5/udisks2.conf.5*
%{_mandir}/man8/udisksd.8*
%{_mandir}/man8/udisks.8*
%{_mandir}/man8/umount.udisks2.8*
%{_datadir}/polkit-1/actions/org.freedesktop.UDisks2.policy
%{_datadir}/dbus-1/system-services/org.freedesktop.UDisks2.service
# Permissions for local state data are 0700 to avoid leaking information
# about e.g. mounts to unprivileged users
%attr(0700,root,root) %dir %{_localstatedir}/lib/udisks2
%files -n libudisks2-0
%defattr(-,root,root,-)
%{_libdir}/libudisks2.so.*
%files -n typelib-1_0-UDisks-2_0
%defattr(-,root,root,-)
%{_libdir}/girepository-1.0/UDisks-2.0.typelib
%files devel
%defattr(-,root,root,-)
%{_libdir}/libudisks2.so
%dir %{_includedir}/udisks2
%dir %{_includedir}/udisks2/udisks
%{_includedir}/udisks2/udisks/*.h
%{_datadir}/gir-1.0/UDisks-2.0.gir
%doc %{_datadir}/gtk-doc/html/udisks2/
%{_libdir}/pkgconfig/udisks2.pc
%files lang -f udisks2.lang
%changelog