File liblastfm.spec of Package liblastfm-qt4

#
# spec file for package liblastfm
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
# Copyright (c) 2009 Buschmann <buschmann23@opensuse.org>
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%define _soversion 1
Name:           liblastfm
Version:        1.1.0
Release:        0
Summary:        A Qt C++ Library for the Last.fm Webservices
License:        GPL-3.0+
Group:          System/Libraries
Url:            https://github.com/lastfm/liblastfm/
# https://github.com/lastfm/liblastfm/archive/1.0.7.tar.gz
Source0:        %{name}-%{version}.tar.gz
# PATCH-FIX-UPSTREAM
Patch0:         0001-Stick-to-c-14-for-liblastfm.patch
BuildRequires:  cmake
BuildRequires:  fftw3-devel
BuildRequires:  kde4-filesystem
BuildRequires:  libqt4-devel >= 4.8.0
BuildRequires:  libsamplerate-devel
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
liblastfm is a collection of libraries to help you integrate Last.fm services
into your rich desktop software. It is officially supported software developed
by Last.fm staff.

%package -n liblastfm%{_soversion}
Summary:        A Qt C++ Library for the Last.fm Webservices
Group:          System/Libraries

%description -n liblastfm%{_soversion}
liblastfm is a collection of libraries to help you integrate Last.fm services
into your rich desktop software. It is officially supported software developed
by Last.fm staff.

%package -n liblastfm-devel
Summary:        Development Files for the Last.fm Webservices
Group:          Development/Libraries/C and C++
Requires:       liblastfm%{_soversion} = %{version}
Requires:       libqt4-devel

%description -n liblastfm-devel
liblastfm is a collection of libraries to help you integrate Last.fm services
into your rich desktop software. It is officially supported software developed
by Last.fm staff.

This package contains development files for liblastfm.

%prep
%setup -q
%patch0 -p1

%build
%cmake_kde4 -d build -- -DBUILD_WITH_QT4=ON
%make_jobs

%install
%kde4_makeinstall -C build

%post -n liblastfm%{_soversion} -p /sbin/ldconfig
%postun -n liblastfm%{_soversion} -p /sbin/ldconfig

%files -n liblastfm%{_soversion}
%defattr(-,root,root,-)
%{_libdir}/liblastfm.so.%{_soversion}*
%{_libdir}/liblastfm_fingerprint.so.%{_soversion}*

%files -n liblastfm-devel
%defattr(-,root,root,-)
%doc COPYING
%{_libdir}/liblastfm.so
%{_libdir}/liblastfm_fingerprint.so
%{_includedir}/lastfm

%changelog
openSUSE Build Service is sponsored by