File marble.spec of Package marble4
#
# spec file for package marble
#
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%define _so 21
Name: marble
Version: 15.04.3
Release: 0
Summary: Generic map viewer
License: LGPL-2.1+
Group: Amusements/Teaching/Other
Url: http://edu.kde.org
Source0: %{name}-%{version}.tar.xz
# PATCH-FIX-OPENSUSE do_not_build_qtonly_and_mobile.diff do not build qt-only version and mobile version
Patch0: do_not_build_qtonly_and_mobile.diff
# PATCH-FIX-UPSTREAM
Patch1: Changing-nominatim-to-https.patch
# PATCH-FIX-UPSTREAM
Patch2: Fix-build-with-gpsd-3.20.patch
# PATCH-FIX-UPSTREAM
Patch3: Fix-build-with-gpsd-3.21.patch
# PATCH-FIX-UPSTREAM
Patch4: Fix-build-with-gpsd-3.23.1.patch
BuildRequires: fdupes
%if 0%{suse_version} > 1500 || 0%{?sle_version} >= 150600
# Adapt to gpsd packaging changes (boo#1215444)
# marble4 fails to build without gps-qt5-devel because it needs the include file libgpsmm.h.
# It doesn't actually link to libQgpsmm though, so the Qt5 dependency shouldn't be a problem...
# Actually, libgpsmm.h (and libgpsmm.3.man) should maybe rather be in gpsd-devel
# because it is also needed for the built-in libgpsmm (part of libgps) which is *not* Qt-based.
BuildRequires: pkgconfig(Qgpsmm)
BuildRequires: pkgconfig(libgps)
%else
BuildRequires: gpsd-devel
%endif
BuildRequires: libkde4-devel
BuildRequires: libshp-devel
BuildRequires: perl
BuildRequires: quazip-qt4-devel
BuildRequires: xz
Requires: %{name}-data = %{version}
Requires: libastro1 = %{version}
Requires: libmarblewidget%{_so} = %{version}
Recommends: %{name}-doc = %{version}
Provides: kde4-marble = 4.3.0
Obsoletes: kde4-marble < 4.3.0
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%kde4_runtime_requires
%description
Marble is a viewer of map data.
%package data
Summary: Generic map viewer: data
Group: Amusements/Teaching/Other
Requires: %{name} = %{version}
Provides: kde4-marble-data = 4.3.0
Obsoletes: kde4-marble-data < 4.3.0
BuildArch: noarch
%description data
Marble is a viewer of map data. This package contains its data.
%package devel
Summary: Generic map viewer: Build Environment
Group: Development/Libraries/KDE
Requires: libmarblewidget%{_so} = %{version}
Provides: kde4-marble-devel = 4.3.0
Obsoletes: kde4-marble-devel < 4.3.0
%description devel
Development headers and libraries for Marble.
%package doc
Summary: Marble documentation
Group: Amusements/Teaching/Other
Requires: %{name} = %{version}
BuildArch: noarch
%description doc
Marble is a viewer of map data. This package contains its documentation.
%package -n libmarblewidget%{_so}
Summary: Generic map viewer: Shared Library
Group: Development/Libraries/KDE
%description -n libmarblewidget%{_so}
The shared library for the MarbleWidget shared library.
%package -n libastro1
Summary: Astronomy: Shared Library
Group: Development/Libraries/KDE
%description -n libastro1
The Astronomy shared library for the MarbleWidget shared library.
%prep
%setup -q
%patch -P0
%patch -P1 -p1
%patch -P2 -p1
%patch -P3 -p1
%patch -P4 -p1
%build
%ifarch ppc ppc64
export RPM_OPT_FLAGS="%{optflags} -mminimal-toc"
%endif
%cmake_kde4 -d build
%make_jobs
%install
%kde4_makeinstall -C build
%kde_post_install
%fdupes -s %{buildroot}
#remove additional desktop files as they cause multiple non distinguishable entries in the homerun (https://bugs.kde.org/show_bug.cgi?id=327405#c8) or even a single random entry in kickoff
rm -rf %{buildroot}/usr/share/applications/kde4/marble-touch.desktop
%post -n libmarblewidget%{_so} -p /sbin/ldconfig
%postun -n libmarblewidget%{_so} -p /sbin/ldconfig
%post -n libastro1 -p /sbin/ldconfig
%postun -n libastro1 -p /sbin/ldconfig
%files
%defattr(-,root,root)
%doc CREDITS ChangeLog COPYING* LICENSE* MANIFESTO.txt
%dir %{_kde4_datadir}/appdata
%dir %{_kde4_libdir}/qt4/plugins/imports/org
%dir %{_kde4_libdir}/qt4/plugins/imports/org/kde/
%dir %{_kde4_libdir}/qt4/plugins/imports/org/kde/edu/
%exclude %{_kde4_appsdir}/marble/data
%{_kde4_applicationsdir}/marble.desktop
%{_kde4_applicationsdir}/marble_gpx.desktop
%{_kde4_applicationsdir}/marble_kml.desktop
%{_kde4_applicationsdir}/marble_osm.desktop
%{_kde4_applicationsdir}/marble_kmz.desktop
%{_kde4_applicationsdir}/marble_geo.desktop
%{_kde4_applicationsdir}/marble_shp.desktop
%{_kde4_applicationsdir}/marble_worldwind.desktop
%{_kde4_appsdir}/marble/
%{_kde4_bindir}/marble*
#{_kde4_bindir}/routing-instructions
#{_kde4_bindir}/tilecreator
%{_kde4_configkcfgdir}/marble.kcfg
%{_kde4_datadir}/appdata/marble.appdata.xml
%{_kde4_datadir}/mime/packages/geo.xml
%{_kde4_iconsdir}/hicolor/*/apps/marble.*
%{_kde4_libdir}/qt4/plugins/imports/org/kde/edu/marble/
%{_kde4_modulesdir}/libmarble_part.so
%{_kde4_modulesdir}/marblethumbnail.so
%{_kde4_modulesdir}/plasma_applet_worldclock.so
%{_kde4_modulesdir}/plasma_runner_marble.so
%{_kde4_modulesdir}/plugins/designer/*
%{_kde4_modulesdir}/plugins/marble/
%{_kde4_servicesdir}/*.desktop
%files devel
%defattr(-,root,root)
%doc BUGS CODING
%{_includedir}/marble/
%{_includedir}/astro/
%{_kde4_libdir}/libmarblewidget.so
%{_kde4_libdir}/libastro.so
%{_kde4_appsdir}/cmake/modules/FindMarble.cmake
%files data
%defattr(-,root,root)
%{_kde4_appsdir}/marble/data
%files doc
%defattr(-,root,root)
%{_kde4_htmldir}/en/marble/
%files -n libmarblewidget%{_so}
%defattr(-,root,root)
%{_kde4_libdir}/libmarblewidget.so.*
%files -n libastro1
%defattr(-,root,root)
%{_kde4_libdir}/libastro.so.*
%changelog