File be-compatible-with-backward-0.26.patch of Package digikam

From 16e452c62a81f1b70844c97f18137a004ab08b65 Mon Sep 17 00:00:00 2001
From: Gilles Caulier <caulier.gilles@gmail.com>
Date: Sun, 7 Oct 2018 11:32:44 +0200
Subject: be compatible with backward 0.26

---
 core/cmake/modules/FindExiv2.cmake | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

(limited to 'core/cmake/modules/FindExiv2.cmake')

diff --git a/core/cmake/modules/FindExiv2.cmake b/core/cmake/modules/FindExiv2.cmake
index 02d2943..2fcee5b 100644
--- a/core/cmake/modules/FindExiv2.cmake
+++ b/core/cmake/modules/FindExiv2.cmake
@@ -73,7 +73,9 @@ if (EXIV2_INCLUDE_DIR  AND NOT  EXIV2_VERSION)
     string(REGEX MATCH "#define EXIV2_PATCH_VERSION +\\( *([0-9]+) *\\)"  _dummy "${EXIV2_VERSION_CONTENT}")
     set(EXIV2_VERSION_PATCH "${CMAKE_MATCH_1}")
 
-    if(EXIV2_VERSION_MAJOR AND EXIV2_VERSION_MINOR AND EXIV2_VERSION_PATCH)
+    if(NOT "${EXIV2_VERSION_MAJOR}" STREQUAL "" AND
+       NOT "${EXIV2_VERSION_MINOR}" STREQUAL "" AND
+       NOT "${EXIV2_VERSION_PATCH}" STREQUAL "")
 
         set(EXIV2_VERSION "${EXIV2_VERSION_MAJOR}.${EXIV2_VERSION_MINOR}.${EXIV2_VERSION_PATCH}"
             CACHE STRING "Version number of Exiv2" FORCE)
-- 
cgit v1.1

openSUSE Build Service is sponsored by