File libqt4-devel-doc-data.spec of Package libqt4-sql-plugins

#
# spec file for package libqt4-devel-doc-data
#
# Copyright (c) 2014 ownCloud GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes, issues or comments via http://github.com/owncloud/mirall/issues
#

# norootforbuild
# nodebuginfo

%define _prefix /opt/qt-4.8
%define packageprefix opt-

Name:           %{packageprefix}libqt4-devel-doc-data
BuildRequires:  cups-devel freeglut-devel freetype2-devel %{packageprefix}libQtWebKit-devel %{packageprefix}libqt4-devel pkgconfig
BuildRequires:  alsa-devel gtk2-devel %{packageprefix}libqt4-sql-sqlite openssl-devel sqlite-devel
%if 0%{?suse_version}
BuildRequires:  fdupes update-desktop-files
%endif
# COMMON-VERSION-BEGIN
# COMMON-VERSION-BEGIN
Version:        4.8.6
Release:        1
%define base_name opt-libqt4
%define x11_free  -everywhere-opensource-src-
%define rversion 4.8.6
# COMMON-VERSION-END
# COMMON-VERSION-END
Url:            http://qt.digia.com
License:        QPL, GPL
Group:          System/Libraries
AutoReqProv:    on
Summary:        Qt documentation (architecture independent files)
BuildArch:      noarch
%requires_eq    %{packageprefix}libqt4
# COMMON-BEGIN
# COMMON-BEGIN
Source:         qt%x11_free%rversion.tar.bz2
# to get mtime of file:
Source1:        libqt4.changes
Source2:        baselibs.conf
Source10:       qt4config.desktop
Source11:       designer4.desktop
Source12:       linguist4.desktop
Source13:       assistant4.desktop
Source14:       assistant.png
Source15:       designer.png
Source16:       linguist.png
Source17:       qt-4.8-env.sh
Patch2:         qt-never-strip.diff
Patch3:         plastik-default.diff
Patch6:         use-freetype-default.diff
Patch1006:      use-freetype-default-legacy.diff
Patch8:         link-tools-shared.diff
Patch39:        0191-listview-alternate-row-colors.diff
Patch40:        0188-fix-moc-parser-same-name-header.diff
Patch41:        konsole-nvidia-font-speed.diff
Patch43:        0195-compositing-properties.diff
Patch60:        0180-window-role.diff
Patch61:        qt4-fake-bold.patch
Patch70:        0225-invalidate-tabbar-geometry-on-refresh.patch
Patch75:        qt-debug-timer.diff
Patch87:        qfatal-noreturn.diff
Patch101:       no-moc-date.diff
Patch102:       0253-qmake_correct_path_separators.diff
Patch107:       webkit-ia64_s390x.patch
Patch109:       libqt4-libtool-nodate.diff
Patch113:       ppc64-webkit-link-fix.diff
Patch118:       rcc-stable-dirlisting.diff
Patch119:       hppa_ldcw_fix.diff
Patch120:       hppa_unaligned_access_fix_458133.diff
Patch121:       webkit-sparc64.diff
Patch123:       use-cups-default-print-settings-bnc552218.diff

BuildRoot:      %{_tmppath}/%{name}-%{version}-build
  %define common_options --opensource -fast -no-separate-debug-info -shared -xkb -xrender -xcursor -dbus-linked -xfixes -xrandr -xinerama -sm -no-nas-sound -no-rpath -system-libjpeg -system-libpng -accessibility -cups -stl -nis -system-zlib -prefix %_prefix -L %_libdir -libdir %_libdir -docdir %_docdir/%{base_name} -examplesdir %_libdir/qt4/examples -demosdir %_libdir/qt4/demos -plugindir %plugindir -translationdir %_datadir/qt4/translations -iconv -sysconfdir /etc/settings -datadir %_datadir/qt4/ -no-pch -reduce-relocations -exceptions -system-libtiff -glib -optimized-qmake -no-webkit -no-xmlpatterns -system-sqlite -qt3support -no-sql-mysql -importdir %plugindir/imports  -xsync -xinput -gtkstyle
%define check_config \
  grep '# define' src/corelib/global/qconfig.h | egrep -v 'QT_(ARCH|USE)';             \
  if test -f %_datadir/qt4/mkspecs/qconfig.pri ; then                                 \
    cmp %_datadir/qt4/mkspecs/qconfig.pri mkspecs/qconfig.pri || exit 1;           \
  fi                                                                                   \

%description
Qt is a set of libraries for developing applications.

This package contains base tools, like string, xml, and network
handling.



Authors:
--------
    Qt Software

%prep
%define plugindir %_libdir/qt4/plugins
%setup -q -n qt%x11_free%rversion
%patch2
%patch3
%if %suse_version > 1010
%patch6
%else
%patch1006
%endif
# needs rediffing
#%patch8
%patch39
%patch40
%patch41
%patch43
# ### 47 rediff
# %patch60
# bnc#374073 comment #8
# %patch61
%patch70
%patch75
%patch87
%patch101
# ### 47 rediff
# %patch102
# ### 47 rediff
# %patch107
%patch109
#%patch113
%patch118 -p1
%ifarch hppa
%patch119
%patch120
%endif
%patch123
# ### 47 rediff
#%patch121 -p1
# be sure not to use them
rm -rf src/3rdparty/{libjpeg,freetype,libpng,zlib,libtiff,fonts}
# COMMON-END
# COMMON-END

%build
export QTDIR=$PWD
export PATH=$PWD/bin:$PATH
export LD_LIBRARY_PATH=$PWD/lib/:%_libdir
export CXXFLAGS="$RPM_OPT_FLAGS"
export CFLAGS="$RPM_OPT_FLAGS"
%if %suse_version > 910
  OPTIONS="-system-sqlite"
%else
  OPTIONS=""
%endif
export MAKEFLAGS="%{?_smp_mflags}"
%ifarch sparc64
platform="-platform linux-g++-64"
%else
platform=""
%endif
echo yes | ./configure %common_options $platform $OPTIONS \
	-plugin-sql-sqlite -nomake demos -xmlpatterns -webkit
%check_config
%if 0
pushd src
make %{?_smp_mflags} sub-moc sub-rcc sub-uic
popd
pushd tools
make %{?_smp_mflags} sub-assistant
popd
pushd tools/qdoc3
make %{?_smp_mflags}
popd
%else # simply use the binaries from the -devel package instead of building it again
rpm -ql %{packageprefix}libqt4-devel | grep %{_bindir}/ | sed 's#%{_bindir}/##' | \
    ( while read file; do test -e bin/$file || ln -s %{_bindir}/$file bin/ ; done )
rpm -ql %{packageprefix}libqt4-devel | grep %{_libdir}/lib | sed 's#%{_libdir}/##' | \
    ( while read file; do test -e lib/$file || ln -s %{_libdir}/$file lib/ ; done )
rpm -ql %{packageprefix}libQtWebKit-devel | grep %{_bindir}/ | sed 's#%{_bindir}/##' | \
    ( while read file; do test -e bin/$file || ln -s %{_bindir}/$file bin/ ; done )
rpm -ql %{packageprefix}libQtWebKit-devel | grep %{_libdir}/lib | sed 's#%{_libdir}/##' | \
    ( while read file; do test -e lib/$file || ln -s %{_libdir}/$file lib/ ; done )
make %{?_smp_mflags} sub-tools-bootstrap
%endif
test -d doc/qch || make %{?_smp_mflags} docs
./config.status

%install
export QTDIR=$PWD
# htmldocs are not generated - why?
for d in docimages qchdocs htmldocs ; do
  make INSTALL_ROOT=$RPM_BUILD_ROOT install_${d}
done

#mkdir -p $RPM_BUILD_ROOT/%_docdir/%base_name/html
#for d in html-api html-assistant html-designer html-linguist html-qmake; do
#  for f in doc/$d/*; do
#    test -f $f && install -m 644 $f  $RPM_BUILD_ROOT/%_docdir/%base_name/html
#  done
#done
rm -rf $RPM_BUILD_ROOT/%_prefix/{bin,%_lib}

# remove some executable flags from image files:
find $RPM_BUILD_ROOT/usr/share -name "*.png" -print0 | xargs -0 chmod a-x

# hardlink duplicates:
%if 0%{?suse_version}
%fdupes %{buildroot}/usr/share/doc/packages/%base_name
%endif

%clean
rm -rf $RPM_BUILD_ROOT
# no baselibs supplements for older distros
%if %suse_version < 1110
  sed -i -e 's, supplements .*,,' $RPM_SOURCE_DIR/baselibs.conf
%endif

%files
%defattr(-,root,root,755)
%dir /usr/share/doc/packages/%base_name  
/usr/share/doc/packages/%base_name/qch  
/usr/share/doc/packages/%base_name/html*  
/usr/share/doc/packages/%base_name/src  

%changelog
openSUSE Build Service is sponsored by