File goldendict-master.spec of Package goldendict-qwebengine-port

#
# spec file for package goldendict
#
# Copyright (c) 2012-2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
# Copyright 2013 Tvangeste <i.4m.l33t@yandex.ru>
# Copyright 2011-2021 <opensuse.lietuviu.kalba@gmail.com>
# Copyright 2021 <coder53@gmail.com>
# Copyright 2008-2009 Buschmann <buschmann23@opensuse.org>
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
#
# Please submit bugfixes or comments via http://bugs.opensuse.org/
# 

Name:           goldendict
Summary:        Dictionary Lookup Program
License:        GPL-3.0-or-later
Group:          Productivity/Office/Dictionary
Url:            http://goldendict.org/
Version:        1.5.0~rc2+git.20211127T220443
Release:        0
Source0:        goldendict-%{version}.tar.xz
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%if 0%{?suse_version}
BuildRequires:  update-desktop-files
%endif
BuildRequires:  desktop-file-utils
BuildRequires:  gcc-c++
BuildRequires:  git
BuildRequires:  hunspell-devel >= 1.2.4
BuildRequires:  libtiff-devel
BuildRequires:  pkgconfig(libzip)
BuildRequires:  lzo-devel
BuildRequires:  pkgconfig(vorbis)
BuildRequires:  pkgconfig(xtst)
BuildRequires:  pkgconfig(zlib)
BuildRequires:  unzip
BuildRequires:  xz
# Qt 5
BuildRequires:  pkgconfig(Qt5Core)
BuildRequires:  pkgconfig(Qt5Gui)
BuildRequires:  pkgconfig(Qt5Help)
BuildRequires:  pkgconfig(Qt5Multimedia)
BuildRequires:  pkgconfig(Qt5Network)
BuildRequires:  pkgconfig(Qt5PrintSupport)
BuildRequires:  pkgconfig(Qt5Sql)
BuildRequires:  pkgconfig(Qt5Svg)
BuildRequires:  pkgconfig(Qt5WebEngineWidgets)
BuildRequires:  pkgconfig(Qt5Widgets)
BuildRequires:  pkgconfig(Qt5X11Extras)
BuildRequires:  pkgconfig(Qt5Xml)
BuildRequires:  pkgconfig(x11)
# bzip2/bz2
%if 0%{?suse_version}
BuildRequires:  libbz2-devel
%else
BuildRequires:  bzip2-devel
%endif
# AV
%if 0%{?suse_version} > 1320 || ( 0%{?suse_version} == 1315 && 0%{?is_opensuse} )
BuildRequires:  libao-devel
BuildRequires:  pkgconfig(libavformat)
#BuildRequires:  libavutil-devel
#BuildRequires:  libffmpeg-devel
%endif
# eb-devel / libeb-dev for epwing. Otherwise use "CONFIG+=no_epwing_support"
%if 0%{?is_opensuse} || 0%{?suse_version} || 0%{?fedora_version} || 0%{?mageia}
BuildRequires:  eb-devel
%endif
# Zstd compression required for optional ZIM format support. It can be enabled by "CONFIG+=zim_support"
%if 0%{?suse_version} > 1320
BuildRequires:  pkgconfig(libzstd)
%endif



%description
Feature-rich dictionary lookup program.
    * Support of multiple dictionary file formats:
      * Babylon .BGL files
      * StarDict .ifo/.dict/.idx/.syn dictionaries
      * Dictd .index/.dict(.dz) dictionary files
      * ABBYY Lingvo .dsl source files
      * ABBYY Lingvo .lsa/.dat audio archives
    * Support for Wikipedia, Wiktionary or any other MediaWiki-based sites
    * Scan popup functionality. A small window pops up with translation of a
      word chosen from antoher application.
    * Full-text search.
    * And much more...

Author:
-------
    Konstantin Isakov

%if 0%{?suse_version}
%lang_package
%else
%package lang
Summary:        Translations for package %{name}
License:        GPL-3.0-or-later

%description lang
This subpackage provides translations for Goldendict.
%endif

%prep
%setup -n goldendict-%{version} -q 
git init 
%if 0%{?suse_version} < 1550
  # For Qt5.12 compatibility in openSUSE Leap 15.3
  find -name '*.cc' -exec sed -i 's/Qt::SkipEmptyParts/QString::SkipEmptyParts/g' {} +
  find -name '*.cc' -exec sed -i 's/errorOccurred/error/g' {} +
%endif

%build
%if 0%{?suse_version}
    %if 0%{?is_opensuse}
      %qmake5 \
        PREFIX=%{_prefix} \
        %if 0%{?sle_version} < 150000
        "CONFIG+=old_hunspell" \
        %endif
        %if 0%{?suse_version} > 1320
        "CONFIG+=zim_support" \
        %endif
        goldendict.pro
      %make_jobs
    %else
      %qmake5 \
        PREFIX=%{_prefix} "CONFIG+=no_ffmpeg_player" \
        %if 0%{?sle_version} < 150000
        "CONFIG+=old_hunspell" \
        %endif
        %if 0%{?suse_version} > 1320
        "CONFIG+=zim_support" \
        %endif
        goldendict.pro
      %make_jobs
    %endif
%endif
# Workaround for error: Empty %files file debugsourcefiles.list
%if 0%{?fedora_version} || 0%{?mageia}
%global debug_package %{nil}
%endif
%if 0%{?mageia}
  qmake-qt5 PREFIX=/usr "CONFIG+=no_ffmpeg_player" "CONFIG+=old_hunspell" goldendict.pro && make clean && make
%endif

%install
%if 0%{?suse_version}
  %if 0%{?suse_version} > 1320 || ( 0%{?suse_version} == 1315 && 0%{?is_opensuse} ) || ( 0%{?suse_version} == 1315 && 0%{?sle_version} >= 120200)
    %qmake5_install
  %else
    INSTALL_ROOT=%{buildroot} %makeinstall
  %endif
  %suse_update_desktop_file -r org.goldendict.GoldenDict Office Dictionary
%endif
%if 0%{?fedora_version} || 0%{?rhel_version} || 0%{?centos_version} || 0%{?mageia}
   rm -rf %{buildroot}
   make install DESTDIR=%buildroot INSTALL_ROOT=%{buildroot} INSTALL="install -p"
%endif
%if 0%{?suse_version} <= 1320
   mv %{buildroot}%_datadir/metainfo %{buildroot}%_datadir/appdata
%endif

%clean
  rm -rf $RPM_BUILD_ROOT

%files
%defattr(644,root,root,755)
%if 0%{?suse_version} >= 1500
%license LICENSE.txt
%else
%doc LICENSE.txt
%endif
%defattr(755,root,root,755)
%_bindir/%{name}
%defattr(644,root,root,755)
%_datadir/%{name}
%_datadir/applications/org.goldendict.GoldenDict.desktop
%if 0%{?suse_version} <= 1310 || ( 0%{?suse_version} == 1315 && 0%{?sle_version} <= 120100)
%dir %_datadir/appdata
%endif
%if 0%{?suse_version} <= 1320
%_datadir/appdata/org.goldendict.GoldenDict.metainfo.xml
%else
%_datadir/metainfo/org.goldendict.GoldenDict.metainfo.xml
%endif
%_datadir/pixmaps/%{name}.png
%exclude %{_datadir}/%{name}/locale/

%files lang
%{_datadir}/%{name}/locale/

%changelog
openSUSE Build Service is sponsored by