File cfengine.spec of Package cfengine

#
# spec file for package cfengine (Version 2.2.2)
#
# Copyright (c) 2007 SUSE LINUX Products GmbH, Nuernberg, Germany.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild

Name:           cfengine
BuildRequires:  bison db-devel flex openssl-devel
License:        GPL v2 or later
Group:          Productivity/Networking/System
AutoReqProv:    on
Version:        2.2.2
Release:        1
Summary:        A Tool to Maintain Complicated Networks
Url:            http://www.cfengine.org/
Source:         %{name}-%{version}.tar.bz2
Source2:        cfenvd
Source3:        cfexecd
Source4:        cfservd
Patch:          %{name}-%{version}-ia64.dif
Patch3:         %{name}-%{version}-chflags.dif
Patch4:         %{name}-%{version}-automake.dif
Patch5:         %{name}-%{version}-strict-aliasing-fix.diff
Patch7:         %{name}-%{version}-printf.diff
Patch9:         %{name}-%{version}-overflow.diff
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
PreReq:         %install_info_prereq

%description
GNU cfengine is an abstract programming language for system
administrators of huge heterogeneous networks. With cfengine, system
administrators have an easy and elegant way to maintain complicated
networks.



Authors:
--------
    Mark Burgess

%prep
%setup -q
%patch
%patch3
%patch4
%patch5
%patch7
%patch9

%build
%{suse_update_config -f}
autoreconf -fi
CC=gcc CFLAGS="$RPM_OPT_FLAGS" \
  ./configure --prefix=/usr \
	      --with-docs \
	      --libdir=%{_libdir} \
              --mandir=%{_mandir} \
              --infodir=%{_infodir} \
              --datadir=%{_defaultdocdir}
make

%install
make "DESTDIR=$RPM_BUILD_ROOT" install
install -d  $RPM_BUILD_ROOT/{usr/sbin,etc/init.d}
install -m 744 %{S:2} %{S:3} %{S:4} $RPM_BUILD_ROOT/etc/init.d/
ln -sf ../../etc/init.d/cfenvd $RPM_BUILD_ROOT/%{_sbindir}/rccfenvd
ln -sf ../../etc/init.d/cfexecd $RPM_BUILD_ROOT/%{_sbindir}/rccfexecd
ln -sf ../../etc/init.d/cfservd $RPM_BUILD_ROOT/%{_sbindir}/rccfservd
sed -i 's@-L/usr/src/packages/BUILD/cfengine-2.2.2/pub@@' $RPM_BUILD_ROOT/%{_libdir}/libcfengine.la 

%clean
[ -d %{buildroot} -a "%{buildroot}" != "" ] && rm -rf  %{buildroot}

%post
%install_info --info-dir=%{_infodir} %{_infodir}/%{name}-Anomalies.info.gz
%install_info --info-dir=%{_infodir} %{_infodir}/%{name}-Reference.info.gz
%install_info --info-dir=%{_infodir} %{_infodir}/%{name}-Tutorial.info.gz

%postun
%install_info_delete --info-dir=%{_infodir} %{_infodir}/%{name}-Anomalies.info.gz
%install_info_delete --info-dir=%{_infodir} %{_infodir}/%{name}-Reference.info.gz
%install_info_delete --info-dir=%{_infodir} %{_infodir}/%{name}-Tutorial.info.gz
%insserv_cleanup

%preun
%stop_on_removal /etc/init.d/cfenvd
%stop_on_removal /etc/init.d/cfservd
%stop_on_removal /etc/init.d/cfexecd

%files
%defattr(-,root,root)
%doc AUTHORS ChangeLog NEWS README COPYING TODO inputs/*.example
/usr/sbin/*
%{_libdir}/*
%doc %{_mandir}/man?/*
%doc %{_infodir}/*.info*
%attr(0755,root,root) %config /etc/init.d/*
%changelog
* Wed Nov 21 2007 - anicka@suse.cz
- update to 2.2.2
  * changes in build procedure, libtoolizing
  * beginning of an integrated auditing system added
  * SCLI interface modifications
- fix init scripts (remove X-United-Linux headers,
  add dependency to $remote_fs)
* Tue Jul 03 2007 - anicka@suse.cz
- add %%insserv_cleanup to %%postun
* Tue Jun 12 2007 - anicka@suse.cz
- update to 2.2.1
  * scli: type section added.
  * Code refactoring for package management.
  * Bug fixes for problems introduced in 2.2.0.
  * structural internal changes that ease the eventual
  confluence with cfengine 3
- fix overflowing buffer, uninitialized variable and
  other minor problems
- remove -configure.diff, fixed in upstream
* Fri Apr 20 2007 - aj@suse.de
- Cleanup build requires.
* Fri Mar 30 2007 - stbinner@suse.de
- add bison and flex to build requires
* Fri Feb 02 2007 - anicka@suse.cz
- update to 2.1.22
  * cfshow output formatting changes
  * database internal format changes
  * rewritten the checksum code, no caching anymore
  * ShowState(rootprocs), ShowState(otherprocs) added for
  better process reporting
  * General code reorganization for better separation of concerns,
  looking towards cfengine 3.
  * cfconvert removed. Change of future strategy for cfengine 3
  migration.
  * Support for old Berkeley DB APIs abandoned.
  * Encryption level added for full encryption of opendir traffic.
  Must set FullEncryption = ( true ) in control for compatability
  * bugfixes
* Wed Oct 18 2006 - anicka@suse.cz
- fix array subscript out of range (#211160)
* Thu Sep 21 2006 - anicka@suse.cz
- update to 2.1.21
  * copy action now supports this $(this) variable
  * PH support removed from cfenvd during code rationalization
  * ReturnsZeroShell function added
  * Cfenvd code rationalization and channge in database format
  * bugfixes
* Fri Jun 16 2006 - schwab@suse.de
- Fix syntax error in configure script.
* Fri May 19 2006 - anicka@suse.cz
- update to 2.1.20:
  - various minor bugfixes added
* Wed Jan 25 2006 - mls@suse.de
- converted neededforbuild to BuildRequires
* Thu Jan 05 2006 - anicka@suse.cz
- update to 2.1.17
* Tue Nov 15 2005 - anicka@suse.cz
- update to 2.1.17
- remove CAN-2005-2960 patch (affected file removed by upstream)
* Fri Oct 07 2005 - schwab@suse.de
- Don't strip binaries.
* Wed Oct 05 2005 - anicka@suse.cz
- fix too few arguments to a *printf function
* Tue Oct 04 2005 - anicka@suse.cz
- fix CAN-2005-2960 vulnerability (#120075)
- update to 2.1.16
* Mon Aug 01 2005 - anicka@suse.cz
- update to 2.1.15
* Fri Apr 22 2005 - postadal@suse.cz
- updated to version 2.1.14
* Sun Feb 13 2005 - ro@suse.de
- added libpng to nfb (for tetex)
* Thu Feb 03 2005 - postadal@suse.cz
- updated to version 2.1.13
- added init scripts (cfenvd, cfexecd, cfservd)
* Tue Aug 17 2004 - postadal@suse.cz
- updated to version 2.1.9
* Wed Feb 18 2004 - postadal@suse.cz
- updated to version 2.1.3
- removed obsoleted patch db.dif
- fixed code that broke strict aliasing
* Fri Jan 23 2004 - ro@suse.de
- fix build with current automake
  use another method to pass flags to MAKEINFOHTML
* Sat Jan 10 2004 - adrian@suse.de
- build as user
* Wed Aug 06 2003 - postadal@suse.cz
- updated to version 2.0.7p3
- removed obsoleted patch (info.diff)
* Mon May 12 2003 - ro@suse.de
- fix build with db-4.1
- fix compile: chflags function available does not mean
  struct stat has st_flags
* Thu Apr 24 2003 - ro@suse.de
- fix install_info --delete call and move from preun to postun
* Wed Feb 26 2003 - postadal@suse.cz
- used install-info macros
- fixed Anomalies.texinfo (dir entry)
* Tue Sep 17 2002 - ro@suse.de
- removed bogus self-provides
* Wed Jul 31 2002 - postadal@suse.cz
- update to version 2.0.3
  * Hpux config changes
  * new options
  * new list in cfservd.conf
  * a lot of fixes
* Fri Nov 23 2001 - cihlar@suse.cz
- added Url:
* Mon Nov 05 2001 - cihlar@suse.cz
- fixed to compile with automake 1.5
* Mon Apr 23 2001 - cihlar@suse.cz
- fixed warnings on ia64
* Tue Mar 06 2001 - cihlar@suse.cz
- update to version 1.6.3
* Mon Oct 30 2000 - cihlar@suse.cz
- update to version 1.6.0.a13
- bzipped sources
* Tue Oct 03 2000 - cihlar@suse.cz
- update to version 1.6.0.a11
* Mon May 15 2000 - cihlar@suse.cz
- Group sorted
- %%{_defaultdocdir} instead of /usr/doc/packages
* Mon Apr 10 2000 - bk@suse.de
- added suse update config macro
* Tue Apr 04 2000 - cihlar@suse.cz
- upgrade to version 1.5.4
- added BuildRoot
* Mon Jan 17 2000 - ro@suse.de
- update to 1.5.3 , man, info to /usr/share
* Mon Sep 13 1999 - bs@suse.de
- ran old prepare_spec on spec file to switch to new prepare_spec.
* Wed Sep 01 1999 - ro@suse.de
- update to 1.5.1 / specfile cleanup
* Tue Sep 22 1998 - ro@suse.de
- update to 1.4.12
* Mon Mar 02 1998 - florian@suse.de
- update to release 1.4.10
* Fri Oct 10 1997 - florian@suse.de
- update to release 1.4.8a
* Mon Jul 07 1997 - florian@suse.de
- update to release 1.4.0
* Thu Jan 02 1997 - florian@suse.de
- update to newest version 1.3.16
* Thu Jan 02 1997 - florian@suse.de
- Update auf neue Version 1.3.12.
openSUSE Build Service is sponsored by