File gdome2.spec of Package gdome2

#
# spec file for package gdome2 (Version 0.8.1)
#
# Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild


Name:           gdome2
Summary:        Gnome DOM Engine
License:        GPL v2 or later; LGPL v2.1 or later
Group:          System/Libraries
Version:        0.8.1
Release:        107
Url:            http://gdome2.cs.unibo.it/
Source:         %{name}-%{version}.tar.bz2
Patch:          gdome2-pkgconfig.patch
Patch1:         %{name}-%{version}.diff
BuildRequires:  glib2-devel libxml2-devel licenses pkg-config
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
The Document Object Model is a platform and language-neutral
   interface that will allow programs and scripts to dynamically
   access and update the content, structure and style of documents.
   A DOM implementation (also called a host implementation) is that
   piece of software which takes a parsed XML or HTML document and
   makes it available for processing via the DOM interfaces.
   Browsers contain a host implementation, for example. Here some
   key points about libgdome: * Libgdome is a DOM level2
   implementation.

* Libgdome supports "Core" and "XML" modules (DOM level2 Core
   Recommendation).

* Libgdome supports "Events" and "MutationEvents" modules (DOM
   level2 Events Recommendation).

* Libgdome is based on libxml2.

* Libgdome is written in C.

* The internal document representation is that libxml except for
   DocumentType, Entity and Notations interfaces.

* Libgdome is released under the GNU LGPL



Authors:
--------
    Raph Levien <raph@gimp.org>
    Ian Main <imain@gtk.org>
    Daniel Veillard <Daniel.Veillard@w3.org>
    Mathieu Lacage <mathieu@advogato.org>
    Anders Carlson <andersca@gnu.org>
    Paolo Casarini <paolo@casarini.org>
    Luca Padovani <lpadovani@cs.unibo.it>
    T.J. Mather <tjmather@tjmather.com>

%package -n libgdome0
License:        GPL v2 or later; LGPL v2.1 or later
Group:          System/Libraries
Summary:        Gnome DOM Engine
# Package with library in openSUSE <= 11.1:
Provides:       gdome = %{version}-%{release}
Obsoletes:      gdome < 0.8.1-108
Requires:       licenses

%description -n libgdome0
The Document Object Model is a platform and language-neutral
   interface that will allow programs and scripts to dynamically
   access and update the content, structure and style of documents.
   A DOM implementation (also called a host implementation) is that
   piece of software which takes a parsed XML or HTML document and
   makes it available for processing via the DOM interfaces.
   Browsers contain a host implementation, for example. Here some
   key points about libgdome: * Libgdome is a DOM level2
   implementation.

* Libgdome supports "Core" and "XML" modules (DOM level2 Core
   Recommendation).

* Libgdome supports "Events" and "MutationEvents" modules (DOM
   level2 Events Recommendation).

* Libgdome is based on libxml2.

* Libgdome is written in C.

* The internal document representation is that libxml except for
   DocumentType, Entity and Notations interfaces.

* Libgdome is released under the GNU LGPL



Authors:
--------
    Raph Levien <raph@gimp.org>
    Ian Main <imain@gtk.org>
    Daniel Veillard <Daniel.Veillard@w3.org>
    Mathieu Lacage <mathieu@advogato.org>
    Anders Carlson <andersca@gnu.org>
    Paolo Casarini <paolo@casarini.org>
    Luca Padovani <lpadovani@cs.unibo.it>
    T.J. Mather <tjmather@tjmather.com>

%package devel
License:        GPL v2 or later; LGPL v2.1 or later
Group:          Development/Libraries/C and C++
Requires:       libgdome0 = %{version} glib2-devel libxml2-devel
Summary:        Gnome DOM Engine

%description devel
The Document Object Model is a platform and language-neutral
   interface that will allow programs and scripts to dynamically
   access and update the content, structure and style of documents.
   A DOM implementation (also called a host implementation) is that
   piece of software which takes a parsed XML or HTML document and
   makes it available for processing via the DOM interfaces.
   Browsers contain a host implementation, for example. Here some
   key points about libgdome: * Libgdome is a DOM level2
   implementation.

* Libgdome supports "Core" and "XML" modules (DOM level2 Core
   Recommendation).

* Libgdome supports "Events" and "MutationEvents" modules (DOM
   level2 Events Recommendation).

* Libgdome is based on libxml2.

* Libgdome is written in C.

* The internal document representation is that libxml except for
   DocumentType, Entity and Notations interfaces.

* Libgdome is released under the GNU LGPL



Authors:
--------
    Raph Levien <raph@gimp.org>
    Ian Main <imain@gtk.org>
    Daniel Veillard <Daniel.Veillard@w3.org>
    Mathieu Lacage <mathieu@advogato.org>
    Anders Carlson <andersca@gnu.org>
    Paolo Casarini <paolo@casarini.org>
    Luca Padovani <lpadovani@cs.unibo.it>
    T.J. Mather <tjmather@tjmather.com>

%prep
%setup -q
%patch
%patch1

%build
autoreconf -f -i
%configure\
	--disable-static
make %{?jobs:-j%jobs}

%install
%makeinstall
for FILE in COPYING COPYING.LIB ; do
    MD5SUM=$(md5sum $FILE | sed 's/ .*//')
    if test -f /usr/share/doc/licenses/md5/$MD5SUM ; then
	ln -sf /usr/share/doc/licenses/md5/$MD5SUM $FILE
    fi
done
rm $RPM_BUILD_ROOT%{_libdir}/*.*a

%clean
rm -rf $RPM_BUILD_ROOT

%post -n libgdome0 -p /sbin/ldconfig

%postun -n libgdome0 -p /sbin/ldconfig

%files -n libgdome0
%defattr(-, root, root)
%doc AUTHORS COPYING COPYING.LIB README
%{_libdir}/lib*.so.*

%files devel
%defattr(-, root, root)
%{_includedir}/*
%{_bindir}/*-config
%{_datadir}/aclocal/gdome2.m4
%{_libdir}/*.so
%{_libdir}/gdomeConf.sh
%{_libdir}/pkgconfig/*.pc
%doc %{_mandir}/man1/gdome-config.1*

%changelog
* Wed Jan 28 2009 sbrabec@suse.cz
- Split according to shared library packaging rules.
- Removed .la file.
* Mon Dec 29 2008 coolo@suse.de
- fixed gdome-config --libs
* Tue Jul 17 2007 sbrabec@suse.cz
- Fixed licenses linking.
* Sat Jul 14 2007 lrupp@suse.de
- remove wrong libgdome0 name from filesection
* Fri Jul 13 2007 sbrabec@suse.cz
- Updated to version 0.8.1:
  * fixed dependencies
  * native glib2 support
* Tue Feb 13 2007 sbrabec@suse.cz
- Do not build unusable static libraries (#238552#c17).
* Fri Jan 12 2007 sbrabec@suse.cz
- Prefix changed to /usr.
* Mon Dec 04 2006 sbrabec@suse.cz
- Call autoreconf.
- Patch to declare glib2 support.
* Mon Oct 23 2006 sbrabec@suse.cz
- New SuSE package, version 0.8.0.
openSUSE Build Service is sponsored by