File koffice2.spec of Package koffice2

#
# spec file for package koffice2
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#



Name:           koffice2
BuildRequires:  ImageMagick-devel OpenEXR-devel aspell-devel doxygen graphviz libkdepimlibs4-devel
BuildRequires:  libpoppler-qt4-devel libpqxx-devel libqt4-devel-doc-data mysql-devel postgresql-devel python-devel
BuildRequires:  GraphicsMagick-devel gsl-devel libwpd-devel readline-devel ruby-devel sqlite-devel wv2-devel
BuildRequires:  glew-devel libeigen2-devel libexiv2-devel libgmm++-devel libqca2-devel libqimageblitz-devel pstoedit
BuildRequires:  fdupes fftw3-devel libkdcraw-devel libwpg-devel okular-devel oxygen-icon-theme
BuildRequires:  librcps-devel
%define with_gtl 0
%if %with_gtl
%if %suse_version > 1110
BuildRequires:  libqtgtl-devel opengtl-devel
%endif
%endif
%if %suse_version > 1130
BuildRequires:  libexif-devel
BuildRequires:  liblcms2-devel
%else
BuildRequires:  libexif
%endif
License:        GPLv2+ ; LGPLv2.1+
Group:          Productivity/Office/Suite
Summary:        Libraries and Base Files for the KDE Office Suite
Url:            http://www.koffice.org
Version:        2.3.1
Release:        4.<RELEASE2>
Source0:        koffice-%version.tar.bz2
Source1:        hi16-app-kexi.png
Source2:        hi22-app-kexi.png
Source3:        hi32-app-kexi.png
Source4:        hi48-app-kexi.png
Source5:        hisc-app-kexi.svgz
Patch2:         koffice_remove_python_shebangs.diff
Patch3:         libwpg020.diff
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%kde4_runtime_requires
%kde4_pimlibs_requires
Requires(post):     shared-mime-info
Requires(postun):   shared-mime-info
Requires:       kdepim4-runtime
Suggests:       koffice2-kword koffice2-kpresenter koffice2-kthesaurus 
Suggests:       koffice2-kplato koffice2-kformula
Suggests:       koffice2-karbon koffice2-krita koffice2-kspread koffice2-doc
Suggests:       create-resources
%if 0
Suggests:       koffice2-kexi koffice2-kivio
%endif
Obsoletes:      koffice2-kchart < 2.2.60
Provides:       koffice2-kchart

%description
Base files and libraries for KOffice applications. The applications are
in the sub-packages.



Authors:
--------
    The KOffice Team <koffice@kde.org>

%prep
%setup -q -n koffice-%version
%patch2
%patch3 -p1

cp %SOURCE1 kexi/pics
cp %SOURCE2 kexi/pics
cp %SOURCE3 kexi/pics
cp %SOURCE4 kexi/pics
cp %SOURCE5 kexi/pics

%build
  %cmake_kde4 -d build -- -DBUILD_f-office=false
  %make_jobs

%install
  cd build
  %makeinstall
  %create_subdir_filelist -d kplato -v devel
  %create_subdir_filelist -d kexi -v devel
  %create_subdir_filelist -d kformula -v devel
  %create_subdir_filelist -d krita -v devel
%if 0
  %create_subdir_filelist -d filters/krita -f krita -v devel
%endif
  %create_subdir_filelist -d kword -v devel
  %create_subdir_filelist -d filters/kword -f kword -v devel
  %create_subdir_filelist -d kspread -v devel
  %create_subdir_filelist -d filters/kspread -f kspread
  %create_subdir_filelist -d karbon -v devel
  %create_subdir_filelist -d filters/karbon -f karbon
%if 0
  %create_subdir_filelist -d kivio -v devel
%endif
  %create_subdir_filelist -d kpresenter -v devel
  cd ..
  sed -ri s,.*/usr/share/doc/kde/HTML/en/.*,, filelists/*
  %create_exclude_filelist
  rm -rf $RPM_BUILD_ROOT/usr/share/doc/kde/HTML/en
  %fdupes -s $RPM_BUILD_ROOT
  %suse_update_desktop_file kformula      Office WordProcessor
%if 0
  %suse_update_desktop_file kivio         Office FlowChart
%endif
  %suse_update_desktop_file kplato        Office ProjectManagement
  %suse_update_desktop_file kplatowork    Office ProjectManagement
  %suse_update_desktop_file -r krita      Graphics RasterGraphics
  %suse_update_desktop_file kspread       Office Spreadsheet
  %suse_update_desktop_file kword         Office WordProcessor
  %suse_update_desktop_file kpresenter    Office Presentation
  %suse_update_desktop_file KThesaurus    Office WordProcessor
  %suse_update_desktop_file -r karbon     Graphics VectorGraphics
  %suse_update_desktop_file kexi          Office Database
  %kde_post_install
  #rm -f $RPM_BUILD_ROOT/usr/share/applications/hildon/FreOffice.desktop
  #rm -f $RPM_BUILD_ROOT/usr/share/kde4/services/ServiceMenus/kexi_konqi.desktop
  rm -f $RPM_BUILD_ROOT/usr/share/kde4/services/ServiceMenus/kformula_konqi.desktop
  rm -f $RPM_BUILD_ROOT/usr/share/kde4/services/ServiceMenus/kivio_konqi.desktop
  for i in {16,32,48,64}; do
     mkdir -p $RPM_BUILD_ROOT/usr/share/icons/hicolor/"$i"x"$i"/apps
     cp %_kde4_iconsdir/oxygen/"$i"x"$i"/apps/karbon.png $RPM_BUILD_ROOT%_kde4_iconsdir/hicolor/"$i"x"$i"/apps/;
     cp %_kde4_iconsdir/oxygen/"$i"x"$i"/apps/kthesaurus.png $RPM_BUILD_ROOT%_kde4_iconsdir/hicolor/"$i"x"$i"/apps/;
  done
  for i in {16,22,32,48}; do
     mkdir -p $RPM_BUILD_ROOT%_kde4_iconsdir/hicolor/"$i"x"$i"/apps
     cp %_kde4_iconsdir/oxygen/"$i"x"$i"/apps/kexi.png $RPM_BUILD_ROOT%_kde4_iconsdir/hicolor/"$i"x"$i"/apps/;
  done

%post -p /sbin/ldconfig

%postun -p /sbin/ldconfig

%clean
  rm -rf $RPM_BUILD_ROOT
  rm -rf filelists

%package kthesaurus
License:        GPLv2+ ; LGPLv2.1+
Group:          Productivity/Office/Suite
Summary:        Related Words Lookup
%kde4_runtime_requires

%description kthesaurus
KThesaurus is the related words lookup application of the KDE office
suite.



Authors:
--------
    The KOffice Team <koffice@kde.org>

%post kthesaurus -p /sbin/ldconfig

%postun kthesaurus -p /sbin/ldconfig

%files kthesaurus
%defattr(-,root,root)
%doc COPYING COPYING.LIB README
%_kde4_modules/thesaurustool.so
%_kde_share_dir/services/thesaurustool.desktop
/usr/bin/kthesaurus
%_libdir/libkdeinit4_kthesaurus.so
%_kde4_applicationsdir/KThesaurus.desktop
%_kde4_appsdir/koffice/thesaurus
%_kde4_iconsdir/hicolor/*/apps/kthesaurus.*

%package kformula
License:        GPLv2+ ; LGPLv2.1+
Group:          Productivity/Office/Suite
Summary:        Tool for Creating Math Symbols and Formulas
%kde4_runtime_requires

%description kformula
KFormula is the math symbol and formulas application of the KDE office
suite.



Authors:
--------
    The KOffice Team <koffice@kde.org>

%post kformula -p /sbin/ldconfig

%postun kformula -p /sbin/ldconfig

%files kformula -f filelists/kformula
%defattr(-,root,root)
%doc COPYING COPYING.LIB README
%dir /usr/share/kde4/apps/formulashape
%dir /usr/share/kde4/apps/formulashape/fonts
#%_kde_share_dir/services/ServiceMenus/kformula_konqi.desktop

%package kword
License:        GPLv2+ ; LGPLv2.1+
Group:          Productivity/Office/Suite
Summary:        Word Processor
%kde4_runtime_requires

%description kword
KWord is the word processor application of the KDE office suite.



Authors:
--------
    The KOffice Team <koffice@kde.org>

%post kword -p /sbin/ldconfig

%postun kword -p /sbin/ldconfig

%files kword -f filelists/kword
%defattr(-,root,root)
%doc COPYING COPYING.LIB README
%dir %_kde4_appsdir/kword/html-odf
%_kde_share_dir/templates/.source/TextDocument.kwt
%_kde_share_dir/templates/TextDocument.desktop
%_kde_share_dir/services/ServiceMenus/kword_konqi.desktop
#%_kde4_appsdir/kword/kpartplugins/googledocs-kword.rc
%_kde4_appsdir/kword/kpartplugins/scan-kword.rc

%package kpresenter
License:        GPLv2+ ; LGPLv2.1+
Group:          Productivity/Office/Suite
Summary:        Application for Creating Presentations
%kde4_runtime_requires

%description kpresenter
KPresenter is the presentation application of the KDE office suite.

%post kpresenter -p /sbin/ldconfig

%postun kpresenter -p /sbin/ldconfig

%files kpresenter -f filelists/kpresenter
%defattr(-,root,root)
%doc COPYING COPYING.LIB README
%_kde_share_dir/templates/.source/Presentation.kpt
%_kde_share_dir/templates/Presentation.desktop
%_kde_share_dir/services/ServiceMenus/kpresenter_konqi.desktop
%_kde_share_dir/services/kpresenter_pptx_import.desktop
%dir %_kde4_appsdir/kpresenter/kpartplugins
#%_kde4_appsdir/kpresenter/kpartplugins/googledocs-kpresenter.rc
%_kde4_appsdir/kpresenter/kpartplugins/scan-kpresenter.rc
%_kde4_modules/Filterkpr2odf.so
%_kde4_modules/pptximport.so
%_kde_share_dir/services/Filterkpr2odf.desktop

%package kplato
License:        GPLv2+ ; LGPLv2.1+
Group:          Productivity/Office/Suite
Summary:        Project Management Application
%kde4_runtime_requires
%kde4_pimlibs_requires

%description kplato
KPlato is the project management application of the KDE office suite.

%post kplato -p /sbin/ldconfig

%postun kplato -p /sbin/ldconfig

%files kplato -f filelists/kplato
%defattr(-,root,root)
%doc COPYING COPYING.LIB README
%dir %_kde4_iconsdir/hicolor/45x45
%dir %_kde4_iconsdir/hicolor/45x45/mimetypes
# creates duplicates but avoids tons of duplicated %dir statements
%_kde4_appsdir/kplatowork

%package karbon
License:        GPLv2+ ; LGPLv2.1+
Group:          Productivity/Office/Suite
Summary:        Vector Drawing Application
Requires:       pstoedit
%kde4_runtime_requires

%description karbon
Karbon is the vector drawing application of the KDE office suite.

%post karbon -p /sbin/ldconfig

%postun karbon -p /sbin/ldconfig

%files karbon -f filelists/karbon
%defattr(-,root,root)
%doc COPYING COPYING.LIB README
%_kde_share_dir/templates/.source/Illustration.karbon
%_kde_share_dir/templates/Illustration.desktop
%_kde_share_dir/services/ServiceMenus/karbon_konqi.desktop
#/usr/%_lib/kde4/libkarbon1ximport.so
#/usr/%_lib/kde4/libkarbonepsimport.so
#/usr/%_lib/kde4/libkarbonpngexport.so
#/usr/%_lib/kde4/libkarbonsvgexport.so
#/usr/%_lib/kde4/libkarbonsvgimport.so
#/usr/%_lib/kde4/libwmfexport.so
#/usr/%_lib/kde4/libwmfimport.so
%_kde4_servicesdir/karbon_1x_import.desktop
%_kde4_servicesdir/karbon_eps_import.desktop
%_kde4_servicesdir/karbon_png_export.desktop
%_kde4_servicesdir/karbon_svg_export.desktop
%_kde4_servicesdir/karbon_svg_import.desktop
%_kde4_servicesdir/karbon_svgz_import.desktop
%_kde4_servicesdir/karbon_wmf_export.desktop
%_kde4_servicesdir/karbon_wmf_import.desktop
%_kde4_iconsdir/hicolor/*/apps/karbon.*
%if 0

%package kivio
License:        GPL v2 or later; LGPL v2.1 or later
Group:          Productivity/Office/Suite
Summary:        Flow Chart Drawing Application
%kde4_runtime_requires

%description kivio
Kivio is the flow chart drawing application of the KDE office suite.

%post kivio -p /sbin/ldconfig

%postun kivio -p /sbin/ldconfig

%files kivio -f filelists/kivio
%defattr(-,root,root)
%doc COPYING COPYING.LIB README
%_kde_share_dir/services/ServiceMenus/kivio_konqi.desktop
%endif

%package krita
License:        GPLv2+ ; LGPLv2.1+
Group:          Productivity/Office/Suite
Summary:        Image Manipulation Application
%kde4_runtime_requires

%description krita
Krita is the image manipulation application of the KDE office suite.

%post krita
/sbin/ldconfig
/usr/bin/update-mime-database %{_datadir}/mime &> /dev/null || :

%postun krita
/sbin/ldconfig
/usr/bin/update-mime-database %{_datadir}/mime &> /dev/null || :

%files krita -f filelists/krita
%defattr(-,root,root)
%doc COPYING COPYING.LIB README
%dir /usr/share/color/icc/krita
%dir %_kde4_appsdir/kritaplugins
%_kde_share_dir/services/ServiceMenus/krita_konqi.desktop
%_kde4_appsdir/krita/icons/*/*/actions/template_cmyk_empty.*
%_kde4_appsdir/krita/icons/*/*/actions/template_gray_empty.*
%dir %_kde4_appsdir/krita/kpartplugins
%_kde4_appsdir/krita/kpartplugins/scan-krita.rc
%dir %_kde4_appsdir/krita/templates/cmyk
%_kde4_appsdir/krita/templates/cmyk/.directory
%dir %_kde4_appsdir/krita/templates/cmyk/.source
%_kde4_appsdir/krita/templates/cmyk/.source/white_2000x800.kra
%_kde4_appsdir/krita/templates/cmyk/white_2000x800.desktop
%dir %_kde4_appsdir/krita/templates/gray
%_kde4_appsdir/krita/templates/gray/.directory
%dir %_kde4_appsdir/krita/templates/gray/.source
%_kde4_appsdir/krita/templates/gray/.source/white_640x480.kra
%_kde4_appsdir/krita/templates/gray/white_640x480.desktop
%dir %_kde4_appsdir/kritaplugins/metadataeditor

%package kexi
License:        GPLv2+ ; LGPLv2.1+
Group:          Productivity/Office/Suite
Summary:        Database Application
%kde4_runtime_requires

%description kexi
Kexi is the database application of the KDE office suite.

%post kexi -p /sbin/ldconfig

%postun kexi -p /sbin/ldconfig

%files kexi -f filelists/kexi
%defattr(-,root,root)
%doc COPYING COPYING.LIB README
%_kde4_iconsdir/hicolor/*/apps/kexi.*
%dir %_kde4_servicesdir/kexi
%dir %_kde4_servicesdir/kformdesigner
#%_kde_share_dir/services/ServiceMenus/kexi_konqi.desktop

%package kspread
License:        GPLv2+ ; LGPLv2.1+
Group:          Productivity/Office/Suite
Summary:        Spreadsheet application
%kde4_runtime_requires

%description kspread
KSpread is the spreadsheet application of the KDE office suite.

%post kspread -p /sbin/ldconfig

%postun kspread -p /sbin/ldconfig

%files kspread -f filelists/kspread
%defattr(-,root,root)
%doc COPYING COPYING.LIB README
%_kde_share_dir/templates/SpreadSheet.desktop
%_kde_share_dir/templates/.source/SpreadSheet.kst
%_kde_share_dir/services/ServiceMenus/kspread_konqi.desktop

%package devel
License:        GPLv2+ ; LGPLv2.1+
Group:          Development/Libraries/KDE
Summary:        The Build Enviroment from KOffice
Requires:       koffice2-kplato koffice2-kformula
%if 0
Requires:       koffice2-kexi koffice2-kivio
%endif
Requires:       koffice2-kspread koffice2-karbon koffice2-kpresenter koffice2-krita koffice2-kword

%description devel
This build environment is needed to compile KOffice applications.

%files devel -f filelists/devel
%defattr(-,root,root)
%doc COPYING COPYING.LIB README
/usr/include/*
%_libdir/libflake.so
%_libdir/libkochart.so
#%_libdir/libkoffice_graya_u16.so
#%_libdir/libkofficegrayau8colorspace.so
%_libdir/libkokross.so
%_libdir/libkomain.so
%_libdir/libkopageapp.so
%_libdir/libkotext.so
%_libdir/libkowmf.so
#%_libdir/libkostore.so
%_libdir/libkwmf.so
%_libdir/libpigmentcms.so
%_libdir/libkoodf.so
#%_libdir/libkoresources.so
%_libdir/libkoproperty.so
%_libdir/libkoreport.so
%_libdir/libmsooxml.so

%_kde4_appsdir/cmake/modules/FindKOfficeLibs.cmake
#/usr/%_lib/libkoaction.so
#/usr/%_lib/libkobase.so  
#/usr/%_lib/libkocolorwidgets.so
/usr/%_lib/libkoplugin.so
/usr/%_lib/libkowidgets.so

%files -f filelists/exclude
%defattr(-,root,root)
%doc COPYING COPYING.LIB README
%if %with_gtl
%if %suse_version > 1110
%dir %_kde4_appsdir/pigmentcms
%dir %_kde4_appsdir/pigmentcms/ctlcolorspaces
%dir %_kde4_appsdir/pigmentcms/ctlcolortransformations
%dir %_kde4_appsdir/pigmentcms/ctlcompositeops
%dir %_kde4_appsdir/pigmentcms/ctlmodules
%dir %_kde4_appsdir/pigmentcms/ctlprofiles
%dir %_kde4_appsdir/pigmentcms/ctltemplates
%endif
%endif
/usr/bin/koconverter
%_kde4_modules/autocorrect.so
%_kde4_modules/changecase.so
%_kde4_modules/chartshape.so
%_kde4_modules/commentshape.so
%_kde4_modules/defaulttools.so
#%_kde4_modules/kofficegoogledocs.so
%_kde4_modules/koreport_*.so
%_kde4_modules/kofficescan.so
%_kde4_modules/kofficethumbnail.so
%_kde4_modules/generickofilter.so
%_kde4_modules/kounavailpart.so
%_kde4_modules/xsltexport.so
%_kde4_modules/xsltimport.so
%_kde4_modules/okularGenerator_odp.so
%_kde4_modules/pathshapes.so
%_kde4_modules/pictureshape.so
%_kde4_modules/pluginshape.so
%_kde4_modules/textshape.so
%_kde4_modules/textvariables.so
%_kde4_modules/divineproportionshape.so
%_kde4_modules/artistictextshape.so
%_kde4_modules/videoshape.so
%_kde4_modules/kolcmsengine.so
%_libdir/libchartshapelib.so*
%_libdir/libflake.so.*
%_libdir/libkdchart.so*
%_libdir/libkochart.so.*
%_libdir/libkokross.so.*
%_libdir/libkomain.so.*
%_libdir/libkoodf.so.*
%_libdir/libkopageapp.so.*
%_libdir/libkotext.so.*
%_libdir/libkowmf.so.*
%_libdir/libkwmf.so.*
%_libdir/libpigmentcms.so.*
%_libdir/libkoproperty.so.*
%_libdir/libkoreport.so.*
%_libdir/libmsooxml.so.*
%_kde4_modules/kofficedockers.so
%_kde4_modules/musicshape.so
%_kde4_appsdir/koffice/koffice_shell.rc
%_kde4_appsdir/koffice/autocorrect
%_kde_share_dir/services/artistictextshape.desktop
%_kde_share_dir/services/autocorrect.desktop
%_kde_share_dir/services/changecase.desktop
%_kde_share_dir/services/chartshape.desktop
%_kde_share_dir/services/commentshape.desktop
%_kde_share_dir/services/defaulttools.desktop
%_kde_share_dir/services/divineproportionshape.desktop
%_kde_share_dir/services/generic_filter.desktop
%_kde_share_dir/services/kchartpart.desktop
%_kde_share_dir/services/kofficedockers.desktop
%_kde_share_dir/services/kofficethumbnail.desktop
%_kde_share_dir/services/kolcmsengine.desktop
%_kde_share_dir/services/koreport_barcodeplugin.desktop
%_kde_share_dir/services/koreport_chartplugin.desktop
%_kde_share_dir/services/koreport_shapeplugin.desktop
%_kde_share_dir/services/kounavail.desktop
%_kde_share_dir/services/musicshape.desktop
%_kde_share_dir/services/pathshapes.desktop
%_kde_share_dir/services/pictureshape.desktop
%_kde_share_dir/services/pluginshape.desktop
%_kde_share_dir/services/textshape.desktop
%_kde_share_dir/services/textvariables.desktop
%_kde_share_dir/services/videoshape.desktop
%_kde_share_dir/services/xslt_export.desktop
%_kde_share_dir/services/xslt_import.desktop
%_kde_share_dir/services/libokularGenerator_odp.desktop
%_kde_share_dir/services/okularOdp.desktop
%_kde4_servicetypesdir/filtereffect.desktop
%_kde4_servicetypesdir/flake.desktop
%_kde4_servicetypesdir/flakeshape.desktop
%_kde4_servicetypesdir/flakedevice.desktop
%_kde4_servicetypesdir/flaketool.desktop
%_kde4_servicetypesdir/textvariableplugin.desktop
%_kde4_servicetypesdir/inlinetextobject.desktop
%_kde4_servicetypesdir/kochart.desktop
%_kde4_servicetypesdir/kofficedocker.desktop
%_kde4_servicetypesdir/kofficepart.desktop
%_kde4_servicetypesdir/kofilter.desktop
%_kde4_servicetypesdir/kofilterwrapper.desktop
%_kde4_servicetypesdir/koplugin.desktop
%_kde4_servicetypesdir/koreport_itemplugin.desktop
%_kde4_servicetypesdir/pigment.desktop
%_kde4_servicetypesdir/pigmentextension.desktop
%_kde4_servicetypesdir/presentationeventaction.desktop
%_kde4_servicetypesdir/scripteventaction.desktop
%_kde4_servicetypesdir/texteditingplugin.desktop
%_kde4_appsdir/musicshape
/usr/share/color/icc/pigment
%dir %_kde_share_dir/services/ServiceMenus
%_kde_share_dir/services/ServiceMenus/kchart_konqi.desktop
%dir %_kde_share_dir/templates
%dir %_kde_share_dir/templates/.source
%_kde4_applicationsdir/koffice.desktop
%_kde4_applicationsdir/okularApplication_odp.desktop
%_kde4_modules/spellcheck.so
%_kde_share_dir/services/spellcheck.desktop
%_kde4_appsdir/xsltfilter
%dir /usr/share/color
%dir /usr/share/color/icc
%dir %_kde4_appsdir/koffice
%dir %_kde4_appsdir/koffice/icons
%dir %_kde4_appsdir/koffice/icons/hicolor
%dir %_kde4_appsdir/koffice/icons/hicolor/*
%dir %_kde4_appsdir/koffice/icons/hicolor/*/actions
%dir %_kde4_appsdir/koffice/icons/hicolor/*/apps
#%dir %_kde4_appsdir/koffice/icons/hicolor/22x22
#%dir %_kde4_appsdir/koffice/icons/hicolor/22x22/actions
#%dir %_kde4_appsdir/koffice/icons/hicolor/32x32
#%dir %_kde4_appsdir/koffice/icons/hicolor/32x32/actions
#%dir %_kde4_appsdir/koffice/icons/hicolor/32x32/apps
#%dir %_kde4_appsdir/koffice/icons/hicolor/48x48
#%dir %_kde4_appsdir/koffice/icons/hicolor/48x48/actions
#%dir %_kde4_appsdir/koffice/icons/hicolor/48x48/apps
%dir %_kde4_appsdir/koffice/icons/oxygen
%dir %_kde4_appsdir/koffice/icons/oxygen/*
%dir %_kde4_appsdir/koffice/icons/oxygen/*/actions
#%dir %_kde4_appsdir/koffice/icons/oxygen/22x22
#%dir %_kde4_appsdir/koffice/icons/oxygen/22x22/actions
%_kde4_appsdir/koffice/icons/*/*/actions/aobottom.*
%_kde4_appsdir/koffice/icons/*/*/actions/aocenterh.*
%_kde4_appsdir/koffice/icons/*/*/actions/aocenterv.*
%_kde4_appsdir/koffice/icons/*/*/actions/aoright.*
%_kde4_appsdir/koffice/icons/*/*/actions/aotop.*
%_kde4_appsdir/koffice/icons/*/*/actions/arrow-down.*
%_kde4_appsdir/koffice/icons/*/*/actions/arrow-left.*
%_kde4_appsdir/koffice/icons/*/*/actions/arrow-left-down.*
%_kde4_appsdir/koffice/icons/*/*/actions/arrow-left-up.*
%_kde4_appsdir/koffice/icons/*/*/actions/arrow-right-down.*
%_kde4_appsdir/koffice/icons/*/*/actions/arrow-right-koffice.*
%_kde4_appsdir/koffice/icons/*/*/actions/arrow-right-up.*
%_kde4_appsdir/koffice/icons/*/*/actions/arrow-up.*
%_kde4_appsdir/koffice/icons/*/*/actions/borderbottom.*
%_kde4_appsdir/koffice/icons/*/*/actions/borderleft.*
%_kde4_appsdir/koffice/icons/*/*/actions/borderoutline.*
%_kde4_appsdir/koffice/icons/*/*/actions/borderright.*
%_kde4_appsdir/koffice/icons/*/*/actions/bordertop.*
%_kde4_appsdir/koffice/icons/*/*/actions/bring_forward.*
%_kde4_appsdir/koffice/icons/*/*/actions/callout-shape.*
%_kde4_appsdir/koffice/icons/*/*/actions/cap_butt.*
%_kde4_appsdir/koffice/icons/*/*/actions/cap_round.*
%_kde4_appsdir/koffice/icons/*/*/actions/cap_square.*
%_kde4_appsdir/koffice/icons/*/*/actions/join_bevel.*
%_kde4_appsdir/koffice/icons/*/*/actions/join_miter.*
%_kde4_appsdir/koffice/icons/*/*/actions/join_round.*
%_kde4_appsdir/koffice/icons/*/*/actions/cancel.*
%_kde4_appsdir/koffice/icons/*/*/actions/char.*
%_kde4_appsdir/koffice/icons/*/*/actions/circular-arrow-shape.*
%_kde4_appsdir/koffice/icons/*/*/actions/clipart.*
%_kde4_appsdir/koffice/icons/*/*/actions/clipart_from_file.*
%_kde4_appsdir/koffice/icons/*/*/actions/color_fill.*
%_kde4_appsdir/koffice/icons/*/*/actions/color_line.*
%_kde4_appsdir/koffice/icons/*/*/actions/convert-to-path.*
%_kde4_appsdir/koffice/icons/*/*/actions/createpath.*
%_kde4_appsdir/koffice/icons/*/*/actions/cross-shape.*
%_kde4_appsdir/koffice/icons/*/*/actions/delete_table_col.*
%_kde4_appsdir/koffice/icons/*/*/actions/delete_table_row.*
%_kde4_appsdir/koffice/icons/*/*/actions/delslide.*
%_kde4_appsdir/koffice/icons/*/*/actions/divine-shape.*
%_kde4_appsdir/koffice/icons/*/*/actions/editpath.*
%_kde4_appsdir/koffice/icons/*/*/actions/edittext.*
%_kde4_appsdir/koffice/icons/*/*/actions/ellipse-shape.*
%_kde4_appsdir/koffice/icons/*/*/actions/flower-shape.*
%_kde4_appsdir/koffice/icons/*/*/actions/format_decreaseindent.*
%_kde4_appsdir/koffice/icons/*/*/actions/format-font-size-less.*
%_kde4_appsdir/koffice/icons/*/*/actions/format-font-size-more.*
%_kde4_appsdir/koffice/icons/*/*/actions/format_increaseindent.*
%_kde4_appsdir/koffice/icons/*/*/actions/format-line-spacing-double.*
%_kde4_appsdir/koffice/icons/*/*/actions/format-line-spacing-normal.*
%_kde4_appsdir/koffice/icons/*/*/actions/format-line-spacing-simple.*
%_kde4_appsdir/koffice/icons/*/*/actions/format-line-spacing-triple.*
%_kde4_appsdir/koffice/icons/*/*/actions/frame_chart.*
%_kde4_appsdir/koffice/icons/*/*/actions/frame_edit.*
%_kde4_appsdir/koffice/icons/*/*/actions/frame_formula.*
%_kde4_appsdir/koffice/icons/*/*/actions/frame_image.*
%_kde4_appsdir/koffice/icons/*/*/actions/frame_query.*
%_kde4_appsdir/koffice/icons/*/*/actions/frame_spreadsheet.*
%_kde4_appsdir/koffice/icons/*/*/actions/frame_text.*
%_kde4_appsdir/koffice/icons/*/*/actions/gearhead-shape.*
%_kde4_appsdir/koffice/icons/*/*/actions/grid.*
%_kde4_appsdir/koffice/icons/*/*/actions/group.*
%_kde4_appsdir/koffice/icons/*/*/actions/hand.*
%_kde4_appsdir/koffice/icons/*/*/actions/hexagon-shape.*
%_kde4_appsdir/koffice/icons/*/*/actions/inline_image.*
%_kde4_appsdir/koffice/icons/*/*/actions/inline_table.*
%_kde4_appsdir/koffice/icons/*/*/actions/insert_table_col.*
%_kde4_appsdir/koffice/icons/*/*/actions/insert_table_row.*
%_kde4_appsdir/koffice/icons/*/*/actions/kdb_form.*
%_kde4_appsdir/koffice/icons/*/*/actions/kdb_table.*
%_kde4_appsdir/koffice/icons/*/*/actions/linewidth.*
%_kde4_appsdir/koffice/icons/*/*/actions/lower.*
%_kde4_appsdir/koffice/icons/*/*/actions/music-cross.*
%_kde4_appsdir/koffice/icons/*/*/actions/music-dottednote.*
%_kde4_appsdir/koffice/icons/*/*/actions/music-doublecross.*
%_kde4_appsdir/koffice/icons/*/*/actions/music-doubleflat.*
%_kde4_appsdir/koffice/icons/*/*/actions/music-flat.*
%_kde4_appsdir/koffice/icons/*/*/actions/music-natural.*
%_kde4_appsdir/koffice/icons/*/*/actions/music-note-128th.*
%_kde4_appsdir/koffice/icons/*/*/actions/music-note-16th.*
%_kde4_appsdir/koffice/icons/*/*/actions/music-note-32nd.*
%_kde4_appsdir/koffice/icons/*/*/actions/music-note-64th.*
%_kde4_appsdir/koffice/icons/*/*/actions/music-note-breve.*
%_kde4_appsdir/koffice/icons/*/*/actions/music-note-eighth.*
%_kde4_appsdir/koffice/icons/*/*/actions/music-note-half.*
%_kde4_appsdir/koffice/icons/*/*/actions/music-note-quarter.*
%_kde4_appsdir/koffice/icons/*/*/actions/music-note-whole.*
%_kde4_appsdir/koffice/icons/*/*/actions/music-rest-16th.*
%_kde4_appsdir/koffice/icons/*/*/actions/music-rest-32nd.*
%_kde4_appsdir/koffice/icons/*/*/actions/music-rest-64th.*
%_kde4_appsdir/koffice/icons/*/*/actions/music-rest-breve.*
%_kde4_appsdir/koffice/icons/*/*/actions/music-rest-eighth.*
%_kde4_appsdir/koffice/icons/*/*/actions/music-rest-half.*
%_kde4_appsdir/koffice/icons/*/*/actions/music-rest-quarter.*
%_kde4_appsdir/koffice/icons/*/*/actions/music-rest-whole.*
%_kde4_appsdir/koffice/icons/*/*/actions/music-tiednote.*
%_kde4_appsdir/koffice/icons/*/*/actions/neonpen.*
%_kde4_appsdir/koffice/icons/*/*/actions/ok.*
%_kde4_appsdir/koffice/icons/*/*/actions/page.*
%_kde4_appsdir/koffice/icons/*/*/actions/path-break-point.*
%_kde4_appsdir/koffice/icons/*/*/actions/path-break-segment.*
%_kde4_appsdir/koffice/icons/*/*/actions/pathpoint-corner.*
%_kde4_appsdir/koffice/icons/*/*/actions/pathpoint-insert.*
%_kde4_appsdir/koffice/icons/*/*/actions/pathpoint-join.*
%_kde4_appsdir/koffice/icons/*/*/actions/pathpoint-merge.*
%_kde4_appsdir/koffice/icons/*/*/actions/pathpoint-remove.*
%_kde4_appsdir/koffice/icons/*/*/actions/pathpoint-smooth.*
%_kde4_appsdir/koffice/icons/*/*/actions/pathpoint-symmetric.*
%_kde4_appsdir/koffice/icons/*/*/actions/pathsegment-curve.*
%_kde4_appsdir/koffice/icons/*/*/actions/pathsegment-line.*
%_kde4_appsdir/koffice/icons/*/*/actions/pathshape.*
%_kde4_appsdir/koffice/icons/*/*/actions/pentagon-shape.*
%_kde4_appsdir/koffice/icons/*/*/actions/polygon-shape.*
%_kde4_appsdir/koffice/icons/*/*/actions/raise.*
%_kde4_appsdir/koffice/icons/*/*/actions/rectangle-shape.*
%_kde4_appsdir/koffice/icons/*/*/actions/select.*
%_kde4_appsdir/koffice/icons/*/*/actions/send_backward.*
%_kde4_appsdir/koffice/icons/*/*/actions/shadow.*
%_kde4_appsdir/koffice/icons/*/*/actions/shadowB.*
%_kde4_appsdir/koffice/icons/*/*/actions/shadowL.*
%_kde4_appsdir/koffice/icons/*/*/actions/shadowLB.*
%_kde4_appsdir/koffice/icons/*/*/actions/shadowLU.*
%_kde4_appsdir/koffice/icons/*/*/actions/shadowR.*
%_kde4_appsdir/koffice/icons/*/*/actions/shadowRB.*
%_kde4_appsdir/koffice/icons/*/*/actions/shadowRU.*
%_kde4_appsdir/koffice/icons/*/*/actions/shadowU.*
%_kde4_appsdir/koffice/icons/*/*/actions/slide.*
%_kde4_appsdir/koffice/icons/*/*/actions/slide-new.*
%_kde4_appsdir/koffice/icons/*/*/actions/smiley-shape.*
%_kde4_appsdir/koffice/icons/*/*/actions/spiral-shape.*
%_kde4_appsdir/koffice/icons/*/*/actions/star-shape.*
%_kde4_appsdir/koffice/icons/*/*/actions/tab_first.*
%_kde4_appsdir/koffice/icons/*/*/actions/tab_last.*
%_kde4_appsdir/koffice/icons/*/*/actions/tab_left.*
%_kde4_appsdir/koffice/icons/*/*/actions/tab_right.*
%_kde4_appsdir/koffice/icons/*/*/actions/textcolor.*
%_kde4_appsdir/koffice/icons/*/*/actions/toggle_docbrowser.*
%_kde4_appsdir/koffice/icons/*/*/actions/tool-changetracking.*
%_kde4_appsdir/koffice/icons/*/*/actions/tool-paragraph.*
%_kde4_appsdir/koffice/icons/*/*/actions/tool-text.*
%_kde4_appsdir/koffice/icons/*/*/actions/ungroup.*
%_kde4_appsdir/koffice/icons/*/*/actions/view_orientation.*
%_kde4_appsdir/koffice/icons/*/*/actions/view_split.*
%_kde4_appsdir/koffice/icons/*/*/actions/zoom-page.*
%_kde4_appsdir/koffice/icons/*/*/actions/zoom-pixels.*
%_kde4_appsdir/koffice/icons/*/*/actions/zoom-width.*
%_kde4_appsdir/koffice/icons/*/*/actions/backgroundtool.*
%_kde4_appsdir/koffice/icons/*/*/apps/go.*
%_kde4_appsdir/koffice/icons/*/*/apps/key_bindings.*
%_kde4_appsdir/koffice/icons/*/*/apps/style.*
%_kde4_appsdir/koffice/icons/rotate.*
%_kde4_appsdir/koffice/icons/shear.*
%_kde4_appsdir/koffice/icons/zoom_in_cursor.*
%_kde4_appsdir/koffice/icons/zoom_out_cursor.*
%_kde4_appsdir/koffice/icons/hicolor/*/actions/view-sort-ascending.*
%_kde4_appsdir/koffice/icons/hicolor/*/actions/view-sort-descending.*
%_kde4_iconsdir/oxygen/*/actions/table.*
%_kde4_iconsdir/oxygen/*/actions/shape-choose.*
%_kde4_iconsdir/oxygen/*/actions/x-shape-chart.*
%_kde4_iconsdir/oxygen/*/actions/x-shape-connection.*
%_kde4_iconsdir/oxygen/*/actions/x-shape-formula.*
%_kde4_iconsdir/oxygen/*/actions/x-shape-image.*
%_kde4_iconsdir/oxygen/*/actions/x-shape-text.*
%_kde4_appsdir/koffice/icons/hicolor/*/actions/kotext-character.*
%_kde4_appsdir/koffice/icons/hicolor/*/actions/kotext-paragraph.*
%_kde4_appsdir/koffice/icons/oxygen/*/actions/snap-extension.*
%_kde4_appsdir/koffice/icons/oxygen/*/actions/snap-guideline.*
%_kde4_appsdir/koffice/icons/oxygen/*/actions/snap-intersection.*
%_kde4_appsdir/koffice/icons/oxygen/*/actions/snap-node.*
%_kde4_appsdir/koffice/icons/oxygen/*/actions/snap-orto.*
%_kde4_appsdir/koffice/icons/oxygen/*/actions/pathpoint-curve.*
%_kde4_appsdir/koffice/icons/oxygen/*/actions/pathpoint-line.*
%_kde4_modules/kopabackgroundtool.so
%_kde4_servicesdir/kopabackgroundtool.desktop
%_kde4_iconsdir/oxygen/*/actions/object-align-horizontal-center-koffice.*
%_kde4_iconsdir/oxygen/*/actions/object-align-horizontal-left-koffice.*
%_kde4_iconsdir/oxygen/*/actions/object-align-horizontal-right-koffice.*
%_kde4_iconsdir/oxygen/*/actions/object-align-vertical-bottom-top-koffice.*
%_kde4_iconsdir/oxygen/*/actions/object-align-vertical-bottom-koffice.*
%_kde4_iconsdir/oxygen/*/actions/object-align-vertical-center-koffice.*
%_kde4_iconsdir/oxygen/*/actions/object-align-vertical-top-koffice.*
%_kde4_iconsdir/oxygen/*/actions/object-group-koffice.*
%_kde4_iconsdir/oxygen/*/actions/object-order-back-koffice.*
%_kde4_iconsdir/oxygen/*/actions/object-order-front-koffice.*
%_kde4_iconsdir/oxygen/*/actions/object-order-lower-koffice.*
%_kde4_iconsdir/oxygen/*/actions/object-order-raise-koffice.*
%_kde4_iconsdir/oxygen/*/actions/object-ungroup-koffice.*
%_kde4_appsdir/koffice/icons/hicolor/*/actions/checkbox.png
%_kde4_appsdir/koffice/icons/hicolor/*/actions/line.png
%_kde4_appsdir/koffice/icons/hicolor/*/actions/view-barcode.png
%_kde4_appsdir/koffice/icons/hicolor/*/actions/label.png
%_kde4_appsdir/koffice/icons/hicolor/*/actions/shapes.png
%_kde4_appsdir/koffice/icons/hicolor/*/actions/aoleft.*
%_kde4_appsdir/koffice/icons/hicolor/*/actions/music-rest-128th.*
%_kde4_appsdir/koffice/icons/hicolor/*/actions/artistictext-attach-path.*
%_kde4_appsdir/koffice/icons/hicolor/*/actions/artistictext-detach-path.*
%_kde4_appsdir/koffice/icons/hicolor/*/actions/artistictext-tool.*
%_kde4_appsdir/koffice/icons/hicolor/*/actions/zoom-two-pages.*
%_kde4_appsdir/koproperty
%_kde4_modules/icalendarexport.so
%_kde4_modules/powerpointimport.so
%_kde4_modules/paragraphtool.so
%_kde4_libdir/libkoplugin.so.*
%_kde4_servicesdir/kplato_icalendar_export.desktop
%_kde4_servicesdir/kpresenter_powerpoint_import.desktop
%_kde4_servicesdir/paragraphtool.desktop
%_kde4_modules/kodocinfopropspage.so
%_kde4_servicesdir/kodocinfopropspage.desktop

%_kde4_libdir/libkowidgets.so.*
/usr/share/mime/packages/msooxml-all.xml

%changelog
openSUSE Build Service is sponsored by