File ktorrent.spec of Package ktorrent

#
# spec file for package ktorrent
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


#
%define srcversion 4.1beta1

Name:           ktorrent
BuildRequires:  gmp-devel kdebase4-workspace-devel libkdepimlibs4-devel libqca2-devel taglib-devel
BuildRequires:  fdupes libktorrent-devel
BuildRequires:  hicolor-icon-theme jpackage-utils
Url:            http://ktorrent.pwsp.net/
License:        GPLv2+
Group:          Productivity/Networking/File-Sharing
Summary:        KDE BitTorrent Client
Version:        4.0.99beta1
Release:        2
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%define rversion %version
Source:         %{name}-%{srcversion}.tar.bz2
Source2:        icons.tar.bz2
Source3:        ktorrent.1
Source4:        ktupnptest.1
Patch1:         remove-links.diff
Patch4:         suse-dht-warning.diff
Patch5:         initial-preference.diff
Recommends:     %{name}-lang = %{version}
%kde4_runtime_requires
%kde4_pimlibs_requires

Requires:       oxygen-icon-theme
# This specific "requires" is neccessary because rpm doesn't specify a version for the libktcore12 requirement
Requires:       libktcore12 = %{version}-%{release}

%description
Torrent is a BitTorrent program for KDE. Its main features are:
* Download of torrent files
* Upload speed capping, seeing that most people cannot upload
   infinite amounts of data
* Internet searching using the BitTorrent Web site's search engine
* UDP trackers

Authors:
--------
    Jois Guisson <jrois.guisson@gmail.com>

%package -n libktcore12
License:        GPLv2+
Group:          System/Libraries
Summary:        Library for ktorrent

%description -n libktcore12
This package contains ktorrent's library
Authors:
--------
    Jois Guisson <jrois.guisson@gmail.com>

%package devel
License:        GPLv2+
Group:          Development/Libraries/C and C++
Summary:        KDE BitTorrent Client Build Environment
Requires:       ktorrent = %{version}

%description devel
This package includes the necessary files to build KTorrent plugins.



Authors:
--------
    Jois Guisson <jrois.guisson@gmail.com>

%lang_package
%prep
%setup -q -n %{name}-%{srcversion}
%patch1
%if ! 0%{?packman_bs}
%patch4
%endif
%patch5
tar xfj %{SOURCE2}

%build
  %cmake_kde4 -d build -- -DENABLE_DHT_SUPPORT=true -DCMAKE_VERBOSE_MAKEFILE:BOOL=true
  %make_jobs

%install
  cd build
  %makeinstall
# Add man pages from help2man edited.
mkdir -p %{buildroot}%{_mandir}/man1
cp %{S:3} %{buildroot}%{_mandir}/man1
cp %{S:4} %{buildroot}%{_mandir}/man1
    %fdupes -s $RPM_BUILD_ROOT
%if %suse_version > 1110
%else
  rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/hne
%endif
  %suse_update_desktop_file -r ktorrent Qt KDE Network P2P

# Fix any .py files with shebangs and wrong permissions.
if test -z `find %{buildroot} -name *.py -perm 0644 -print0|xargs -0r grep -l '#!'`; \
then break;
else chmod -f 0755 `find %{buildroot} -name *.py -perm 0644 -print0|xargs -0r grep -l '#!'`; \
fi

  %kde_post_install
  %find_lang %name

%pre -p /sbin/ldconfig

%post -p /sbin/ldconfig

%postun -p /sbin/ldconfig

%post -n libktcore12 -p /sbin/ldconfig

%postun -n libktcore12 -p /sbin/ldconfig

%files lang -f build/%name.lang
%defattr(-,root,root)
%if %suse_version < 1140
%dir %{_datadir}/locale/sr@ijekavian
%dir %{_datadir}/locale/sr@ijekavian/LC_MESSAGES
%dir %{_datadir}/locale/sr@ijekavianlatin
%dir %{_datadir}/locale/sr@ijekavianlatin/LC_MESSAGES
%endif

%files
%defattr(-,root,root)
%{_bindir}/ktorrent
%{_bindir}/ktupnptest
%{_bindir}/ktmagnetdownloader
%_kde4_modules/ktbwschedulerplugin.so
%_kde4_modules/ktinfowidgetplugin.so
%_kde4_modules/ktipfilterplugin.so
%_kde4_modules/ktlogviewerplugin.so
%_kde4_modules/ktscanfolderplugin.so
%_kde4_modules/ktsearchplugin.so
%_kde4_modules/ktstatsplugin.so
%_kde4_modules/ktupnpplugin.so
%_kde4_modules/ktwebinterfaceplugin.so
%_kde4_modules/ktmediaplayerplugin.so
%_kde4_modules/ktdownloadorderplugin.so
%_kde4_modules/ktscriptingplugin.so
%_kde4_modules/ktsyndicationplugin.so
%_kde4_modules/plasma_applet_ktorrent.so
%_kde4_modules/plasma_engine_ktorrent.so
%{_iconsbasedir}/*/actions/kt-add-feeds.*
%{_iconsbasedir}/*/actions/kt-add-filters.*
%{_iconsbasedir}/*/actions/kt-remove-feeds.*
%{_iconsbasedir}/*/actions/kt-remove-filters.*
%{_iconsbasedir}/*/actions/kt-magnet.*
%_kde_share_dir/services/ktdownloadorderplugin.desktop
%_kde_share_dir/services/ktscriptingplugin.desktop
%_kde_share_dir/services/ktsyndicationplugin.desktop
%_kde_share_dir/services/plasma-applet-ktorrent.desktop
%_kde_share_dir/services/plasma-dataengine-ktorrent.desktop
%{_kde4_applicationsdir}/ktorrent.desktop
%{_iconsbasedir}/*/apps/ktorrent.*
%{_iconsbasedir}/*/mimetypes/torrent.*
%{_iconsbasedir}/*/actions/kt-bandwidth-scheduler.*
%{_iconsbasedir}/*/actions/kt-change-tracker.*
%{_iconsbasedir}/*/actions/kt-check-data.*
%{_iconsbasedir}/*/actions/kt-chunks.*
%{_iconsbasedir}/*/actions/kt-encrypted.*
%{_iconsbasedir}/*/actions/kt-info-widget.*
%{_iconsbasedir}/*/actions/kt-pause.*
%{_iconsbasedir}/*/actions/kt-plugins.*
%{_iconsbasedir}/*/actions/kt-queue-manager.*
%{_iconsbasedir}/*/actions/kt-remove.*
%{_iconsbasedir}/*/actions/kt-restore-defaults.*
%{_iconsbasedir}/*/actions/kt-set-max-download-speed.*
%{_iconsbasedir}/*/actions/kt-set-max-upload-speed.*
%{_iconsbasedir}/*/actions/kt-show-hide.*
%{_iconsbasedir}/*/actions/kt-show-statusbar.*
%{_iconsbasedir}/*/actions/kt-speed-limits.*
%{_iconsbasedir}/*/actions/kt-start-all.*
%{_iconsbasedir}/*/actions/kt-start.*
%{_iconsbasedir}/*/actions/kt-stop-all.*
%{_iconsbasedir}/*/actions/kt-stop.*
%{_iconsbasedir}/*/actions/kt-upnp.*
%_kde_share_dir/apps/ktorrent
%_kde_share_dir/services/ktbwschedulerplugin.desktop
%_kde_share_dir/services/ktinfowidgetplugin.desktop
%_kde_share_dir/services/ktipfilterplugin.desktop
%_kde_share_dir/services/ktlogviewerplugin.desktop
%_kde_share_dir/services/ktscanfolderplugin.desktop
%_kde_share_dir/services/ktsearchplugin.desktop
%_kde_share_dir/services/ktstatsplugin.desktop
%_kde_share_dir/services/ktupnpplugin.desktop
%_kde_share_dir/services/ktwebinterfaceplugin.desktop
%_kde_share_dir/services/ktmediaplayerplugin.desktop
%_kde_share_dir/services/magnet.protocol
%_kde_share_dir/servicetypes/ktorrentplugin.desktop
%{_kde4_modulesdir}/ktzeroconfplugin.so
%{_kde4_modulesdir}/ktmagnetgeneratorplugin.so
%{_kde4_sharedir}/services/ktzeroconfplugin.desktop
%{_kde4_sharedir}/services/ktshutdownplugin.desktop
%{_kde4_modulesdir}/ktshutdownplugin.so
%{_kde4_sharedir}/services/ktmagnetgeneratorplugin.desktop
%{_mandir}/man1/*

%files -n libktcore12
%defattr(-,root,root)
%{_libdir}/libktcore.so.12*

%files devel
%defattr(-,root,root)
%_libdir/libktcore.so

%changelog
openSUSE Build Service is sponsored by