File openslp.spec of Package openslp
#
# spec file for package openslp (Version 1.2.0)
#
# Copyright (c) 2010 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: openslp
BuildRequires: bison flex openssl-devel
Summary: An OpenSLP Implementation of Service Location Protocol V2
Version: 1.2.0
Release: 182
License: BSD3c
Group: System/Daemons
Url: http://www.openslp.org/
# bug437293
%ifarch ppc64
Obsoletes: openslp-64bit
%endif
#
BuildRoot: %{_tmppath}/%{name}-%{version}-build
Source0: %name-%version.tar.bz2
Source1: slpd.init
Source2: README.SuSE
Source3: openslp.desktop
Source4: openslp-devel.desktop
Source5: openslp.logrotate
Source6: slpd.xml
Source7: openslp.SuSEfirewall2
Source8: baselibs.conf
Patch1: openslp.diff
Patch2: openslp.audit.diff
Patch3: extensions.diff
Patch4: slptool-timeout.diff
Patch5: hppa.diff
Patch6: v1dadiscovery.diff
Patch7: openslp.poll.diff
Patch8: openslp.v1sladdr.diff
Patch9: openslp.tcpclearovr.diff
Patch10: openslp.checkovr.diff
Patch11: openslp.truncate.diff
Patch12: openslp.emptyanswer.diff
Patch13: openslp.doubleequal.diff
Patch14: openslp.dereg.diff
Patch15: openslp.fixaddrcheck.diff
Patch16: openslp.fixdsareturn.diff
Patch17: openslp.clrflags.diff
Patch18: openslp.use-TCPDIAG-for-checking-listeners
Patch19: openslp.discovery.diff
Patch20: openslp.initda.diff
Patch21: openslp.ignorespaces.diff
Patch22: openslp.parseext.diff
%description
Service Location Protocol is an IETF standards track protocol that
provides a framework that allows networking applications to discover
the existence, location, and configuration of networked services in
enterprise networks.
OpenSLP is an open source implementation of the SLPv2 protocol as
defined by RFC 2608 and RFC 2614. This package includes the slptool
and runtime libraries.
Authors:
--------
Matthew Peterson <mpeterson@calderasystems.com>
Ganesan Rajagopal <rganesan@myrealbox.com>
David McCormack <david.mccormack@ottawa.com>
Evan Hughes <hughes@lab43.org>
Matthieu Desmons <mdes@ocegr.fr>
Praveen Kumar Amritaluru <praveen@india.hp.com>
%package server
License: BSD3c
Group: System/Daemons
Summary: The OpenSLP Implementation of the Service Location Protocol V2
PreReq: %fillup_prereq %insserv_prereq
Recommends: logrotate
%description server
Service Location Protocol is an IETF standards track protocol that
provides a framework that allows networking applications to discover
the existence, location, and configuration of networked services in
enterprise networks.
This package contains the SLP server. Every system, which provides any
services that should be used via an SLP client must run this server and
register the service.
Authors:
--------
Matthew Peterson <mpeterson@calderasystems.com>
Ganesan Rajagopal <rganesan@myrealbox.com>
David McCormack <david.mccormack@ottawa.com>
Evan Hughes <hughes@lab43.org>
Matthieu Desmons <mdes@ocegr.fr>
Praveen Kumar Amritaluru <praveen@india.hp.com>
%package devel
License: BSD3c
Requires: openssl-devel openslp = %version
Group: System/Daemons
Summary: OpenSLP Development SDK
# bug437293
%ifarch ppc64
Obsoletes: openslp-devel-64bit
%endif
#
%description devel
Service Location Protocol is an IETF standards track protocol that
provides a framework that allows networking applications to discover
the existence, location, and configuration of networked services in
enterprise networks.
This package contains header and library files to compile applications
with SLP support. It also contains developer documentation to develop
such applications.
Authors:
--------
Matthew Peterson <mpeterson@calderasystems.com>
Ganesan Rajagopal <rganesan@myrealbox.com>
David McCormack <david.mccormack@ottawa.com>
Evan Hughes <hughes@lab43.org>
Matthieu Desmons <mdes@ocegr.fr>
Praveen Kumar Amritaluru <praveen@india.hp.com>
%prep
%setup -q
%patch1
%patch2
%patch3
%patch4
%ifarch hppa
%patch5
%endif
%patch6
%patch7
%patch8
%patch9
%patch10
%patch11
%patch12
%patch13
%patch14
%patch15
%patch16
%patch17
%patch18 -p1
%patch19
%patch20
%patch21
%patch22
%build
autoreconf -fiv
%configure --disable-static --with-pic --enable-slpv1 \
--enable-async-api \
--enable-slpv2-security
%{__make} %{?jobs:-j%jobs}
%install
mkdir -p ${RPM_BUILD_ROOT}/etc/slp.reg.d
mkdir -p ${RPM_BUILD_ROOT}/etc/slp.reg.d/slpd
cp etc/slp.conf ${RPM_BUILD_ROOT}/etc
cp etc/slp.reg ${RPM_BUILD_ROOT}/etc
cp etc/slp.spi ${RPM_BUILD_ROOT}/etc
mkdir -p ${RPM_BUILD_ROOT}/%_libdir
./libtool --mode=install install libslp/libslp.la ${RPM_BUILD_ROOT}/%_libdir
mkdir -p ${RPM_BUILD_ROOT}/usr/sbin
./libtool --mode=install install slpd/slpd ${RPM_BUILD_ROOT}/usr/sbin
mkdir -p ${RPM_BUILD_ROOT}/usr/bin
./libtool --mode=install install slptool/slptool ${RPM_BUILD_ROOT}/usr/bin
mkdir -p ${RPM_BUILD_ROOT}/usr/include
cp libslp/slp.h ${RPM_BUILD_ROOT}/usr/include
mkdir -p ${RPM_BUILD_ROOT}%_defaultdocdir/%name
find . -name CVS -o -name .cvsignore -o -name .xvpics | xargs rm -rf
cp -a AUTHORS COPYING README FAQ doc/rfc doc/html %SOURCE2 \
${RPM_BUILD_ROOT}%_defaultdocdir/%name
mkdir -p ${RPM_BUILD_ROOT}/etc/init.d/
install -m 755 %{SOURCE1} ${RPM_BUILD_ROOT}/etc/init.d/slpd
ln -sf ../../etc/init.d/slpd ${RPM_BUILD_ROOT}/usr/sbin/rcslpd
ln -sf ../../etc/init.d/slpd ${RPM_BUILD_ROOT}/usr/sbin/rcopenslp
install -D -m 0644 %{SOURCE5} ${RPM_BUILD_ROOT}/etc/logrotate.d/openslp-server
# install susehelp file
mkdir -p $RPM_BUILD_ROOT/usr/share/susehelp/meta/Administration/
install -m 0644 %SOURCE3 \
$RPM_BUILD_ROOT/usr/share/susehelp/meta/Administration/
mkdir -p $RPM_BUILD_ROOT/usr/share/susehelp/meta/Development/Libraries/
install -m 0644 %SOURCE4 \
$RPM_BUILD_ROOT/usr/share/susehelp/meta/Development/Libraries/
install -d -m 755 $RPM_BUILD_ROOT/usr/share/omc/svcinfo.d
install -m 0644 %SOURCE6 $RPM_BUILD_ROOT/usr/share/omc/svcinfo.d
%if 0
# actually, these files should get translated, but do we really want to
# add update-desktop-files to needed_for_build ?
%suse_update_desktop_file $RPM_BUILD_ROOT/usr/share/susehelp/meta/Administration/openslp.desktop
%suse_update_desktop_file $RPM_BUILD_ROOT/usr/share/susehelp/meta/Development/Libraries/openslp-devel.desktop
%endif
%{__rm} -f %{buildroot}%{_libdir}/*.la
%if 0%{?suse_version}
install -D -m 644 %{S:7} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/SuSEfirewall2.d/services/openslp
%endif
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%post server
%if 0%{?sles_version} == 9 || 0%{?sles_version} == 10
%{fillup_and_insserv -y slpd}
%else
%{fillup_and_insserv slpd}
%endif
%postun server
%restart_on_update slpd
%insserv_cleanup
%preun server
%stop_on_removal slpd
%clean
rm -rf $RPM_BUILD_ROOT
%files
%defattr(-,root,root)
%dir %_defaultdocdir/%name
%dir %_defaultdocdir/%name/html
%doc %_defaultdocdir/%name/AUTHORS
%doc %_defaultdocdir/%name/COPYING
%doc %_defaultdocdir/%name/README
%doc %_defaultdocdir/%name/README.SuSE
%_libdir/libslp.so.*
/usr/bin/slptool
%config(noreplace) /etc/slp.conf
%config(noreplace) /etc/slp.spi
%files server
%defattr(-,root,root)
%dir /usr/share/susehelp
%dir /usr/share/susehelp/meta
%dir /usr/share/susehelp/meta/Administration
%doc %dir %_defaultdocdir/%name/FAQ
%doc %_defaultdocdir/%name/html/IntroductionToSLP
%doc %_defaultdocdir/%name/html/UsersGuide
%doc %_defaultdocdir/%name/html/faq.html
%doc %_defaultdocdir/%name/rfc
%doc /usr/share/susehelp/meta/Administration/openslp.desktop
%dir /etc/slp.reg.d/
%dir /etc/slp.reg.d/slpd
/usr/sbin/rcopenslp
/usr/sbin/rcslpd
/usr/sbin/slpd
/etc/init.d/slpd
%config(noreplace) /etc/slp.reg
%config(noreplace) /etc/logrotate.d/openslp-server
/usr/share/omc/svcinfo.d/slpd.xml
%if 0%{?suse_version} > 0
%config %{_sysconfdir}/sysconfig/SuSEfirewall2.d/services/openslp
%endif
%files devel
%defattr(-,root,root)
%dir /usr/share/susehelp
%dir /usr/share/susehelp/meta
%dir /usr/share/susehelp/meta/Development
%dir /usr/share/susehelp/meta/Development/Libraries
%doc %_defaultdocdir/%name/html/ProgrammersGuide
%doc /usr/share/susehelp/meta/Development/Libraries/openslp-devel.desktop
/usr/include/slp.h
%_libdir/libslp.so
%changelog