File perl-Sub-Exporter.spec of Package perl-Sub-Exporter

#
# spec file for package perl-Sub-Exporter (Version 0.982)
#
# Copyright (c) 2010 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild


Name:           perl-Sub-Exporter
%define cpan_name %( echo %{name} | %{__sed} -e 's,perl-,,' )
Summary:        A sophisticated exporter for custom-built routines
Version:        0.982
Release:        4
License:        GPL v1 or later, Artistic License
Group:          Development/Libraries/Perl
Url:            http://search.cpan.org/dist/Sub-Exporter
Source:         %{cpan_name}-%{version}.tar.bz2
BuildArch:      noarch
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%{perl_requires}
BuildRequires:  perl
BuildRequires:  perl-macros
# other not perl || perl-base
BuildRequires:  perl(Sub::Install) >= 0.92
BuildRequires:  perl(Data::OptList) >= 0.100
BuildRequires:  perl(Params::Util) >= 0.14
BuildRequires:  perl(Package::Generator)
# other not perl || perl-base
Requires:       perl(Sub::Install) >= 0.92
Requires:       perl(Data::OptList) >= 0.100
Requires:       perl(Params::Util) >= 0.14
Requires:       perl(Package::Generator)

%description
Sub::Exporter provides a sophisticated alternative to Exporter.pm.  It allows
for renaming, currying/sub-generation, and other cool stuff.  Read its own
documentation.


The biggest benefit of Sub::Exporter over existing exporters
(including the ubiquitous Exporter.pm) is its ability to build new coderefs
for export, rather than to simply export code identical to that found
in the exporting package.

  Author:	Ricardo Signes, <rjbs@cpan.org>


%prep
%setup -q -n %{cpan_name}-%{version}

%build
%{__perl} Makefile.PL OPTIMIZE="$RPM_OPT_FLAGS -Wall"
%{__make} %{?_smp_mflags}

%check
%{__make} test

%install
%perl_make_install
# do not perl_process_packlist (noarch)
# remove .packlist file
%{__rm} -rf $RPM_BUILD_ROOT%perl_vendorarch
# remove perllocal.pod file
%{__rm} -rf $RPM_BUILD_ROOT%perl_archlib
%perl_gen_filelist

%clean 
%{__rm} -rf $RPM_BUILD_ROOT

%files -f %{name}.files
# normally you only need to check for doc files
%defattr(-,root,root)
%doc Changes LICENSE README

%changelog
openSUSE Build Service is sponsored by