File digikam.spec of Package digikam

#
# spec file for package digikam (Version 1.2.0)
#
# Copyright (c) 2010 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild


Name:           digikam
BuildRequires:  graphviz-devel libgphoto2-devel libkdepimlibs4-devel libqimageblitz-devel sqlite-devel
BuildRequires:  libkdcraw-devel libkexiv2-devel libkipi-devel marble-devel
BuildRequires:  lensfun-devel libjasper-devel liblqr-devel soprano-backend-redland
Url:            http://www.digikam.org/
License:        GPLv2+
Group:          Productivity/Graphics/Viewers
Summary:        A KDE Photo Manager
Version:        1.2.0
Release:        2
%define tar_version 1.2.0
Source0:        %name-%{tar_version}.tar.bz2
Source1:        %{name}-docs.tar.bz2
Patch0:         r1109177.diff
Patch1:         %{name}-buildtime.patch
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%kde4_runtime_requires
%kde4_pimlibs_requires
Recommends:     libqt4-sql-sqlite kipi-plugins
Requires:       oxygen-icon-theme
Requires:       %{name}-lang = %{version}
Provides:       kde4-digikam = 0.10.0
Obsoletes:      kde4-digikam <= 0.10.0

%description
digiKam is a simple digital photo management application for KDE, which
allows you to import and organize your digital photos easily. The
photos can be organized in albums, which can be sorted chronologically,
by directory layout, or by custom collections. An easy-to-use interface
that enables you to connect to your camera and preview, download, or
delete your images, is provided.



Authors:
--------
    Gilles Caulier <caulier dot gilles at gmail dot com>
    Marcel Wiesweg <marcel dot wiesweg at gmx dot de>
    Andi Clemens <andi dot clemens at gmx dot net>
    Renchi Raju <renchi@green.tam.uiuc.edu> (Original author, retired)

%package devel
License:        GPLv2+
Group:          Development/Libraries/KDE
Summary:        Development Headers for Digikam
Requires:       %name = %{version}

%description devel
digiKam is a simple digital photo management application for KDE. This
package contains its build environment.



Authors:
--------
    Gilles Caulier <caulier dot gilles at gmail dot com>
    Marcel Wiesweg <marcel dot wiesweg at gmx dot de>
    Andi Clemens <andi dot clemens at gmx dot net>
    Renchi Raju <renchi@green.tam.uiuc.edu>

%package doc
License:        GPLv2+
Group:          Productivity/Graphics/Viewers
Summary:        A KDE Photo Manager Build Environment
Requires:       %name = %{version}

%description doc
digiKam is a simple digital photo management application for KDE. This
package contains its build environment.


Authors:
--------
    Gilles Caulier <caulier dot gilles at gmail dot com>
    Marcel Wiesweg <marcel dot wiesweg at gmx dot de>
    Andi Clemens <andi dot clemens at gmx dot net>
    Renchi Raju <renchi@green.tam.uiuc.edu>


%lang_package
%prep
%setup -q -n %name-%{tar_version} -a 1
%patch0
%patch1
FAKE_BUILDDATE=$(LC_ALL=C date -r %{_sourcedir}/%{name}.changes '+%b %e %Y')
sed -i "s/__DATE__/\"$FAKE_BUILDDATE\"/" digikam/version.h.cmake
echo "find_package(Msgfmt REQUIRED)" >> CMakeLists.txt
echo "find_package(Gettext REQUIRED)" >> CMakeLists.txt
echo "add_subdirectory( doc-translations )" >> CMakeLists.txt
echo "add_subdirectory( doc/digikam )" >> CMakeLists.txt
echo "add_subdirectory( doc/showfoto )" >> CMakeLists.txt

%build
  %cmake_kde4 -d build
  %make_jobs

%install
  cd build
  %makeinstall
  cd ..
  %suse_update_desktop_file digikam  Graphics Photography
  %suse_update_desktop_file -G "Photo Editor" showfoto Graphics Photography
  %find_lang %name
  %kde_post_install
  %if %suse_version < 1120
  mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kde/HTML/et/common
  mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kde/HTML/it/common
  mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kde/HTML/uk/common
  mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kde/HTML/sv/common
  mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kde/HTML/pt_BR/common
  %endif

%post -p /sbin/ldconfig

%postun -p /sbin/ldconfig

%clean
rm -rf $RPM_BUILD_ROOT
rm -rf filelists

%files devel
%defattr(-,root,root)
/usr/include/digikam
/usr/include/digikam_export.h
%_libdir/libdigikamcore.so
%_libdir/libdigikamdatabase.so

%files lang -f %name.lang
%defattr(-,root,root)
%exclude /usr/share/doc/kde/HTML/*/digikam
%exclude /usr/share/doc/kde/HTML/*/showfoto

%files doc
%defattr(-,root,root)
%dir /usr/share/doc/kde/HTML/*/digikam
%dir /usr/share/doc/kde/HTML/*/showfoto
%if %suse_version < 1120
%dir /usr/share/doc/kde/HTML/*/common
%endif
%doc %lang(en) /usr/share/doc/kde/HTML/en/*
%doc %lang(et) /usr/share/doc/kde/HTML/et/*
%doc %lang(it) /usr/share/doc/kde/HTML/it/*
%doc %lang(pt_BR) /usr/share/doc/kde/HTML/pt_BR/*
%doc %lang(uk) /usr/share/doc/kde/HTML/uk/*
%doc %lang(sv) /usr/share/doc/kde/HTML/sv/*

%files
%defattr(-,root,root)
/usr/bin/digikam
/usr/bin/digitaglinktree
/usr/bin/showfoto
/usr/bin/cleanup_digikamdb
# new
%_kde4_modules/digikamimageplugin_color.so
%_kde4_modules/digikamimageplugin_decorate.so
%_kde4_modules/digikamimageplugin_enhance.so
%_kde4_modules/digikamimageplugin_fxfilters.so
%_kde4_modules/digikamimageplugin_transform.so
# old
%_kde4_modules/kio_digikamalbums.so
%_kde4_modules/kio_digikamdates.so
%_kde4_modules/kio_digikamsearch.so
%_kde4_modules/kio_digikamtags.so
%_kde4_modules/plugins/marble/ExternalDraw.so
%_libdir/libdigikamcore.so.*
%_libdir/libdigikamdatabase.so.*
/usr/share/applications/kde4/digikam.desktop
/usr/share/applications/kde4/showfoto.desktop
/usr/share/icons/hicolor/*/apps/digikam.*
/usr/share/icons/hicolor/*/apps/showfoto.*
%_kde_share_dir/apps/digikam
%_kde_share_dir/apps/showfoto
%_kde_share_dir/services/digikamalbums.protocol
%_kde_share_dir/services/digikamdates.protocol
%_kde_share_dir/services/digikamimageplugin_color.desktop
%_kde_share_dir/services/digikamimageplugin_decorate.desktop
%_kde_share_dir/services/digikamimageplugin_enhance.desktop
%_kde_share_dir/services/digikamimageplugin_fxfilters.desktop
%_kde_share_dir/services/digikamimageplugin_transform.desktop
%_kde_share_dir/services/digikamsearch.protocol
%_kde_share_dir/services/digikamtags.protocol
%_kde_share_dir/servicetypes/digikamimageplugin.desktop
#%_kde_share_dir/apps/showfoto/data/logo-showfoto.png
#%_kde_share_dir/apps/showfoto/data/splash-showfoto.png
#%_kde_share_dir/apps/showfoto/showfotoui.rc
/usr/share/man/man1/digitaglinktree.1.gz
/usr/share/man/man1/cleanup_digikamdb.1.gz
%dir /usr/share/kde4/apps/solid
%dir /usr/share/kde4/apps/solid/actions
%_kde_share_dir/apps/solid/actions/digikam-opencamera.desktop
%if %suse_version < 1120
%dir /usr/share/locale/hne
%dir /usr/share/locale/hne/LC_MESSAGES
%endif
%_kde4_modules/digikamnepomukservice.so
%_kde_share_dir/services/digikamnepomukservice.desktop

%changelog
openSUSE Build Service is sponsored by