File liferea.spec of Package liferea

#
# spec file for package liferea (Version 1.4.19)
#
# Copyright (c) 2008 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild


Name:           liferea
%define xulrunner_version 190
BuildRequires:  NetworkManager-devel dbus-1-devel fdupes gcc-c++ gconf2-devel gnutls-devel gtk2-devel hicolor-icon-theme intltool libglade2-devel libnotify-devel libstdc++-devel libxslt-devel lua-devel sqlite-devel update-desktop-files
# FIXME: for libgtkhtml-devel: checking for 64bit platform... yes -> disabling GtkHTML2
License:        GPL v2 or later
Group:          Productivity/Other
Version:        1.4.19
Release:        1
Summary:        Linux Feed Reader
Source:         %{name}-%{version}.tar.bz2
Patch:          %{name}-opensuse-feeds.patch
Patch1:         %{name}-1.4.18-xulrunner-1.9.patch
Url:            http://liferea.sourceforge.net/
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Requires:       dbus-1 >= 0.30
%if %suse_version > 1010 || 0%{?opensuse_bs}
BuildRequires:  mozilla-xulrunner%{xulrunner_version}-devel
Requires:       mozilla-xulrunner%{xulrunner_version}
%else
BuildRequires:  gecko-sdk
Requires:       mozilla-xulrunner
%endif
Requires:       hicolor-icon-theme
Requires:       %{name}-lang = %{version}
AutoReqProv:    on
%gconf_schemas_prereq

%description
Liferea is an abbreviation for Linux Feed Reader. It is a news
aggregator for online news feeds. It supports a number of different
feed formats including RSS/RDF, CDF, Atom, OCS, and OPML. There are
many other news readers available, but these others are not available
for Linux or require many extra libraries to be installed. Liferea
tries to fill this gap by creating a fast, easy-to-use, easy-to-install
news aggregator for GTK and GNOME.



Authors:
--------
    Lars Lindner <lars.lindner@gmx.net>
    Nathan J. Conrad <t98502@users.sourceforge.net>

%lang_package
%prep
%setup -q
rm src/liferea
%patch
%patch1

%build
autoreconf -f -i
# I: Program is likely to break with new gcc. Try -fno-strict-aliasing.
# W: liferea strict-aliasing-punning common.c: 557
# mozsupport.cpp:91: warning: dereferencing type-punned pointer will break strict-aliasing rules
export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
export CXXFLAGS="$CFLAGS"
# FIXME: ld: .libs/liblinotifpopup_la-notif_popup.o: relocation R_X86_64_32 against `a local symbol' can not be used when making a shared object; recompile with -fPIC
export CPPFLAGS="$RPM_OPT_FLAGS -fPIC"
%configure \
        --disable-gtkhtml2 \
	--disable-gecko \
	--disable-schemas-install
make %{?jobs:-j %jobs}

%install
%makeinstall
%suse_update_desktop_file -r -N "Liferea" liferea Network X-SuSE-RSS-News
%find_lang %{name}
%find_gconf_schemas
cat %{name}.schemas_list >%{name}.lst
rm $RPM_BUILD_ROOT%{_libdir}/*/*.*a
rm doc/Makefile*
rm doc/html/Makefile*
%fdupes $RPM_BUILD_ROOT

%clean
rm -rf $RPM_BUILD_ROOT

%pre -f %{name}.schemas_pre
%posttrans -f %{name}.schemas_posttrans

%preun -f %{name}.schemas_preun

%files -f %{name}.lst
%defattr(-, root, root)
%doc AUTHORS COPYING ChangeLog NEWS README
%{_bindir}/*
%{_datadir}/applications/liferea.desktop
%{_datadir}/liferea
%{_libdir}/liferea
%{_datadir}/icons/hicolor/*/*/*.*
%doc %{_mandir}/man1/liferea.1*
%dir %{_mandir}/pl
%dir %{_mandir}/pl/man1
%doc %{_mandir}/pl/man1/liferea.1*

%files lang -f %{name}.lang

%changelog
* Tue Sep 09 2008 cthiel@suse.de
- update to version 1.4.19
  * Fixes a cache limit bug when merging items of feeds with more items than
  the cache allows.
  * Fixes po/LINGUAS which missed "hu".
  * Fixes a bug introduced with 1.4.18 which caused news bins to drop
  everything on startup.
  * Workaround for SF #1995329: Next-Unread item selection doesn't always
  work
  * Removing broken 'updated' state handling.  Manually resetting update
  states didn't work persistently. Also many users confused the 'updated'
  flag with the read status.
  * Added pownce.com social bookmarking support.
* Sun Aug 31 2008 cthiel@suse.de
- switch to xulrunner 190, thanks to Wolfgang Rosenauer!
* Fri Aug 29 2008 cthiel@suse.de
- update to version 1.4.18
  * Fixes SF #1800030: Fix date format problem in non UTF-8 locale for date
  strings representing dates older one week.
  * Fixes a bug that causes the single item removal to have no effect at
  all. This also can cause reappearing of old items and wrong unread
  counts.
  * Fixes the 100%% CPU usage of the previous versions that was cost by
  exorbitant merging costs due to the cache dropping not working anymore
  due to the item removal issue mentioned above.
* Mon Aug 04 2008 cthiel@suse.de
- update to version 1.4.17
  * Changes LUA module loading to use the default module loading function
  provided by LUA 5.1. This solves the problem that the "os" module isn't
  loaded on some setups.
  * New DB cleanup handling that removes stale rows in the "items",
  "itemsets" and "subscription" table.
  * Fixes autocommit warning during migration.
  * Fixes SF #2020621: Can't play Ogg/Vorbis audio enclosures. Now doesn't
  present XSPF for those.
  * Update of French translation
  * Update of Czech translation
  * Added new Hungarian translation
- changes in version 1.4.16b
  * Fixes SF #1990601: schema creation bug introduced in 1.4.16. Only
  affects first installations.
- changes in version 1.4.16
  * Fixed wrong language code of Czech translation.
  * Fixes SF #1920860: crash after memory corruption when parsing feed with
  invalid encoding
  * Build support for XulRunner 1.9
  * Significant speed improvement for the cache conversion necessary when
  upgrading from 1.4.9. Fixes 100%% CPU during startup problem.
  * Fixes comment removal bug.
  * Drops all comments from cache to cleanup stale comments.
  * Changes DB schema to better handle comments during item and subscription
  deletion. This makes the cache version incompatible to 1.4.15!
  * Update of French translation
* Mon Apr 28 2008 cthiel@suse.de
- update to version 1.4.15
  * Fixes assertion when creating subscriptions using the advanced
  subscription dialog.
  * Fixes Debian #433393: subscription not update anymore when number of
  flagged items = cache limit.
  * Fixes OpenSuSE #371307: possible undefined behaviour when decoding
  authentication data.
  * Fixes SF #1912774: news.yv valid feed "is not available"
  * Fixes SF #1874030: build breakage with recent WebKit versions
  * Fixes SF #1919640: segfault when 'Ctrl-R' pressed without selection
  * Merged patch from OpenBSD (SF #1924623) to correctly handle feeds served
  with non-ASCII HTTP headers.
  * Merged patch from Arnold Noronha that fixes deallocation of GdkColor
  instances.
  * Update of Portugese translation
  * New Czech translation
  * Update of Russian translation
  * Fixes Debian #475603: invalid XHTML displayed in HTML view when
  searching (Swedish only).
  * Fixes SF #1940695: crash when using Turkish translation
- changes in version 1.4.14
  * Fixes SQL join when matching item metadata in a search folder.
  * Added workaround for negative search folder unread count values.
  * Fixes Debian #469245: hanging on cache migration from 1.0 when copying
  deprecated named pipe "new_subscription"
* Tue Mar 18 2008 cthiel@suse.de
- update to version 1.4.13
  * WebKitGtk interface updates for SVN r28711.
  * Fixes SF #1886797: crash on format string
  * Fixes SF #1884048: crashes on empty comment feed URI
  * Workaround for Debian #454184: crash on startup when Gecko widget not
  visible.
- changes in version 1.4.12
  * Added support for OPML blogrolls with "xmlURL" (instead of "xmlUrl")
  feed attributes as created by LiveJournal blogroll exports.
  * Fix for missing statusbar signal.
  * Fixes SF #1879861: browser skimming hotkey doesn't work correctly when
  used in search folders.
  * Removes versioned notification plugin soname.
* Fri Jan 25 2008 cthiel@suse.de
- update to version 1.4.11
  * Fixes SF #1795739: Unread count on systray icon is wrong
  * Fixes crash when selecting news bins.
  * Fixes SF #1870052: Crash upon hitting <enter> with no headline selected
  * Fixes SF #1868054: _XOPEN_SOURCE defined incorrectly
  * Fixes SF #1868052: gmtime reentrancy problem
  * Update of European Portugese translation
  * Update of Spanish feed list translation
* Mon Dec 24 2007 cthiel@suse.de
- update to version 1.4.10
  * Fixes SF #1842579: feed:// URI handling broken for URIs without protocol
  part. Such URIs are used by Firefox 3.0
  * Fixes a memory leak in the item list loading duplicate elimination
  handling.
  * Fixes SF #1832389: cache limit causes flipping between old items
  * Fixes SF #1850139: assertion when searching for feed item
  * Fixes broken indication of updated items.
  * Fixes removal of comments along with parent items.  This was broken with
  earlier releases and causes uncontrolled DB file growth.
  * On migration from 1.4.9 or older versions it drops all comment items to
  clean up the database.
  * Update of default feed lists to be distro neutral. Removes Debian/Ubuntu
  feeds.  (patch SF #1843737)
  * Update of Brazilian Portugese translation
  * Added new European Portugese translation
  * Added new European Portugese default feed list
* Thu Dec 13 2007 cthiel@suse.de
- update to version 1.4.9
  * Adds a Ctrl-W binding to close browser tabs.
  * Fixes SF #1836691 core dump when sqlite DB file is already locked
  * Fixes a crash when marking search folders as read.
  * Fixes loose of feed description text after restarts.
  * Fixes impossible use of --version/--help when Liferea is already running
  due to wrong check order.
  * Fixes an assertion when changing search folder rules.
  * Fixes broken negative search folders rules
  * Fixes missing translation of combo boxes in preferences dialog
  * Update of Japanese translation
- changes in version 1.4.8
  * Now never loads duplicates when using recursive folder view. This avoids
  duplicate removal problems when using Mark-All-Read on such a view.
  * Fixes CVE-2005-4791: LD_LIBRARY_PATH problem in Liferea starter script.
  * Fixes SF #1832671: use default update interval even if feed specifies
  one if it is larger than the feed specific one.
  * Fixes failing DB close when terminated by session manager or
  SIGHUP/TERM/INT which causes long startup durations (>30s) on next start
  due to leftover sqlite journal file.
  * Patch SF #1835414 from goyko that improves menu enabling and disabling
  for the "Item" menu options.
  * Updated Italian translation
  * Updated Belorusian Latin translation
  * Correction for Spanish translation
- changes in version 1.4.7
  * Fixes SF #1821179 crash with Catalan locale.
  * Fixes disabled mark-all-read toolbar button when a folder is selected.
  * Fixes SF #1825113 crash when removing folders when child feeds are in
  update.
  * Fixes drag&drop into empty folders.
  * Fixes handling of updated items. Now updated items are replaced and
  marked again appropriately.
  * Fixes problems with search folders with more than one rule.
  * Added kget download manager support SF #1824344.
  * Updated Polish translation
  * Updated French translation
- changes in version 1.4.6
  * Fixes visible markup in "no title" item titles.
  * Fixes SF #1809742 unread count in tray icon not updated properly
  * Fixes Debian #445457 segfaults when clicking on empty folder
  * Fixes security issue that feedlist.opml backup file has permissions 0644
  instead if 0600.
  * Updated Japanese translation
  * Fixes Ubuntu #156303 segfault on mark-all-read
  * Build fix for NetworkManager 0.7.x
  * Fixes SF #1787007: looses user-defined feed titles on updates
- changes in version version 1.4.5b
  * Fixing wrong deallocation that prevents Liferea from working with sqlite
  3.5.x (SF #1811055).
- changes in version 1.4.5
  * Parses Atom links with rel="related" and rel="via" now and displays the
  links in the item header. This makes so called "link blogs" readable
  with Liferea (SF #1784970).
  * Fixes incorrect SQL join for search folders with multiple rules one of
  which is a node title match (SF #1803859)
  * Fixes DnD command line warnings (SF #1799006)
  * Fixes DnD target check to avoid dropping nodes into read-only source sub
  trees.
  * Fixes crash when using "Select File" from the
  advanced subscribtion dialog (SF #1810825)
  * Workaround for loosing data on forced termination.  Liferea now
  reconnects sqlite every 500 write attempts (SF #1791068, SF #1784045).
  * Fixes instant updating of the item count of search folders matching
  flagged items.
  * Adapted WebKit support to changed function names in WebKit SVN.
* Sun Oct 07 2007 cthiel@suse.de
- update to version 1.4.4
  * Removing deprecated "Encoding" entry from
  .desktop file
  * Fixed warnings/errors with "gecko" as program name. Now the correct name
  "liferea" is used.
  * Fixes assertion when cancelling feed updates using the update monitor
  dialog.
  * Fixes Debian #443751: Tries to run scripts to retrieve favicons
  * Fixes SF #1803072: Search folders broken
  * Fixes vertical/horizontal pane position saving when exiting Liferea
  while the mainwindow is not visible.
* Wed Sep 26 2007 cthiel@suse.de
- update to version 1.4.3b
  * Fixes a data loss problem that causes flagged items to be dropped out of
  cache. Normally flagged items are never to be dropped.
- changes in version 1.4.3
  * Fixes a grave bug that caused continuous feed downloads when the default
  update interval is set to 0, which is to mean disabled.
  * Fixes assertions in db_item_check() and db_query_to_sql() for search
  folders that do not have rules.
  * Fixes SF #1798880: problem when using Ctrl-u inside a search folder
  matching unread items.
  * Fixes Debian #430782: better handling of RSS 2.0 LiveJournal feeds which
  use lj: prefix for some HTML elements.
  * Fixes SF #1799476: crash when following links.
- changes in version 1.4.2b
  * Fixes compilation problems of GtkHTML2 rendering.
  * Fixes SF #1798158: problem with 'mark as read' option in popup window
  * Now removes leading/trailing white spaces from feed list node titles.
  * Fixes broken HTTP authentication. Auth info was just not passed with
  HTTP requests.
  * Fixes Debian #442798: update interval values isn't correctly updated.
  Interval unit is lost.
* Thu Sep 13 2007 cthiel@suse.de
- update to version 1.4.2, changes compared to 1.2:
  * Comment feed support: auto-downloading of comments.
  * Sqlite3 database backend for feed content storage.
  * Improved proxy support (better no-proxy support).
  * Duplicate headlines detection.
  * Automatic browser support selection (removed preference)
  * Dropped proprietary popup code in favour of libnotify solution.
  * Improved DBUS support, some new methods.
  * Added support for gwget support as download tool.
- disable gkthml2 support
* Fri Aug 31 2007 maw@suse.de
- Pass -fno-strict-aliasing to gcc as well as to g++.
* Wed Aug 08 2007 maw@suse.de
- Use %%fdupes
- Split off a -lang subpackage.
* Tue Aug 07 2007 cthiel@suse.de
- added openSUSE News feed (#293690)
* Tue Aug 07 2007 cthiel@suse.de
- exclude Makefile* (#217472)
* Tue Aug 07 2007 cthiel@suse.de
- update to version 1.2.20
  * Update of Spanish translation
  * Fixes a compilation problem on systems without
  getaddrinfo
  * Fixes a bug in the networking code
- changes in version 1.2.19
  * Fixes SF #1741243 which caused endless loops on
  LiveJournal authentication.
  * Added Brazilian-Portugese localized feed list.
- changes in version 1.2.18
  * Fixes some memory leaks
  * Improved manpage
  * Starter script support for $DEBUGGER
  * Fixed XulRunner library root compilation parameter
  * Making the tray icon transparent again when the
  "show new count" option is disabled.
- changes in version 1.2.17
  * Fixes some memory leaks
  * Fixes SF #1731789 "Open Feed" in detailed libnotify
  popup view did not work
  * Fixes SF #1736409 HTTP Digest authentication handling
  to support spaces in quoted value strings.
  * Ignores GNUTLS_E_UNEXPECTED_PACKET_LENGTH (-9)
  errors which seems to happen with GMail feeds.
  * New Czech translation
  * New Basque default feed list
- changes in version 1.2.16
  * Major code reorganisation to minimize the number
  of gettimeofday() calls which caused a lot of CPU
  activity and wakeups on laptops.
  * Fixes "jumpy" behaviour of the HTML view item menu
  in three pane mode. Now the menu is visible
  immediately on rendering.
  * Fixes a bad mistake in the timer code that caused
  a lot of unnecessary wakeups and thereby high power
  consumption on laptops.
  * New Basque translation
- changes in version 1.2.15
  * Better update result processing timer, should cause
  less CPU usage.
  * Increased security: disallowing clicking on file://
  links in the rendering widget, as well as preventing
  from opening such links using the context menu.
  * Fixes unresolved symbol in LUA binding.
  * Fixes broken base URL when selecting items in 3 pane
  mode from folders.
- changes in version 1.2.14
  * Adds network execution priviledges for the XSPF flash applet
  Liferea uses to play MP3 enclosures
  * Allowing HTTP headers with tab character at line start.
  * Fixes a crash when updating the Atom 0.3 GMail feed
  * Update of Japanese translation
- changes in version 1.2.13
  * Fixes a significant memory leak when dropping items
  from cache reported by several users.
  * Changes the new item counting to a simpler counting
  statistic so that on subsequent updates of the same
  feed might present a lower new item number, but which
  is a bit faster.
  * Added new Catalan default feed list
- changes in version 1.2.12b
  * Fix for default feed list filename used with
  Brazilian Portugese translation
  * Update of Brazilian Portugese translation
  * Adds a check to prevent loading of invalid filenames
  of localized feed lists.
- changes in version 1.2.12
  * Workaround for Gentoo bug #116797
  * Fixes possible crash when removing folders with unread items.
  * Updated Spanish translation
  * Added Catalan translation
- changes in version 1.2.11
  * Added scripting hook for program shutdown.
  * Updated French translation
  * Updated Swedish translation
  * Added Swedish default feed list
- changes in version 1.2.10c
  * Reverting fix of 1.2.10 to prevent crashes in the
  Gecko support code when clicking links in the HTML view.
  * Changed feed property label (auto-load link) to match
  real (suboptimal) behaviour when external browser
  is configured.
  * Adds a hot key (Ctrl-L) to mark all feeds as read.
  * Fixes outdated URL in the default feed lists.
  * Fixes syntax errors in some default feed lists.
  * Update of Turkish translation
- changes in version 1.2.10b
  * Fixes a crash when updating a folder recursively
  after marking all items of this folder as read.
  * Update of French translation
- changes in version 1.2.10
  * Added rendering of "creator" metadata attribute.
  * Fixes crash when removing folder with unread items.
  * Fixes links opening up in the configured external browser
  for feeds with enabled "auto load link" setting when the
  "load links in internal browser" preference is not set.
  * Fixes another negative unread count problem.
  * Update of Arabic translation
- changes in version 1.2.9
  * Fixes negative unread count problems introduced with
  the last release.
  * Lowered memory usage by correctly unloading feeds from
  memory after unselecting recursively displayed folders.
  * Improved performance by avoiding unnecessary folder load
  recursions.
  * New preference option that allows enabling the display
  of the number of new items in the tray icon.
  * New preference option that allows to disable minimizing
  to tray when closing the main window.
  * Adding DBUS introspection
  * Update of German translation
- changes in version 1.2.8
  * Adds a DBUS ping function that is used by the
  liferea-add-feed script to check if the program is running.
  * The liferea-add-feed script now starts Liferea if necessary.
  * Added 1x1 pixel filter to adblocking stylesheet.
  * Fixes SF #1668278: error when exporting the feed list
  although the export was successfully completed
  * Fixes SF #1657717: memory leak when stripping DHTML from
  HTML type metadata
  * Updated Italian translation
  * Updated Brazilian Portugese translation
  * New Swedish translation
* Mon Apr 02 2007 ro@suse.de
- added non-english manpage directories to filelist
* Fri Mar 16 2007 sbrabec@suse.cz
- Added c++ packages to BuildRequires.
* Fri Mar 09 2007 sbrabec@suse.cz
- Fixed BuildRequires to enable all features.
- Removed obsolete hicolor icon symlink (#248676).
* Thu Feb 22 2007 cthiel@suse.de
- update to version 1.2.7
  * Fixes in the feed list loading error handling.
  * Now after successful feed list import on startup a feedlist.opml backup
  file will be created.
  * Fixes LUA support detection.
- changes from 1.2.5 to 1.2.6
  * Fixes SF #1654989 that caused crashes when marking duplicate items as
  read/unread
  * Merged patch SF #1646186 by mooonz that improves LUA build support and
  allows compilation against LUA 5.0 and 5.1
  * Update of French translation
  * Update of Japanese translation
  * Conditional display of the feed title when viewing merged item lists so
  that it is clear what the source feed of a displayed item is.
  * The item view header now provides a list of the feeds that contain a
  duplicate of the feed.
  * When changing the read status of an item with duplicates in other feeds
  the read status is propagated to the other item instances.
  * Update of French translation
- changes from 1.2.4 to 1.2.5
  * Disabling GtkHTML2 support for x86_64 platforms.  Maintainers: please do
  discontinue any GtkHTML2 support on such platforms if possible, as it
  cause only trouble!
  * Removed console warning that was given on each startup as long as social
  bookmarking site was not set.
  * Fixes Debian #408475: liferea wrapper script is brittle, depends on $0
  * Fixes a type problem in the Digest authentication that caused crashes on
  AMD64 (SF #1636563)
  * Fixes for Turkish translation
  * Fixes for Arabic translation
  * New Russian translation
- changes from 1.2.3 to 1.2.4
  * Fixes a possible GUI deadlock usually happening when using the Gecko
  rendering during background feed updates.
  * Fixes a problem with relative feed base URLs.
  * Fixes broken "item unselect" script trigger.
  * Update of French translation
  * New Turkish translation
- changes from 1.2.2 to 1.2.3
  * HTML view respects GTK theme colors now.
  * Fixes negative new count values in the mainwindow status bar.
  * Fixes incorrect unread count of parent folder when removing
  subscriptions with unread items.
  * Fixes node info updating when marking read with middle mouse button in
  the feed list.
  * Fixes a bug that caused item loss in news bins.
  * Adds Arabic translation
* Thu Jan 11 2007 cthiel@suse.de
- update to version 1.2.2
  * Fixes folder expansion problem on startup: subfolders were not expanded
  at all.
  * Fixes the broken cache disabled archive mode. Feeds without caching
  should be usable again.
  * Fixes link styles in 2 pane summary mode when used with GtkHTML2.
  * Fixes an effect where items selected from a search folder are rendered
  in summary instead of detailed mode.
  * Memleak patch from Philip Withnall.
- changes from 1.2 to 1.2.1
  * Fixes a bug that prevented column resizing in the item list.
  * Fixes SF #1617434: prevents launching links in internal browser when
  using GtkHTML2.
  * Fixes SF #1620875: loosing feeds after DnD
  * Fixes recursive favicon features which didn't update favicons of feeds
  within folders.
- changes for 1.2
  * Fixes a crash when removing subscriptions.
  * Fixes suboptimal item list updating.
  * Fixes SF #1595486: items whose base URL contained an "=" character are
  not to be displayed at all.
  * Fixes SF #1617081: heavy memory leaking.
  * Suppress unknown metadata type warnings. They are now printed at trace
  level only.
  * Allow flagging by left clicking in the flag column.
  * Simple sorting feature for the item state column.
  * Makes item header links work for GtkHTML2 again.
  * Dropping ns_fm.* code as namespace is not used anymore in any feeds on
  line.
  * Added Slashdot namespace rendering again.
- numerous fixes since 1.0.20
* Thu Jan 11 2007 sbrabec@suse.cz
- Spec file cleanup.
* Thu Jan 11 2007 maw@suse.de
- Move to /usr.
* Wed Dec 20 2006 jhargadon@suse.de
- fixed an issue where liferea was being displayed twice in the
  desktop menu.  (#225609)
* Thu Nov 30 2006 sbrabec@suse.cz
- Fixed xulrunner dependencies for older products.
* Tue Nov 07 2006 sbrabec@suse.cz
- Use exact xulrunner version 181 (#216100).
* Thu Nov 02 2006 jhargadon@suse.de
- fixed a problem with LD_LIBRARY_PATH reported in bug #216105
* Fri Aug 11 2006 btimothy@suse.de
- added two (2) example feeds specific to openSUSE
  * Novell Forge : Community - SUSE LINUX
  * Planet SuSE
  * Fixes BNC #183686
* Tue Aug 08 2006 cthiel@suse.de
- update to version 1.0.20
  * The Mozilla rendering plugin now has the Mozilla library path hard coded
  to ensure to use the correct gtkmozembed library. This also means that
  there is no more searching for gtkmozembed by the start script.  This
  should fix SF #1532011 and SF #1455278.
  * Fixes SF #1529612 which causes Liferea to ignore a HTTP 301 redirect if
  it is followed by a HTTP 304.
* Tue Aug 01 2006 cthiel@suse.de
- update to version 1.0.19
  * Fixes a uninitialized value bug in the lock handling.
  * Adds a DBUS method to change the online state of Liferea
  * Fixes a possible DBUS crash by correctly initializing
  the DBUS thread handling. (SF #1523428)
  * Added a patch which solves three 64bit issue that cause crashes on AMD64
  installations.
  * Fixes some compiler warnings for the Mozilla renderer plugin.
  * Bigger update of the manpage.
* Sat Jul 22 2006 cthiel@suse.de
- update to version 1.0.18
  * Fixes SF #1526078 which caused crashes when accessing RSS 2.0 feeds
  without a channel link.
  * Avoid crashes by checking the content type of responses before parsing
  favicon image data
  * Quoting fix in the liferea start fix to make it run with Bourne shell SF
  [#1526724].
  * Compile flags fix for Solaris where -lresolv was missing SF #1526722.
  * Added a note about the DBUS interface and wrapper script to the manpage.
  * Added a gconf key to disable DBUS if necessary
  (/apps/liferea/disable-dbus).
  * Removed support for DBUS 0.23. Now the minimal DBUS dependency is 0.30.
- changes from 1.0.16 to 1.0.17
  * Added SuSE patches supplied by Christoph Thiel.
  * Fixes a possible uninitialized value in the network authentication code.
  * Partially fixes Debian #378075 reported by Daniel Jacobowitz, which
  caused the unwanted unescaping of URLs when internally launching links
  with the GtkHTML browser module.
* Thu Jul 13 2006 cthiel@suse.de
- remove unneeded liferea-64arch.patch
* Wed Jul 12 2006 cthiel@suse.de
- liferea-1.0.16-xulrunner.patch: make lifera find the xulrunner stuff
* Tue Jul 11 2006 cthiel@suse.de
- update to version 1.0.16
  * dropped obsolete liferea-xulrunner.patch
- changes from 1.0.15 to 1.0.16
  * Workaround for SF #1509741 where GtkHTML2 can cause crashes when
  reducing the zoomlevel when multi-line text is selected.
  * Fixes a significant memory leak as described in SF #1498277
- changes from 1.0.14 to 1.0.15
  * Removing confusing output line from starter script (Debian #372733)
  * Added patch SF #1504171 that fixes the problem of the headline states
  not getting updated after a feed update.
  * Added a workaround for SF #1503029 which crashes when doing HTTP digest
  authentication without a "nonce" field in the authentication data.
- changes 1.0.13 to 1.0.14
  * New wrapper script "liferea-add-feed" for the dbus-send command needed
  to add subscriptions from the command line.
  * Fixes full content display for Atom 0.3 feeds (Debian #366822).
  * Fixes the --mainwindow-state=hidden behaviour.  Until now it had the
  same effect like --mainwindow-state=iconified.
  * Update of Polish translation
  * Fixed some links in the German documentation.
- changes from 1.0.12 to 1.0.13
  * Added a patch to make the tray icon respect the GNOME panel transparency
  setting. This will only work for the most recent GNOME versions.
  * Liferea now calls res_init() to recover from disconnect situations where
  the host was moved to another network.
- changes from 1.0.11 to 1.0.12
  * XulRunner support. Liferea now provides an additional browser module
  that is for running with XulRunner. So now it can work with GtkHTML2,
  Mozilla/Firefox and XulRunner.
- changes from 1.0.10 to 1.0.11
  * Added "ins" and "del" element styles to CSS.  SF patch #1393105
  * The source package now contains a Firefox extension (feedbag.xpi) that
  changes the live bookmarks button so that it will add add subscriptions
  directly to Liferea.
  * Fixes a Atom 1.0 parsing bug when parsing plain text content.
  * Fix for SF #1480051: Avoid adding internal feed list properties when
  exporting the feed list to OPML. Also always adding a text attribute to
  each outline node.
  * Fix for SF #1479930: Liferea exited with assertion when unselecting a
  vfolder that was displayed in 2 pane mode.
- changes from 1.0.9 to 1.0.10
  * Added 64bit library path for Firefox to start script
  * Added fix a timezone parsing problem
  * Added a workaround for a problem caused by installing the gconf schemes
  from earlier Liferea version, which caused a HTML view zoom level of 0.
- changes from 1.0.8 to 1.0.9
  * Patch to prevent the invisible text problem. This happened because the
  schema default values (including the one for text zooming) could not be
  localised.
  * Update of Italian translation
- changes from 1.0.7 to 1.0.8
  * Adaption of style sheets to prevent GtkHTML2 from using the theme color
  for links.
  * Fix for a problem that did prevent opening file:// URLs with anchors in
  GtkHTML2
  * German translation of the user documentation.
  * Update of Swedish translation
- changes from 1.0.6 to 1.0.7
  * Fix crashes relating to file selection.
  * Improves all GTK 2.0 directory selection dialogs.  They no longer show
  the file selection list. It also fixes an issue with loading the last
  dirname part as the filename.
  * New Polish default feed list
  * Update of Polish translation
  * Update of Dutch translation
- changes from 1.0.5 to 1.0.6
  * The schema documentation was updated to add all still undocumented gconf
  keys.
  * Fixes a mismatch between the schema default and the preference
  preselection for the item list time column format option.
  * Update of Polish translation
  * Update of Dutch translation
  * Added Dutch default feed list
  * Added Dutch quick reference
  * Added Japanes quick reference, FAQ & help topics
- changes from 1.0.4 to 1.0.5
  * Added Dutch translation
  * Update of Brazilian Portugese translation
- changes from 1.0.3 to 1.0.4
  * Removes GDK locking to avoid freezing the program when a new browser
  window is created or a flash plugin is used. Note that this only effects
  users of the mozilla renderer and not the gtkhtml2 renderer.
  * When browsing the World Wide Web inside of Liferea, tab titles now
  change to the title of the HTML page being viewed. Also, a similar
  change was made for the location bar.
  * Fixes a crash in the Atom 1.0 parser.
  * Tray icon reports if Liferea is in offline or online mode.
  * Long headlines are now ellipsized when displayed in the item list.
  * Update of Spanish translation
  * Update of German translation
- changes from 1.0.2 to 1.0.3
  * Fixes a problem introduced with 1.0.2 that causes crashes when parsing
  Atom 1.0 feeds without proper type attributes on content tags.
- changes from 1.0.1 to 1.0.2
  * Escapes comma characters in URL so loading websites with such URLs in
  external browsers that use the X remote protocol works. (SF #1404730)
  * Atom 1.0 parsing improvements.
  * Improved zlib decompression support (SF #1411596)
  * Updated mozilla browser module source to allow compilation against
  Firefox 1.5.
- changes from 1.0 to 1.0.1
  * Fixes a compatibility issue with Firefox 1.5 that might cause crashes
  when running with both the Mozilla Suite and Firefox are installed.
  * Removes vfolder nodes when exporting the feed list. (SF #1407742)
* Sat Feb 18 2006 gekker@suse.de
- fixup .desktop file for UI team
* Sat Feb 04 2006 gekker@suse.de
- Fix to also use "." to read next unread message
* Wed Jan 25 2006 mls@suse.de
- converted neededforbuild to BuildRequires
* Tue Jan 17 2006 lmichnovic@suse.cz
- updated to version 1.0
- added section clean
- two new patches: liferea-uninitialized_var.patch, liferea-64arch.patch
* Thu Nov 03 2005 dmueller@suse.de
- don't build as root
* Thu Oct 13 2005 ro@suse.de
- use mozilla-devel-packages in nfb
- use xulrunner if others not found
* Thu Sep 29 2005 sbrabec@suse.cz
- Use secure LD_LIBRARY_PATH in wrapper (#118188).
* Tue Aug 02 2005 rodrigo@suse.de
- Updated to 0.9.4.
- Removed part of liferea-warnings.patch already fixed upstream.
- Removed liferea-0.9.2-dbus.patch.
* Mon Jun 20 2005 sbrabec@suse.cz
- Build with mozilla and dbus support.
- Fixed for new dbus.
  http://bugs.gentoo.org/show_bug.cgi?id=91928
* Tue Jun 14 2005 gekker@suse.de
- Initial import of version 0.9.2.
openSUSE Build Service is sponsored by