File perl-Sub-Uplevel.spec of Package perl-Sub-Uplevel
#
# spec file for package perl-Sub-Uplevel (Version MACRO)
#
# Copyright (c) 2010 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
# norootforbuild
# decimal versioning as used by perl
%define d_ver 0.22
# decimal dotted versioning as used by rpm
%if 0%{?suse_version} > 1010
%define dd_ver %(%{__perl} -e "print version->new(%{d_ver})->normal" | %{__sed} "s/v//")
%else
%define dd_ver 0.220.0
%endif
Name: perl-Sub-Uplevel
%define cpan_name Sub-Uplevel
Summary: Apparently run a function in a higher stack frame
Version: %{dd_ver}
Release: 2
License: GPL+ or Artistic
Group: Development/Libraries/Perl
Url: http://search.cpan.org/dist/Sub-Uplevel/
#Source: http://www.cpan.org/modules/by-module/Sub/Sub-Uplevel-%{version}.tar.gz
Source: %{cpan_name}-%{d_ver}.tar.bz2
BuildArch: noarch
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%{perl_requires}
BuildRequires: perl
BuildRequires: perl(Module::Build)
BuildRequires: perl-macros
BuildRequires: perl(Carp)
BuildRequires: perl(Test::More) >= 0.47
%description
Like Tcl's uplevel() function, but not quite so dangerous. The idea is
just to fool caller(). All the really naughty bits of Tcl's uplevel()
are avoided.
Authors:
--------
Michael G Schwern <schwern@pobox.com> (original author)
David A Golden <dagolden@cpan.org> (current maintainer)
%prep
%setup -q -n %{cpan_name}-%{d_ver}
%build
%{__perl} Build.PL installdirs=vendor
./Build build flags=%{?_smp_mflags}
%check
./Build test
%install
./Build install destdir=$RPM_BUILD_ROOT create_packlist=0
%perl_gen_filelist
%clean
%{__rm} -rf $RPM_BUILD_ROOT
%files -f %{name}.files
%defattr(-,root,root,-)
%doc Changes examples LICENSE README Todo xt
%changelog