File scpm.spec of Package scpm
#
# spec file for package scpm (Version 1.1.7)
#
# Copyright (c) 2010 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
# norootforbuild
Name: scpm
BuildRequires: doxygen gcc-c++ graphviz libjpeg-devel libpng-devel lzma mhash-devel
Summary: System Configuration Profile Management
Version: 1.1.7
Release: 6
Group: System/Base
License: GPLv2+
Source: scpm-%{version}.tar.lzma
Source1: logrotate-scpm
Patch1: scpm-fix_boot_script.patch
Patch2: scpm-1.1.7-gcc44.patch
Patch3: scpm-1.1.7-no_static_linking.patch
Patch4: scpm-fix_link_order.patch
Requires: diffutils textutils
Recommends: logrotate
Suggests: %{name}-lang
BuildRoot: %{_tmppath}/%{name}-%{version}-build
PreReq: %insserv_prereq %fillup_prereq %install_info_prereq
%description
SCPM enables your system to save different configurations in profiles.
You can boot directly into a profile as well as switch profiles at run
time. It is the successor of scheme management.
Authors:
--------
Joachim Gleissner <joe@ugh.de>
%package devel
License: GPLv2+
Summary: Header files and API documentation for SCPM
Provides: scpm:/usr/include/scpm.h
Requires: scpm
Group: Development/Libraries/C and C++
%description devel
This package is only needed if you want to compile applications that
make use of libscpm.
Authors:
--------
Joachim Gleissner <jg@suse.de>
%package lang
License: GPLv2+
Summary: Localized messages for scpm
Requires: scpm = %{version}
Group: Development/Libraries/C and C++
%description lang
This package contains the localized messages for scpm.
Authors:
--------
Joachim Gleissner <jg@suse.de>
%prep
%setup -q
%patch1 -p0
%patch2
%patch3
%patch4
%build
export CXXFLAGS="$RPM_OPT_FLAGS"
make
%install
mkdir -p $RPM_BUILD_ROOT/%{_libdir}
mkdir -p $RPM_BUILD_ROOT/%{_sbindir}
mkdir -p $RPM_BUILD_ROOT/%{_var}/lib
mkdir -p $RPM_BUILD_ROOT/%{_prefix}/include
mkdir -p $RPM_BUILD_ROOT/%{_prefix}/share/locale/de/LC_MESSAGES
mkdir -p $RPM_BUILD_ROOT/%{_prefix}/share/update-messages/en
#mkdir -p $RPM_BUILD_ROOT/etc/init.d
mkdir -p $RPM_BUILD_ROOT/%{_defaultdocdir}
mkdir -p $RPM_BUILD_ROOT/%{_infodir}
mkdir -p $RPM_BUILD_ROOT/%{_mandir}
mkdir -p $RPM_BUILD_ROOT/sbin/conf.d
mkdir -p $RPM_BUILD_ROOT/etc/logrotate.d
mkdir -p $RPM_BUILD_ROOT/var/adm/fillup-templates
make PREFIX=%{buildroot} EXEC_PREFIX=%{_prefix} install
install -m 755 -d $RPM_BUILD_ROOT/%{_defaultdocdir}/scpm
install -m 755 SuSEconfig.scpm $RPM_BUILD_ROOT/sbin/conf.d/SuSEconfig.scpm
# work around until scpm gets autoconf'd
if [ "%{_lib}" != "lib" ]; then
mv $RPM_BUILD_ROOT%{_prefix}/lib/libscpm* $RPM_BUILD_ROOT%{_libdir}
fi
install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/logrotate.d/scpm
#install -m 644 update-message $RPM_BUILD_ROOT/usr/share/update-messages/en/scpm
mkdir -p $RPM_BUILD_ROOT/var/log
touch $RPM_BUILD_ROOT/var/log/scpm
%find_lang %name
%post
/sbin/ldconfig
%{fillup_and_insserv -y boot.scpm}
%install_info --info-dir=%{_infodir} %{_infodir}/%{name}.info.gz
%postun
/sbin/ldconfig
%install_info_delete --info-dir=%{_infodir} %{_infodir}/%{name}.info.gz
%{insserv_cleanup}
%files
%defattr(-,root,root)
%config(noreplace) /etc/scpm.users
%config /etc/init.d/boot.scpm
%config /etc/logrotate.d/scpm
%config /etc/bash_completion.d/scpm_completion.sh
%{_sbindir}/scpm
/sbin/conf.d/SuSEconfig.scpm
%{_libdir}/libscpm.so.*
%{_prefix}/lib/scpm
%{_mandir}/man8/scpm.8.gz
%{_infodir}/scpm.info.gz
%doc CHANGES README
%dir /var/lib/scpm
%dir /var/lib/scpm/scdb
%dir /var/lib/scpm/profiles
%dir /var/lib/scpm/resource_sets
%dir /var/lib/scpm/resource_groups
%config /var/lib/scpm/active_groups
%config /var/lib/scpm/active_groups
%ghost /var/log/scpm
/var/adm/fillup-templates/sysconfig.scpm
%files devel
%defattr(-,root,root)
%{_includedir}/*
%{_libdir}/libscpm.so
%doc doc/api
%files lang -f %name.lang
%defattr(-,root,root)
%clean
test "$RPM_BUILD_ROOT" != "/" && rm -rf $RPM_BUILD_ROOT
%changelog