File valgrind.spec of Package valgrind

#
# spec file for package valgrind
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#



Name:           valgrind
BuildRequires:  docbook-xsl-stylesheets docbook_4 gcc-c++ glibc-devel-32bit libxslt xorg-x11-devel
%ifarch x86_64 ppc64
BuildRequires:  gcc-32bit glibc-devel-32bit
%endif
Url:            http://valgrind.org/
License:        GPLv2+
Group:          Development/Tools/Debuggers
Summary:        Memory Management Debugger
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Version:        3.6.1
Release:        1.<RELEASE14>
Source0:        %{name}-%{version}.tar.bz2
# svn  di svn://svn.valgrind.org/valgrind/tags/VALGRIND_3_5_0 svn://svn.valgrind.org/valgrind/branches/VALGRIND_3_5_BRANCH > 3_5_BRANCH.diff
# svn  di svn://svn.valgrind.org/vex/tags/VEX_3_5_0 svn://svn.valgrind.org/vex/branches/VEX_3_5_BRANCH > VEX_3_5_BRANCH.diff
Patch1:         jit-register-unregister.diff
Patch3:         valgrind-3.6.0.svn11566-s390x-port.diff
Patch5:         valgrind-vex-r2109.diff
Patch6:         valgrind-r11644.diff
Patch7:         valgrind-r11643.diff
Patch8:         valgrind-vex-r2106.diff
Patch9:         vg_bug259977_r11687.patch
Patch10:        vg_bug259977_r11688.patch
Patch11:        vg_bug259977_r11689.patch
Patch12:        vg_bug259977_r11690.patch
Patch14:        vg_bug270794_r11697.patch
Patch15:        vg_bug271042_r11699.patch
Patch16:        vg_bug271043_r11700.patch
Patch17:        vg_bug271043_r11765.patch

Patch41:        vg_bug267630_r2127.patch
Patch42:        vg_bug270851_r2130.patch
Patch43:        vg_bug270856_r2136.patch
Patch44:        vg_bug270851_r2148.patch
Patch45:        valgrind-3.6.1-kernel3.patch
Patch46:        glibc-2.14.diff
Patch47:        valgrind_r12002.diff
Patch48:        valgrind-opge.patch
# during building the major version of glibc is built into the suppression file
%define glibc_main_version %(getconf GNU_LIBC_VERSION | cut -d' ' -f2 | cut -d. -f1)
%define glibc_major_version %(getconf GNU_LIBC_VERSION | cut -d' ' -f2 | cut -d. -f2)
Requires:       glibc >= %glibc_main_version.%glibc_major_version
Requires:       glibc < %glibc_main_version.%{lua: print(rpm.expand("%glibc_major_version")+1)}
%if %suse_version <= 1100
Provides:       valgrind-devel = %version
%endif
Provides:       callgrind = %version
Obsoletes:      callgrind < %version
ExclusiveArch:  %ix86 x86_64 ppc ppc64 s390x
%if %suse_version > 1100
%define building_docs 1
%else
%define building_docs 0
%endif

%description
Valgrind checks all memory operations in an application, like read,
write, malloc, new, free, and delete. Valgrind can find uses of
uninitialized memory, access to already freed memory, overflows,
illegal stack operations, memory leaks, and any illegal
new/malloc/free/delete commands. Another program in the package is
"cachegrind," a profiler based on the valgrind engine.

To use valgrind you should compile your application with "-g -O0"
compiler options. Afterwards you can use it with:

valgrind --tool=memcheck --sloppy-malloc=yes --leak-check=yes
--db-attach=yes my_application, for example.

More valgrind options can be listed via "valgrind --help". There is
also complete documentation in the /usr/share/doc/packages/valgrind/
directory. A debugged application runs slower and needs much more
memory, but is usually still usable. Valgrind is still in development,
but it has been successfully used to optimize several KDE applications.



Authors:
--------
    Julian Seward <jseward@acm.org>
    Cerion Armour-Brown
    Jeremy Fitzhardinge
    Tom Hughes
    Nicholas Nethercote
    Paul Mackerras
    Dirk Mueller
    Robert Walsh

%if %suse_version > 1100

%package devel
License:        GPLv2+
Summary:        Memory Management Debugger
Group:          Development/Tools/Debuggers
Requires:       %name = %version

%description devel
Valgrind checks all memory operations in an application, like read,
write, malloc, new, free, and delete. Valgrind can find uses of
uninitialized memory, access to already freed memory, overflows,
illegal stack operations, memory leaks, and any illegal
new/malloc/free/delete commands. Another program in the package is
"cachegrind," a profiler based on the valgrind engine.

To use valgrind you should compile your application with "-g -O0"
compiler options. Afterwards you can use it with:

valgrind --tool=memcheck --sloppy-malloc=yes --leak-check=yes
--db-attach=yes my_application, for example.

More valgrind options can be listed via "valgrind --help". There is
also complete documentation in the /usr/share/doc/packages/valgrind/
directory. A debugged application runs slower and needs much more
memory, but is usually still usable. Valgrind is still in development,
but it has been successfully used to optimize several KDE applications.



Authors:
--------
    Julian Seward <jseward@acm.org>
    Cerion Armour-Brown
    Jeremy Fitzhardinge
    Tom Hughes
    Nicholas Nethercote
    Paul Mackerras
    Dirk Mueller
    Robert Walsh

%endif

%prep
%setup -q -n %{name}-%{version}
cd VEX
%patch5
%patch8
cd ..
%patch1
#%ifarch s390x
%patch3
#%endif
%patch6
%patch7
%patch9
%patch10
%patch11
%patch12
%patch14
%patch15
%patch16
%patch17

%patch41
%patch42
%patch43
%patch44
%patch45
%patch46
%patch47
%patch48

%build
export CFLAGS="$RPM_OPT_FLAGS"
export CXXFLAGS="$RPM_OPT_FLAGS"
autoreconf -fi
export GDB=/usr/bin/gdb
%configure
make %{?jobs:-j%jobs}
%if %building_docs
pushd docs
    #make all-docs
    # building the docs needs network access at the moment :-(
    make FAQ.txt man-pages html-docs
popd
%endif

%install
make DESTDIR=$RPM_BUILD_ROOT install
mkdir -p $RPM_BUILD_ROOT/%_defaultdocdir
if test -d $RPM_BUILD_ROOT/usr/share/doc/valgrind; then
     mv $RPM_BUILD_ROOT/usr/share/doc/valgrind $RPM_BUILD_ROOT/%_defaultdocdir
fi
mkdir -p $RPM_BUILD_ROOT/usr/share/doc/packages/%name
cp -a README* NEWS AUTHORS COPYING COPYING.DOCS $RPM_BUILD_ROOT/%_defaultdocdir/%name

%files
%defattr(-,root,root)
/usr/bin/*
%doc %_defaultdocdir/%name
%doc %_mandir/*/*
%dir %_libdir/valgrind
%ifarch x86_64
%_libdir/valgrind/*-amd64-linux
%endif
%ifarch %ix86 x86_64
%_libdir/valgrind/*-x86-linux
%endif
%ifarch ppc ppc64
%_libdir/valgrind/*-ppc32-linux
%_libdir/valgrind/*-ppc64-linux
%endif
%ifarch s390 s390x
%libdir/valgrind/*-s390x-linux
%endif
%_libdir/valgrind/*-linux.so
%_libdir/valgrind/*.supp

%if %suse_version > 1100

%files devel
%defattr(-,root,root)
%endif
%_libdir/valgrind/lib*.a
/usr/include/valgrind
/usr/%_lib/pkgconfig/valgrind.pc

%changelog
openSUSE Build Service is sponsored by