File kdegames4.spec of Package kdegames4
#
# spec file for package kdegames4
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: kdegames4
BuildRequires: fdupes
BuildRequires: ggz-client-libs-devel
BuildRequires: libkde4-devel
BuildRequires: libqca2-devel
BuildRequires: libsndfile-devel
BuildRequires: openal-soft-devel
BuildRequires: oxygen-icon-theme-large
BuildRequires: qhull-devel
%define with_python 1
%if %with_python
BuildRequires: python-kde4-devel
%if 0%{?suse_version} <= 1140
BuildRequires: python-twisted
%else
BuildRequires: python-Twisted
%endif
%endif
Version: 4.7.2
Release: 1
License: GPLv2+
Summary: General Data for KDE Games
Url: http://www.kde.org
Group: System/GUI/KDE
Source0: kdegames-%{version}.tar.bz2
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%define libname lib%{name}
%description
This package contains data which is required by the KDE games library.
%prep
%setup -q -n kdegames-%{version}
%build
%cmake_kde4 -d build --
%make_jobs
%install
cd build
%make_install
%create_subdir_filelist -d libkdegames -v libkdegames.devel
%create_subdir_filelist -d bomber
%create_subdir_filelist -d bovo
%create_subdir_filelist -d granatier
%if %with_python
%create_subdir_filelist -d kajongg
%endif
%create_subdir_filelist -d kapman
%create_subdir_filelist -d katomic
%create_subdir_filelist -d kbattleship
%create_subdir_filelist -d kblackbox
%create_subdir_filelist -d kblocks
%create_subdir_filelist -d kbounce
%create_subdir_filelist -d kbreakout
%create_subdir_filelist -d kdiamond
%create_subdir_filelist -d kfourinline
%create_subdir_filelist -d kgoldrunner
%create_subdir_filelist -d kigo
%create_subdir_filelist -d killbots
%create_subdir_filelist -d kiriki
%create_subdir_filelist -d kjumpingcube
%create_subdir_filelist -d klickety
%create_subdir_filelist -d klines
%create_subdir_filelist -d kmahjongg
%create_subdir_filelist -d libkmahjongg -f kmahjongg
%create_subdir_filelist -d kmines
%create_subdir_filelist -d knetwalk
%create_subdir_filelist -d kolf
%create_subdir_filelist -d kollision
%create_subdir_filelist -d konquest
%create_subdir_filelist -d kpat
%create_subdir_filelist -d kreversi
%create_subdir_filelist -d kshisen
%create_subdir_filelist -d ksirk
%create_subdir_filelist -d kspaceduel
%create_subdir_filelist -d ksquares
%create_subdir_filelist -d ksudoku
%create_subdir_filelist -d ktuberling
%create_subdir_filelist -d ktron
%create_subdir_filelist -d kubrick
%create_subdir_filelist -d lskat
%create_subdir_filelist -d palapeli -v libkdegames.devel
cd ..
sed -ri s,.*%{_kde4_appsdir}/carddecks.*,, filelists/libkdegames
%suse_update_desktop_file -r granatier Game ArcadeGame
%if %with_python
%suse_update_desktop_file -r kajongg Game BoardGame
chmod a+x %{buildroot}%{_kde4_appsdir}/kajongg/deferredutil.py
chmod a+x %{buildroot}%{_kde4_appsdir}/kajongg/server.py
%else
rm -rf %{buildroot}%{_kde4_htmldir}/en/kajongg
%endif
%suse_update_desktop_file -r kapman Game ArcadeGame
%suse_update_desktop_file -r katomic Game LogicGame
%suse_update_desktop_file -r kbattleship Game BoardGame
%suse_update_desktop_file -r kblackbox Game BoardGame
%suse_update_desktop_file -r kbounce Game LogicGame
%suse_update_desktop_file -r kfourinline Game BoardGame
%suse_update_desktop_file -r KGoldrunner Game ArcadeGame
%suse_update_desktop_file -r kigo Game BoardGame
%suse_update_desktop_file -r kiriki Game BoardGame
%suse_update_desktop_file -r klickety Game LogicGame
%suse_update_desktop_file -r klines Game LogicGame
%suse_update_desktop_file -r kmahjongg Game BoardGame
%suse_update_desktop_file -r kmines Game LogicGame
%suse_update_desktop_file -r knetwalk KNetwalk "Tactical Game" Game LogicGame
%suse_update_desktop_file -r kolf Game SportsGame
%suse_update_desktop_file -r konquest Game LogicGame
%suse_update_desktop_file -r kpat Game CardGame
%suse_update_desktop_file -r kreversi Game BoardGame
%suse_update_desktop_file -r kshisen Game BoardGame
%suse_update_desktop_file -r kspaceduel Game ArcadeGame
%suse_update_desktop_file -r ksquares Game BoardGame
%suse_update_desktop_file -G "Sudoku Puzzles" ksudoku Game LogicGame
%suse_update_desktop_file -r ktuberling Game KidsGame
%suse_update_desktop_file -r lskat Game CardGame
%suse_update_desktop_file -r palapeli Game BoardGame
%kde_post_install
%fdupes -s %{buildroot}
%package -n %{libname}
License: LGPLv2.1+
Summary: Library for KDE Games
Group: Development/Libraries/KDE
Requires: ggz-client-libs
Requires: %{name}-carddecks-default = %{version}
Recommends: %{name}-carddecks-other = %{version}
Obsoletes: %{name} < %{version}
Provides: %{name} = %{version}
%kde4_runtime_requires
%description -n %{libname}
This package contains the KDE games library.
%package -n %{libname}-devel
License: LGPLv2.1+
Summary: Library for KDE Games: Build Environment
Group: Development/Libraries/KDE
Requires: libkde4-devel
Requires: %{libname} = %{version}
%description -n %{libname}-devel
This package contains all necessary files and libraries needed to
develop KDE games.
%package carddecks-default
License: LGPLv2.1+
Summary: Default Card Decks for KDE Games
Group: System/GUI/KDE
Requires: %{libname} = %{version}
Suggests: carddecks-other = %{version}
BuildArch: noarch
%description carddecks-default
This package contains the default card deck set for KDE games.
%package carddecks-other
License: LGPLv2.1+
Summary: Further Card Decks for KDE Games
Group: System/GUI/KDE
Requires: %{name}-carddecks-default = %{version}
BuildArch: noarch
%description carddecks-other
This package contains several further card deck sets for KDE games.
%package -n bomber
License: GPLv2+
Summary: Invading cities with a plane
Group: Amusements/Games/Action/Arcade
Requires: %{libname} >= %{version}
Provides: kde4-bomber = 4.3.0
Obsoletes: kde4-bomber < 4.3.0
%kde4_runtime_requires
%description -n bomber
Bomber is a single player arcade game. The player is invading various cities
in a plane that is decreasing in height.
The goal of the game is to destroy all the buildings and advance to the next
level. Each level gets a harder by increasing the speed of the plane and the
height of the buildings.
%package -n bovo
License: GPLv2+
Summary: Five-in-a-row board game
Group: Amusements/Games/Board/Other
Requires: %{libname} >= %{version}
Provides: kde4-bovo = 4.3.0
Obsoletes: kde4-bovo < 4.3.0
%kde4_runtime_requires
%description -n bovo
Bovo is a Gomoku (Also known as: Connect Five, Five in a row, X and O,
Naughts and Crosses) like game for two players, where the opponents
alternate in placing their respective pictogram on the game board.
%package -n granatier
License: GPLv2+
Summary: Bomberman-like game
Group: Amusements/Games/Action/Arcade
Requires: %{libname} >= %{version}
Provides: kde4-granatier = 4.3.0
Obsoletes: kde4-granatier < 4.3.0
%kde4_runtime_requires
%description -n granatier
Walk through an arena, lay bombs and kill your enemies.
Granatier is a clone of the classic Bomberman game,
inspired by the work of the Clanbomber clone.
%package -n kajongg
License: GPLv2+
Summary: 4 Player Mahjongg game
Group: Amusements/Games/Board/Other
Requires: %{libname} >= %{version}
Requires: python-kde4
Requires: python-twisted
Provides: kde4-kmahjongg = 4.3.0
Obsoletes: kde4-kmahjongg < 4.3.0
%kde4_runtime_requires
%description -n kajongg
Kajongg is the ancient Chinese board game for 4 players. Kajongg can be
used in two different ways: Scoring a manual game where you play as
always and use Kajongg for the computation of scores and for bookkeeping.
Or you can use Kajongg to play against any combination of other human
players or computer players.
%package -n kapman
License: GPLv2+
Summary: Pac-Man-like game for KDE
Group: Amusements/Games/Action/Arcade
Requires: %{libname} >= %{version}
Provides: kde4-kapman = 4.3.0
Obsoletes: kde4-kapman < 4.3.0
%kde4_runtime_requires
%description -n kapman
Kapman is a clone of the well known game Pac-Man. You must go
through the levels escaping ghosts in a maze. You lose a life
when a ghost eats you, but you can eat the ghosts for a few
seconds when eating an energizer.
You win points when eating pills, energizers, and bonus, and you
win one life for each 10,000 points. When you have eaten all the
pills and energizers of a level, you go to the next level, and the
player and ghost speeds increase. The game ends when you have lost
all your lives.
%package -n katomic
License: GPLv2+
Summary: Sokoban-like logic game
Group: Amusements/Games/Board/Puzzle
Requires: %{libname} >= %{version}
Provides: kde4-katomic = 4.3.0
Obsoletes: kde4-katomic < 4.3.0
%kde4_runtime_requires
%description -n katomic
KAtomic is a thinking game where you have to form chemical molecules
out of atoms. This is done with a nice graphical interface where you
can move each atom in a labyrinth.
%package -n kblackbox
License: GPLv2+
Summary: Blackbox logic game
Group: Amusements/Games/Board/Puzzle
Requires: %{libname} >= %{version}
Provides: kde4-kblackbox = 4.3.0
Obsoletes: kde4-kblackbox < 4.3.0
%kde4_runtime_requires
%description -n kblackbox
KBlackbox is a game of hide and seek played on a grid
of boxes where the computer has hidden several balls.
The position of the hidden balls can be deduced by
shooting beams into the box.
%package -n kblocks
License: LGPLv2.1+
Summary: Classic falling blocks game
Group: Amusements/Games/Logic
Requires: %{libname} >= %{version}
Provides: kde4-kblocks = 4.3.0
Obsoletes: kde4-kblocks < 4.3.0
%kde4_runtime_requires
%description -n kblocks
KBlocks is the KDE version of the classic falling blocks game.
The idea is to stack the falling blocks to create horizontal
lines without any gaps. When a line is completed it is removed,
and more space is available in the play area. When there is not
enough space for blocks to fall, the game is over.
%package -n kbounce
License: GPLv2+
Summary: Ball bouncing game
Group: Amusements/Games/Action/Other
Requires: %{libname} >= %{version}
Provides: kde4-kbounce = 4.3.0
Obsoletes: kde4-kbounce < 4.3.0
%kde4_runtime_requires
%description -n kbounce
Your task in KBounce (Jezz Ball) is to catch several moving balls in a
rectangular game field by building walls. The motivation consists of
finding new and advanced strategies to catch as many balls as possible.
%package -n kbreakout
License: LGPLv2.1+
Summary: Breakout-like game for KDE
Group: Amusements/Games/Action/Breakout
Requires: %{libname} >= %{version}
Provides: kde4-kbreakout = 4.3.0
Obsoletes: kde4-kbreakout < 4.3.0
%kde4_runtime_requires
%description -n kbreakout
KBreakout is the KDE version of a Breakout-like game. Its object
is to destroy as many bricks as possible without losing the ball.
%package -n kdiamond
License: LGPLv2.1+
Summary: Three-in-a-row game
Group: Amusements/Games/Logic
Requires: %{libname} >= %{version}
Provides: kde4-kdiamond = 4.3.0
Obsoletes: kde4-kdiamond < 4.3.0
%kde4_runtime_requires
%description -n kdiamond
KDiamond is a single player puzzle game. The object of the
game is to build lines of three similar diamonds.
%package -n kfourinline
License: GPLv2+
Summary: Four-in-a-row board game
Group: Amusements/Games/Board/Other
Requires: %{libname} >= %{version}
Provides: kde4-kfourinline = 4.3.0
Obsoletes: kde4-kfourinline < 4.3.0
%kde4_runtime_requires
%description -n kfourinline
KFourInLine is a board game for two players based on the Connect-Four game.
The players try to build up a row of four pieces using different strategies.
%package -n kgoldrunner
License: GPLv2+
Summary: Hunt gold, dodge enemies & solve puzzles
Group: Amusements/Games/Action/Arcade
Requires: %{libname} >= %{version}
Provides: kde4-kgoldrunner = 4.3.0
Obsoletes: kde4-kgoldrunner < 4.3.0
%kde4_runtime_requires
%description -n kgoldrunner
KGoldrunner is a maze-threading game with a puzzle flavor.
It has hundreds of levels where pieces of gold must be collected,
with enemies in hot pursuit.
%package -n kigo
License: GPLv2+
Summary: Traditional Chinese Boardgame
Group: Amusements/Games/Board/Other
Requires: gnugo
Requires: %{libname} >= %{version}
Provides: kde4-kigo = 4.3.0
Obsoletes: kde4-kigo < 4.3.0
Suggests: kigo-doc = %{version}
%kde4_runtime_requires
%description -n kigo
Kigo is an open-source implementation of the popular Go game. Go is a
strategic board game for two players (also known as igo, weiqi,
wei ch'i or baduk). Go is noted for being rich in strategic complexity
despite its simple rules. The game is played by two players who
alternately place black and white stones on the vacant intersections
of a grid of 19x19 lines (9x9 or 13x13 for easier games). Go is noted
for being rich in strategic complexity despite its simple rules.
%package -n kigo-doc
License: GPLv2+
Summary: Documentation for kigo
Group: Amusements/Games/Board/Other
Requires: kigo = %{version}
%kde4_runtime_requires
%description -n kigo-doc
This package contains documentation and help files for kigo
%package -n killbots
License: GPLv2+
Summary: Robots-like game for KDE
Group: Amusements/Games/Action/Arcade
Requires: %{libname} >= %{version}
Provides: kde4-killbots = 4.3.0
Obsoletes: kde4-killbots < 4.3.0
%kde4_runtime_requires
%description -n killbots
Killbots is a simple game of evading killer robots. Who created the robots
and why they have been programmed to destroy, no one knows. All that is
known is that the robots are numerous and their sole objective is to
destroy you. Fortunately for you, their creator has focused on quantity
rather than quality and as a result the robots are severely lacking in
intelligence. Your superior wit and a fancy teleportation device are your
only weapons against the never-ending stream of mindless automatons.
%package -n kiriki
License: GPLv2+
Summary: Yahtzee-like dice game
Group: Amusements/Games/Board/Other
Requires: %{libname} >= %{version}
Provides: kde4-kiriki = 4.3.0
Obsoletes: kde4-kiriki < 4.3.0
%kde4_runtime_requires
%description -n kiriki
Kiriki is an addictive and fun dice game, designed to be played by as many
as six players. Participants have to collect points by rolling five dice for
up to three times per single turn.
%package -n kjumpingcube
License: GPLv2+
Summary: Territory game
Group: Amusements/Games/Board/Other
Requires: %{libname} >= %{version}
Provides: kde4-kjumpingcube = 4.3.0
Obsoletes: kde4-kjumpingcube < 4.3.0
%kde4_runtime_requires
%description -n kjumpingcube
KJumpingCube is a simple dice driven tactical game. The playing area
consists of squares containing points. Players move by clicking on
either a vacant square, or on their own square, in an attempt to
increase their territory and ultimately take over the entire board.
%package -n klickety
License: GPLv2+
Summary: Strategic board game
Group: Amusements/Games/Logic
Requires: %{libname} >= %{version}
Provides: kde4-ksame = 4.3.0
Obsoletes: kde4-ksame < 4.3.0
Provides: ksame = 4.5.60
Obsoletes: ksame < 4.5.60
%kde4_runtime_requires
%description -n klickety
Klickety is an adaptation of the Clickomania and SameGame games.
It is simple, yet challenging color matching game. The idea is
to completely clear the game board filled with the colored
tiles by removing groups of adjoining tiles of the same color
%package -n kmahjongg
License: GPLv2+
Summary: Mahjongg solitaire game
Group: Amusements/Games/Board/Puzzle
Requires: %{libname} >= %{version}
Provides: kde4-kmahjongg = 4.3.0
Obsoletes: kde4-kmahjongg < 4.3.0
%kde4_runtime_requires
%description -n kmahjongg
KMahjongg is a clone of the well known tile based patience game of the
same name. In the game you have to empty a game board filled with pieces
by removing pieces of the same type.
%package -n kmines
License: GPLv2+
Summary: Minesweeper-like game
Group: Amusements/Games/Board/Puzzle
Requires: %{libname} >= %{version}
Provides: kde4-kmines = 4.3.0
Obsoletes: kde4-kmines < 4.3.0
Provides: kdegames3:/opt/kde3/bin/kmines
%kde4_runtime_requires
%description -n kmines
KMines is a classic Minesweeper game. The idea is to use logic to uncover
all the squares without blowing up any mines. When a mine is blown up,
the game is over.
%package -n knetwalk
License: GPLv2+
Summary: Network construction game
Group: Amusements/Games/Logic
Requires: %{libname} >= %{version}
Provides: kde4-knetwalk = 4.3.0
Obsoletes: kde4-knetwalk < 4.3.0
%kde4_runtime_requires
%description -n knetwalk
KNetWalk is a small game where you have to build up a computer network
by rotating the wires to connect the terminals to the server. When the
network is build, a highscore-list comes up where competitions can be
fought out.
%package -n kolf
License: GPLv2+
Summary: Miniature golf game
Group: Amusements/Games/Other
Requires: %{libname} >= %{version}
Provides: kde4-kolf = 4.3.0
Obsoletes: kde4-kolf < 4.3.0
%kde4_runtime_requires
%description -n kolf
Kolf is a miniature golf game. The game is played from an overhead view,
with a short bar representing the golf club. Kolf features many different
types of objects, such water hazards, slopes, sand traps, and black holes
(warps), among others.
%package -n kollision
License: LGPLv2.1+
Summary: Simple ball dodging game
Group: Amusements/Games/Action/Arcade
Requires: %{libname} >= %{version}
Provides: kde4-kollision = 4.3.0
Obsoletes: kde4-kollision < 4.3.0
%kde4_runtime_requires
%description -n kollision
KDE version of a classic arcade game where you move a ball
around to avoid colliding with bouncing balls.
%package -n kolorlines
License: GPLv2+
Summary: Tactical game
Group: Amusements/Games/Logic
Requires: %{libname} >= %{version}
Provides: kde4-klines = 4.3.0
Obsoletes: kde4-klines < 4.3.0
Provides: klines = 4.7.1
Obsoletes: klines < 4.7.1
%kde4_runtime_requires
%description -n kolorlines
Kolor Lines is a simple but highly addictive one player game. The player
has to move the colored balls around the game board, gathering them into
the lines of the same color by five. Once the line is complete it is
removed from the board, therefore freeing precious space. In the same
time the new balls keep arriving by three after each move, filling up
the game board.
%package -n konquest
License: GPLv2+
Summary: Galactic strategy game
Group: Amusements/Games/Strategy/Turn Based
Requires: %{libname} >= %{version}
Provides: kde4-konquest = 4.3.0
Obsoletes: kde4-konquest < 4.3.0
%kde4_runtime_requires
%description -n konquest
This the KDE version of Gnu-Lactic Konquest, a multi-player strategy
game. Players conquer other planets by sending ships to them. The goal
is to build an interstellar empire and ultimately conquer all other
player's planets.
%package -n kpat
License: GPLv2+
Summary: Patience solitaire card game
Group: Amusements/Games/Board/Card
Requires: %{libname} >= %{version}
Provides: kde4-kpat = 4.3.0
Obsoletes: kde4-kpat < 4.3.0
%kde4_runtime_requires
%description -n kpat
KPatience is a collection of various patience solitaire games known all
over the world. It includes Klondike, Freecell, Yukon, Forty and Eight
and many more. The game has nice graphics and many different card decks.
%package -n kreversi
License: GPLv2+
Summary: Reversi board game
Group: Amusements/Games/Board/Other
Requires: %{libname} >= %{version}
Provides: kde4-kreversi = 4.3.0
Obsoletes: kde4-kreversi < 4.3.0
Suggests: kreversi-doc = %{version}
%kde4_runtime_requires
%description -n kreversi
KReversi is a simple one player strategy game played against the computer.
If a player's piece is captured by an opposing player, that piece is
turned over to reveal the color of that player. A winner is declared when
one player has more pieces of his own color on the board and there are no
more possible moves.
%package -n kreversi-doc
License: GPLv2+
Summary: Documentation for kreversi
Group: Amusements/Games/Board/Other
Requires: kreversi = %{version}
%kde4_runtime_requires
%description -n kreversi-doc
This package contains documentation and help files for kreversi
%package -n kshisen
License: GPLv2+
Summary: Shisen-sho mahjongg-like tile game
Group: Amusements/Games/Board/Puzzle
Requires: %{libname} >= %{version}
Provides: kde4-kshisen = 4.3.0
Obsoletes: kde4-kshisen < 4.3.0
%kde4_runtime_requires
%description -n kshisen
Shisen-Sho (KShishen) is a game similar to Mahjongg. KShisen is a
solitaire-like game played using the standard set of Mahjong tiles.
Unlike Mahjong however, KShisen has only one layer of scrambled tiles,
and matching tiles need paths between them in order to be removed.
%package -n ksirk
License: LGPLv2.1+
Summary: World domination strategy game for KDE
Group: Amusements/Games/Strategy/Turn Based
Requires: %{libname} >= %{version}
Provides: kde4-ksirk = 4.3.0
Obsoletes: kde4-ksirk < 4.3.0
%kde4_runtime_requires
%description -n ksirk
KsirK is a computerized version of the well known strategic board
game Risk. The goal of the game is simply to conquer the world by
attacking your neighbors with your armies.
The game can also be played with friends online via the internet.
%package -n ksnakeduel
License: GPLv2+
Summary: Tron-like game
Group: Amusements/Games/Action/Arcade
Requires: %{libname} >= %{version}
Provides: kde4-ktron = 4.3.0
Obsoletes: kde4-ktron < 4.3.0
Provides: ktron = 4.7.1
Obsoletes: ktron < 4.7.1
%kde4_runtime_requires
%description -n ksnakeduel
KTron is a simple Tron-Clone You can play KTron against
the computer or a friend. The aim of the game is to live
longer than your opponent. To do that, avoid running into
a wall, your own tail and that of your opponent.
%package -n kspaceduel
License: GPLv2+
Summary: Space arcade game
Group: Amusements/Games/Action/Arcade
Requires: %{libname} >= %{version}
Provides: kde4-kspaceduel = 4.3.0
Obsoletes: kde4-kspaceduel < 4.3.0
%kde4_runtime_requires
%description -n kspaceduel
KSpaceduel is a space arcade game for two players. However, one player
can be controlled by the computer. Each player controls a satellite
spaceship orbiting the sun. As the game progresses players have to
eliminate the opponent's spacecraft with bullets or mines.
%package -n ksquares
License: GPLv2+
Summary: Connect the dots to create squares
Group: Amusements/Games/Board/Other
Requires: %{libname} >= %{version}
Provides: kde4-ksquares = 4.3.0
Obsoletes: kde4-ksquares < 4.3.0
%kde4_runtime_requires
%description -n ksquares
KSquares is a game modeled after the well known pen and paper based game
of Dots and Boxes. Each player takes it in turns to draw a line between
two adjacent dots on the board. The objective is to complete more squares
than your opponents.
%package -n ksudoku
License: GPLv2+
Summary: Generate and Solve Sudoku Puzzles in 2D or 3D
Group: Amusements/Games/Logic
Requires: %{libname} >= %{version}
Provides: kde4-ksudoku = 4.3.0
Obsoletes: kde4-ksudoku < 4.3.0
%kde4_runtime_requires
%description -n ksudoku
KSudoku is a program that can generate and solve sudoku puzzles. The
word Sudoku means "single number in an allotted place" in Japanese. Some
cells are filled with a number at the beginning: the remaining are to
be filled by the player using numbers from 1 to 9, without repeating a
number twice on each column, row, or subsquare.
%package -n kubrick
License: LGPLv2.1+
Summary: 3-D game based on Rubik's Cube
Group: Amusements/Games/Logic
Requires: %{libname} >= %{version}
Provides: kde4-kubrick = 4.3.0
Obsoletes: kde4-kubrick < 4.3.0
%kde4_runtime_requires
%description -n kubrick
Kubrick is a game based on the Rubik's Cubeā¢ puzzle. The cube
sizes range from 2x2x2 up to 6x6x6, or you can play with
irregular "bricks" such as 5x3x2 or "mats" such as 6x4x1 or
2x2x1. The game has a selection of puzzles at several levels of
difficulty, as well as demos of pretty patterns and solution
moves, or you can make up your own puzzles.
%package -n lskat
License: GPLv2+
Summary: German skat card game
Group: Amusements/Games/Board/Card
Requires: %{libname} >= %{version}
Provides: kde4-lskat = 4.3.0
Obsoletes: kde4-lskat < 4.3.0
%kde4_runtime_requires
%description -n lskat
Lieutnant Skat (from German "Offiziersskat") is a fun and engaging card
game for two players, where the second player is either live opponent,
or a built in artificial intelligence.
%package -n navalbattle
License: GPLv2+
Summary: Ship sinking game
Group: Amusements/Games/Board/Other
Requires: %{libname} >= %{version}
Provides: kde4-kbattleship = 4.3.0
Obsoletes: kde4-kbattleship < 4.3.0
Provides: kbattleship = 4.7.1
Obsoletes: kbattleship < 4.7.1
%kde4_runtime_requires
%description -n navalbattle
Naval Battle is a Battle Ship game for KDE. Ships are placed on a
board which represents the sea. Players try to hit each others
ships in turns without knowing where they are placed. The first
player to destroy all ships wins the game.
The game can also be played with friends online via the internet.
%package -n palapeli
License: LGPLv2.1+
Summary: Jigsaw puzzle game
Group: Amusements/Games/Board/Puzzle
Requires: %{libname} >= %{version}
Requires: palapeli-data = %{version}
Provides: kde4-palapeli = 4.3.0
Obsoletes: kde4-palapeli < 4.3.0
%kde4_runtime_requires
%description -n palapeli
Palapeli is a single-player jigsaw puzzle game. Unlike other
games in that genre, you are not limited to aligning pieces
on imaginary grids. The pieces are freely moveable. Also,
Palapeli features real persistency, i.e. everything you do
is saved on your disk immediately.
%package -n palapeli-data
License: GPLv2+
Summary: Palapeli's standard puzzle files
Group: Amusements/Games/Board/Puzzle
Requires: palapeli = %{version}
BuildArch: noarch
%description -n palapeli-data
This package contains the standard puzzle files for Palapeli.
%package -n potatoguy
License: GPLv2+
Summary: Picture game for children
Group: Amusements/Toys/Other
Requires: %{libname} >= %{version}
Provides: kde4-ktuberling = 4.3.0
Obsoletes: kde4-ktuberling < 4.3.0
%kde4_runtime_requires
%description -n potatoguy
Potato guy is a nice potato editor for kids. The game intended for
small children. Of course, it may be suitable for adults who have
remained young at heart. Eyes, mouths, mustaches, and other parts of
face and goodies can be attached onto a potato-like guy.
%post -n %{libname} -p /sbin/ldconfig
%postun -n %{libname} -p /sbin/ldconfig
%post -n %{libname}-devel -p /sbin/ldconfig
%postun -n %{libname}-devel -p /sbin/ldconfig
%post -n bomber -p /sbin/ldconfig
%postun -n bomber -p /sbin/ldconfig
%post -n bovo -p /sbin/ldconfig
%postun -n bovo -p /sbin/ldconfig
%post -n granatier -p /sbin/ldconfig
%postun -n granatier -p /sbin/ldconfig
%post -n kapman -p /sbin/ldconfig
%postun -n kapman -p /sbin/ldconfig
%post -n katomic -p /sbin/ldconfig
%postun -n katomic -p /sbin/ldconfig
%post -n kblackbox -p /sbin/ldconfig
%postun -n kblackbox -p /sbin/ldconfig
%post -n kblocks -p /sbin/ldconfig
%postun -n kblocks -p /sbin/ldconfig
%post -n kbounce -p /sbin/ldconfig
%postun -n kbounce -p /sbin/ldconfig
%post -n kbreakout -p /sbin/ldconfig
%postun -n kbreakout -p /sbin/ldconfig
%post -n kdiamond -p /sbin/ldconfig
%postun -n kdiamond -p /sbin/ldconfig
%post -n kfourinline -p /sbin/ldconfig
%postun -n kfourinline -p /sbin/ldconfig
%post -n kgoldrunner -p /sbin/ldconfig
%postun -n kgoldrunner -p /sbin/ldconfig
%post -n kigo -p /sbin/ldconfig
%postun -n kigo -p /sbin/ldconfig
%post -n killbots -p /sbin/ldconfig
%postun -n killbots -p /sbin/ldconfig
%post -n kiriki -p /sbin/ldconfig
%postun -n kiriki -p /sbin/ldconfig
%post -n klickety -p /sbin/ldconfig
%postun -n klickety -p /sbin/ldconfig
%post -n kmahjongg -p /sbin/ldconfig
%postun -n kmahjongg -p /sbin/ldconfig
%post -n kmines -p /sbin/ldconfig
%postun -n kmines -p /sbin/ldconfig
%post -n knetwalk -p /sbin/ldconfig
%postun -n knetwalk -p /sbin/ldconfig
%post -n kolf -p /sbin/ldconfig
%postun -n kolf -p /sbin/ldconfig
%post -n kollision -p /sbin/ldconfig
%postun -n kollision -p /sbin/ldconfig
%post -n kolorlines -p /sbin/ldconfig
%postun -n kolorlines -p /sbin/ldconfig
%post -n konquest -p /sbin/ldconfig
%postun -n konquest -p /sbin/ldconfig
%post -n kpat -p /sbin/ldconfig
%postun -n kpat -p /sbin/ldconfig
%post -n kreversi -p /sbin/ldconfig
%postun -n kreversi -p /sbin/ldconfig
%post -n kshisen -p /sbin/ldconfig
%postun -n kshisen -p /sbin/ldconfig
%post -n ksirk -p /sbin/ldconfig
%postun -n ksirk -p /sbin/ldconfig
%post -n ksnakeduel -p /sbin/ldconfig
%postun -n ksnakeduel -p /sbin/ldconfig
%post -n kspaceduel -p /sbin/ldconfig
%postun -n kspaceduel -p /sbin/ldconfig
%post -n ksquares -p /sbin/ldconfig
%postun -n ksquares -p /sbin/ldconfig
%post -n ksudoku -p /sbin/ldconfig
%postun -n ksudoku -p /sbin/ldconfig
%post -n kubrick -p /sbin/ldconfig
%postun -n kubrick -p /sbin/ldconfig
%post -n lskat -p /sbin/ldconfig
%postun -n lskat -p /sbin/ldconfig
%post -n palapeli -p /sbin/ldconfig
%postun -n palapeli -p /sbin/ldconfig
%post -n potatoguy -p /sbin/ldconfig
%postun -n potatoguy -p /sbin/ldconfig
%post -n navalbattle -p /sbin/ldconfig
%postun -n navalbattle -p /sbin/ldconfig
%files -n %{libname} -f filelists/libkdegames
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%dir %{_kde4_appsdir}/kdegames
%dir %{_kde4_appsdir}/kdegames/pics
%exclude %{_kde4_appsdir}/carddecks
%files -n %{libname}-devel -f filelists/libkdegames.devel
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%dir %{_includedir}/highscore
%dir %{_includedir}/KDE/KGame
%dir %{_includedir}/digits
%dir %{_includedir}/kgame
%dir %{_includedir}/kggzgames
%dir %{_includedir}/kggzmod
%dir %{_includedir}/kggznet
%dir %{_includedir}/Pala
%dir %{_includedir}/libpala
%{_includedir}/*kmahjongg*
%{_kde4_libdir}/libkolfprivate.so
%{_kde4_libdir}/libiris_ksirk.so
%{_kde4_libdir}/libkmahjongglib.so
%{_kde4_appsdir}/cmake/modules/FindLibKDEGames.cmake
%{_kde4_appsdir}/cmake/modules/GGZ.cmake
%files carddecks-default
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%{_kde4_appsdir}/carddecks/decks
%{_kde4_appsdir}/carddecks/svg-oxygen-air
%{_kde4_appsdir}/carddecks/svg-ancient-egyptians
%files carddecks-other
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%exclude %{_kde4_appsdir}/carddecks/decks
%exclude %{_kde4_appsdir}/carddecks/svg-oxygen-air
%exclude %{_kde4_appsdir}/carddecks/svg-ancient-egyptians
%{_kde4_appsdir}/carddecks
%files -n bomber -f filelists/bomber
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%files -n bovo -f filelists/bovo
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%files -n granatier -f filelists/granatier
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%if %with_python
%files -n kajongg -f filelists/kajongg
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%endif
%files -n kapman -f filelists/kapman
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%dir %{_datadir}/sounds/kapman
%files -n katomic -f filelists/katomic
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%files -n kblackbox -f filelists/kblackbox
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%files -n kblocks -f filelists/kblocks
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%files -n kbounce -f filelists/kbounce
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%files -n kbreakout -f filelists/kbreakout
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%files -n kdiamond -f filelists/kdiamond
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%files -n kfourinline -f filelists/kfourinline
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%files -n kgoldrunner -f filelists/kgoldrunner
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%files -n kigo -f filelists/kigo
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%exclude %{_kde4_htmldir}/en/kigo/
%files -n kigo-doc
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%doc %{_kde4_htmldir}/en/kigo/
%files -n killbots -f filelists/killbots
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%dir %{_kde4_appsdir}/kmahjongglib/backgrounds
%dir %{_kde4_appsdir}/kmahjongglib/tilesets
%files -n kiriki -f filelists/kiriki
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%files -n kjumpingcube -f filelists/kjumpingcube
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%files -n klickety -f filelists/klickety
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%files -n kmahjongg -f filelists/kmahjongg
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%dir %{_kde4_appsdir}/kmahjongglib
%exclude %{_includedir}/*kmahjongg*
%exclude %{_kde4_libdir}/libkmahjongglib.so
%files -n kmines -f filelists/kmines
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%config %{_kde4_configdir}/kmines.knsrc
%files -n knetwalk -f filelists/knetwalk
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%files -n kolf -f filelists/kolf
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%exclude %{_kde4_libdir}/libkolfprivate.so
%files -n kollision -f filelists/kollision
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%files -n kolorlines -f filelists/klines
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%files -n konquest -f filelists/konquest
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%files -n kpat -f filelists/kpat
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%files -n kreversi -f filelists/kreversi
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%exclude %{_kde4_htmldir}/en/kreversi/
%files -n kreversi-doc
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%doc %{_kde4_htmldir}/en/kreversi/
%files -n kshisen -f filelists/kshisen
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%dir %{_datadir}/sounds/kshisen
%files -n ksirk -f filelists/ksirk
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%dir %{_kde4_appsdir}/ksirkskineditor
%dir %{_kde4_htmldir}/en/ksirkskineditor
%exclude %{_kde4_libdir}/libiris_ksirk.so
%files -n ksnakeduel -f filelists/ktron
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%files -n kspaceduel -f filelists/kspaceduel
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%files -n ksquares -f filelists/ksquares
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%files -n ksudoku -f filelists/ksudoku
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%files -n kubrick -f filelists/kubrick
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%files -n lskat -f filelists/lskat
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%files -n navalbattle -f filelists/kbattleship
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%files -n palapeli -f filelists/palapeli
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%dir %{_kde4_libdir}/libpala
%exclude %{_kde4_appsdir}/palapeli/collection/
%exclude %{_kde4_configdir}/palapeli-collectionrc
%files -n palapeli-data
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%{_kde4_appsdir}/palapeli/collection/
%config %{_kde4_configdir}/palapeli-collectionrc
%files -n potatoguy -f filelists/ktuberling
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB README
%changelog