File perl-MooseX-Types.spec of Package perl-MooseX-Types

#
# spec file for package perl-MooseX-Types
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%if 0%{?suse_version} < 1119
%define with_test 1
%endif

Name:           perl-MooseX-Types
Version:        0.27
Release:        1
Summary:        Organise your Moose types in libraries
Source:         ftp://ftp.cpan.org/pub/CPAN/authors/id/D/DR/DROLSKY/MooseX-Types-%{version}.tar.gz
Url:            http://search.cpan.org/dist/MooseX-Types
Group:          Development/Libraries/Perl
License:        GNU General Public License version 2 or later or Artistic (GPLv2+ or Artistic)
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%{perl_requires}
BuildRequires:  perl
BuildRequires:  perl-macros
BuildRequires:  make
%if 0%{?with_test}
BuildRequires:  perl(Test::More) >= 0.80
BuildRequires:  perl(Test::Requires)
BuildRequires:  perl(Test::Fatal)
BuildRequires:  perl(Test::Moose)
%endif
BuildRequires:  perl(FindBin)
BuildRequires:  perl(ExtUtils::MakeMaker) >= 6.42
BuildRequires:  perl(Scalar::Util) >= 1.19
BuildRequires:  perl(Sub::Name)
BuildRequires:  perl(Carp)
BuildRequires:  perl(namespace::clean) >= 0.08
BuildRequires:  perl(Sub::Install) >= 0.924
BuildRequires:  perl(Carp::Clan) >= 6.00
BuildRequires:  perl(Moose) >= 1.06
Requires:       perl(Scalar::Util) >= 1.19
Requires:       perl(Sub::Name)
Requires:       perl(Carp)
Requires:       perl(namespace::clean) >= 0.08
Requires:       perl(Sub::Install) >= 0.924
Requires:       perl(Carp::Clan) >= 6.00
Requires:       perl(Moose) >= 1.06

%description
The types provided with Moose are by design global. This package helps you
to organise and selectively import your own and the built-in types in
libraries. As a nice side effect, it catches typos at compile-time too.
However, the main reason for this module is to provide an easy way to not
have conflicts with your type names, since the internal fully qualified
names of the types will be prefixed with the library's name.
This module will also provide you with some helper functions to make it
easier to use Moose types in your code.

%prep
%setup -q -n "MooseX-Types-%{version}"
%__sed -i '/^auto_install/d' Makefile.PL

%build
%__perl Makefile.PL PREFIX="%{_prefix}"
%__make %{?_smp_flags}

%install
%perl_make_install
%perl_process_packlist

%if 0%{?with_test}

%check
%__make test
%endif

%clean
%{?buildroot:%__rm -rf "%{buildroot}"}

%files
%defattr(-,root,root)
%doc Changes README
%dir %{perl_vendorlib}/MooseX
%{perl_vendorlib}/MooseX/Types.pm
%{perl_vendorlib}/MooseX/Types
%dir %{perl_vendorarch}/auto/MooseX
%{perl_vendorarch}/auto/MooseX/Types
%doc %{perl_man3dir}/MooseX::Types.%{perl_man3ext}%{ext_man}
%doc %{perl_man3dir}/MooseX::Types::*.%{perl_man3ext}%{ext_man}
%changelog
openSUSE Build Service is sponsored by