File flickrnet.spec of Package flickrnet
#
# spec file for package flickrnet (Version 2.1.5)
#
# Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: flickrnet
BuildRequires: mono-devel unzip
Version: 2.1.5
Release: 2
License: LGPL v2.1 or later
Source: FlickrNet-25207.zip
Patch0: assemblyinfo.patch
Group: Productivity/Networking/Other
Summary: Flickr.Net API Library
Url: http://www.codeplex.com/FlickrNet
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildArch: noarch
%description
The Flickr.Net API is a .Net Library for accessing the Flickr API. Written entirely in C# it can be accessed from with any .Net language.
%prep
%setup -n FlickrNet -q
%patch0 -p1
%build
gmcs -debug -target:library -out:FlickrNet.dll -r:System.Web.dll -r:System.Drawing.dll *.cs
cat << EOF > flickrnet.pc
prefix=%{_prefix}
assemblies_dir=\${prefix}/lib/mono/flickrnet
Libraries=\${assemblies_dir}/FlickrNet.dll
Name: FlickrNet
Description: Flickr.Net API Library
Version: %{version}
Libs: -r:\${assemblies_dir}/FlickrNet.dll
EOF
%install
gacutil -i FlickrNet.dll -package flickrnet -root %{buildroot}%{_prefix}/lib
%__mkdir -p %{buildroot}%{_datadir}/pkgconfig
%__cp flickrnet.pc %{buildroot}%{_datadir}/pkgconfig/
%files
%defattr(-,root,root)
%{_prefix}/lib/mono/%{name}
%{_prefix}/lib/mono/gac/FlickrNet
%{_datadir}/pkgconfig/%{name}.pc
%changelog