File emacs-vm.spec of Package emacs-vm
#
# spec file for package emacs-vm
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: emacs-vm
BuildRequires: emacs-nox
Url: http://www.wonderworks.com/vm
License: GPL-2.0+
Group: Productivity/Editors/Emacs
Provides: calc
Requires: emacs ed
PreReq: %install_info_prereq
Version: 7.19
Release: 241
Summary: VM - a mail reader for GNU Emacs
Source: ftp://ftp.uni-mainz.de/gnu/vm/vm-%{version}.tar.gz
Source2: emacs-vm-autoload.el
Patch: vm-Makefile.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
VM (View Mail) is an Emacs subsystem that allows UNIX mail to be read
and disposed of within Emacs. Commands exist to do the normal things
expected of a mail user agent, such as generating replies, saving
messages to folders, deleting messages and so on. There are other more
advanced commands that do tasks like bursting and creating digests,
message forwarding, and organizing message presentation according to
various criteria.
%define _sitedir /usr/share/emacs/site-lisp
%define _vmdir %{_sitedir}/vm
%define _infodir /usr/share/info
%prep
%setup -n vm-%{version}
%patch
%build
export LC_CTYPE=ISO-8859-1
export EMACS_UNIBYTE=1
EMACS="emacs --no-site"
rm -rf *.elc
make EMACS="${EMACS}" vm %{?_smp_mflags}
make EMACS="${EMACS}" vm.info %{?_smp_mflags}
make EMACS="${EMACS}" CFLAGS="$RPM_OPT_FLAGS" utils %{?_smp_mflags}
%install
mkdir -p ${RPM_BUILD_ROOT}
EMACS="emacs --no-site"
_emacs_ver=$(rpm -q --qf '%{VERSION}' emacs)
make EMACS="${EMACS}" LISPDIR=${RPM_BUILD_ROOT}%{_vmdir} install-vm install-el
make INFODIR=${RPM_BUILD_ROOT}%{_infodir} install-info
make BINDIR=${RPM_BUILD_ROOT}/usr/bin install-utils
make PIXMAPDIR=${RPM_BUILD_ROOT}/usr/share/emacs/${_emacs_ver}/etc/vm install-pixmaps
{
echo ";; /usr/share/emacs/site-lisp/suse-start-%{name}.el"
cat %{S:2}
echo ";; /usr/share/emacs/site-lisp/suse-start-%{name}.el ends here"
} > ${RPM_BUILD_ROOT}%{_sitedir}/suse-start-%{name}.el
%post
%install_info --info-dir=%{_infodir} %{_infodir}/vm.info.gz
%postun
%install_info_delete --info-dir=%{_infodir} %{_infodir}/vm.info.gz
%files
%defattr(-, root, root)
%doc README
%dir %{_sitedir}
%{_sitedir}/*.el
%dir %{_vmdir}
%{_vmdir}/*.el
%{_vmdir}/*.elc
/usr/bin/base64-encode
/usr/bin/base64-decode
/usr/bin/qp-decode
/usr/bin/qp-encode
%doc %{_infodir}/*.gz
/usr/share/emacs/*/etc
%changelog