File go-httplib.go.spec of Package go-httplib.go

#
# spec file for package go-httplib.go
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
# Copyright (c) 2011 Sascha Peilicke <saschpe@gmx.de>
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#



Name:           go-httplib.go
Version:        0.0.0+git20111213
Release:        0
Summary:        A simple, low-level http library for Go
License:        MIT
Group:          Development/Languages/Other
Url:            https://github.com/hoisie/httplib.go
Source0:        httplib.go-%{version}.tar.bz2
Patch0:         httplib.go-weekly-fixes.patch
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  go-devel
Recommends:     go-httplib.go-doc
%{go_provides}
%{go_requires}
%{go_disable_brp_strip_static_archive}

%description
httplib.go is a simple extension of Go's http client that provides keep-alive
connections and generic requests. This is a small usage example:

    //get the google home page
    c := new(httplib.Client)
    resp, err := c.Request ("http://google.com", "GET", nil, "")
    data := ioutil.ReadAll( resp.Body )
    println(string(data))

%package doc
Summary:        API documenation
Group:          Documentation/Other
Requires:       %{name} = %{version}

%description doc
API, examples and documentation.

%prep
%setup -q -n httplib.go
%patch0 -p1

%build
%goprep  github.com/hoisie/httplib.go
%gobuild /

%install
%goinstall
%godoc

%check
%gotest github.com/hoisie/httplib.go

%files
%defattr(-,root,root,-)
%doc Readme.md LICENSE
%{go_contribdir}/*

%files doc
%defattr(-,root,root,-)
%{go_contribsrcdir}/*

%changelog
openSUSE Build Service is sponsored by