File nagios.spec of Package nagios
#
# spec file for package nagios
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: nagios
Summary: The Nagios Network Monitor
License: GPL-2.0+
Group: System/Monitoring
Version: 3.4.1
Release: 0
Url: http://www.nagios.org/
Source0: %{name}-%{version}.tar.bz2
Source1: rc%{name}
Source2: convertcfg.8
Source3: %{name}.sysconfig
Source4: suse.de-nagios
Source5: nagios.8
Source6: nagiosstats.8
Source7: nagios-htpasswd.users
Source8: mini_epn.8
Source9: new_mini_epn.8
#
Source10: %{name}-README.SuSE
Source20: %{name}-rpmlintrc
# PATCH-FIX-UPSTREAM Fixes the output of spurious $ signs in commandoutput (deb#480001)
Patch2: nagios-fix_spurious_dollar_signs_added_to_command_lines.patch
# PATCH-FIX-UPSTREAM unescape hex characters in CGI input - avoid addional '+'
Patch3: nagios-fix_encoding_trends.cgi.patch
# PATCH-FIX-OPENSUSE openSUSE uses a special location for p1.pl
Patch10: nagios-p1.pl-location.patch
# PATCH-FIX-OPENSUSE disable Nagios online update checks for distributed packages
Patch11: nagios-disable_phone_home.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-build
PreReq: %fillup_prereq
PreReq: %insserv_prereq
PreReq: /bin/logger
PreReq: coreutils
PreReq: grep
PreReq: pwdutils
PreReq: sed
BuildRequires: apache2-devel
BuildRequires: freetype2-devel
BuildRequires: gd-devel
BuildRequires: iputils
BuildRequires: libjpeg-devel
BuildRequires: libpng-devel
BuildRequires: mailx
BuildRequires: nagios-rpm-macros
BuildRequires: net-tools
BuildRequires: openssl-devel
BuildRequires: pcre-devel
BuildRequires: zlib-devel
%if 0%{?suse_version} < 1010
BuildRequires: XFree86-devel
BuildRequires: XFree86-libs
BuildRequires: libapr0
Requires: cron
%else
BuildRequires: libapr-util1-devel
BuildRequires: xorg-x11-devel
Recommends: cron
Recommends: %{name}-www
# we enable nagios embedded perl, but if people disable it...
Recommends: perl = %{perl_version}
%endif
%if 0%{?suse_version} > 1020
Recommends: %{name}-plugins
%else
Requires: %{name}-plugins
%endif
Requires: mailx
%define nslockfile_dir /var/run/%{name}
%define nslockfile %nslockfile_dir/%{name}.pid
%define apache2_sysconfdir %(/usr/sbin/apxs2 -q SYSCONFDIR)/conf.d
# Macro that print mesages to syslog at package (un)install time
%define nnmmsg logger -t %{name}/rpm
%description
Nagios is a program that will monitor hosts and services on your
network. It has the ability to email or page you when a problem arises
and when a problem is resolved. Nagios is written in C and is designed
to run under Linux (and some other *NIX variants) as a background
process, intermittently running checks on various services that you
specify.
The actual service checks are performed by separate "plugin" programs
which return the status of the checks to Nagios. The plugins are
available at http://sourceforge.net/projects/nagiosplug
This package provides core programs for Nagios. The web interface,
documentation, and development files are built as separate packages
%package www
Summary: Provides the HTML and CGI files for the Nagios web interface
Group: System/Monitoring
PreReq: /bin/logger
PreReq: apache2
PreReq: coreutils
PreReq: gawk
PreReq: grep
PreReq: pwdutils
PreReq: sed
Requires: %{name} = %{version}
Requires: gd
Requires: mod_php_any
Requires: php5
%description www
Nagios is a program that will monitor hosts and services on your
network. It has the ability to email or page you when a problem arises
and when a problem is resolved. Nagios is written in C and is designed
to run under Linux (and some other *NIX variants) as a background
process, intermittently running checks on various services that you
specify.
Several CGI programs are included with Nagios in order to allow you to
view the current service status, problem history, notification history,
and log file via the web. This package provides the HTML and CGI files
for the Nagios web interface. In addition, HTML documentation is
included in this package.
%package devel
Summary: Development files for Nagios
Group: Development/Libraries/C and C++
Requires: %{name} = %{version}
Requires: gcc
%description devel
Nagios is a program that will monitor hosts and services on your
network. It has the ability to email or page you when a problem arises
and when a problem is resolved. Nagios is written in C and is designed
to run under Linux (and some other *NIX variants) as a background
process, intermittently running checks on various services that you
specify.
This package provides include files that Nagios-related applications
may compile against.
%prep
%setup -q -n %{name}
%patch2 -p1
%patch3 -p1
%patch10 -p0
%patch11 -p1
find -name ".gitignore" | xargs rm
# fix p1.pl [dos]
perl -p -i -e 's|\r\n|\n|' contrib/p1.pl
# fix p1.pl pathname of mini_epn
sed -i 's|p1.pl|%{nagios_libdir}/p1.pl|g' contrib/mini_epn.c
sed -i 's|p1.pl|%{nagios_libdir}/p1.pl|g' contrib/new_mini_epn.c
# fix file permissions
chmod -x Changelog LEGAL LICENSE README
%build
# if the following command fails, then apache dependencies are not met
/usr/sbin/apxs2 -q DATADIR >/dev/null
%configure \
--prefix=%{_prefix} \
--exec-prefix=%{_sbindir} \
--bindir=%{_sbindir} \
--sbindir=%{nagios_cgidir} \
--libexecdir=%{nagios_plugindir} \
--datadir=%{nagios_datadir} \
--sysconfdir=%{nagios_sysconfdir} \
--with-init-dir=%{_sysconfdir}/init.d \
--localstatedir=%{nagios_localstatedir} \
--with-cgiurl=/%{name}/cgi-bin \
--with-htmurl=/%{name} \
--with-httpd-conf=%{apache2_sysconfdir} \
--with-checkresult-dir=%{nagios_spooldir} \
--with-lockfile=%{nslockfile} \
--with-nagios-user=%{nagios_user} \
--with-nagios-group=%{nagios_group} \
--with-command-user=%{nagios_command_user} \
--with-command-group=%{nagios_command_group} \
--with-gd-lib=%{_libdir} \
--with-gd-inc=%{_includedir} \
--with-template-objects \
--with-template-extinfo \
--with-perlcache \
--enable-event-broker \
--enable-embedded-perl
#
# /usr/bin/p1.pl is not a good place for a perl-_module_!
#
sed -i 's#@p1pldir@#%{nagios_libdir}#g' Makefile include/locations.h sample-config/nagios.cfg
#
# fix p1.pl debug-path
#
sed -i 's#/usr/local/nagios/var/#/var/log/%{name}/#g' p1.pl
# make rpmlint happy: add shebang to p1.pl
echo "#!/usr/bin/perl" > p1.pl.new
cat p1.pl >> p1.pl.new
mv p1.pl.new p1.pl
#
# make daemonchk.cgi and event handlers
#
make %{?jobs:-j%jobs} all
make %{?jobs:-j%jobs} -C contrib
pushd contrib/eventhandlers 1>/dev/null
for f in `find . -type f` ; do
F=`mktemp temp.XXXXXX`
sed "s=/usr/local/nagios/var/rw/=%{nagios_spooldir}/=; \
s=NscaBin\=\"/usr/local/nagios/libexec/send_nsca\"=NscaBin\=/usr/bin/send_nsca=; \
s=/usr/local/nagios/libexec/eventhandlers/=%{nagios_eventhandlerdir}/=; \
s=/usr/local/nagios/libexec/=%{nagios_plugindir}/=; \
s=/usr/local/nagios/etc/=%{nagios_sysconfdir}/=; \
s=/usr/local/nagios/test/var=%{nagios_logdir}/=" ${f} > ${F}
mv ${F} ${f}
done
popd 1>/dev/null
%install
mkdir -p %{buildroot}/%{nagios_logdir}/archives
mkdir -p %{buildroot}%{_sbindir}
mkdir -p %{buildroot}%apache2_sysconfdir/
mkdir -p %{buildroot}%nslockfile_dir
%{__make} install install-commandmode install-config install-webconf install-classicui\
DESTDIR=%{buildroot} \
INSTALL_OPTS="" \
COMMAND_OPTS="" \
CGICFGDIR="%{nagios_sysconfdir}" \
INIT_OPTS=""
%{__make} install -C contrib \
DESTDIR=%{buildroot} \
INSTALL_OPTS=""
# install event handlers
%{__install} -d -m0755 %{buildroot}/%{nagios_eventhandlerdir}
%{__cp} -afpv contrib/eventhandlers/* %{buildroot}%{nagios_eventhandlerdir}/
find %{buildroot}%{nagios_eventhandlerdir}/ -type f -exec chmod +x {} \;
# install directory for event brokers like ndoutils
%{__install} -d -m0755 %{buildroot}%{nagios_localstatedir}/brokers
# install headers for development package
%{__install} -d -m0755 %{buildroot}%{_includedir}/%{name}/
pushd include
for file in *.h; do
if test "x${file}" != "xconfig.h" -a "x${file}" != "xsnprintf.h" -a "x${file}" != "xcgiutils.h" ; then
install -m 644 $file %{buildroot}%{_includedir}/%{name}/
fi;
done
popd
#
# cleanup sample-conf dir for including in docdir
#
find sample-config/ -name "*.in" -exec rm {} \;
find sample-config/ -name "*.in.orig" -exec rm {} \;
sed -e 's|command_file=.*|command_file=%{nagios_command_file}|g' \
-e 's|log_file=/var/lib/nagios/nagios.log|log_file=%{nagios_logdir}/nagios.log|g' \
-e 's|log_archive_path=/var/lib/nagios/archives|log_archive_path=%{nagios_logdir}/archives|g' \
-e 's|^lock_file=.*|lock_file=%nslockfile|g' \
%{buildroot}/%{nagios_sysconfdir}/nagios.cfg > %{buildroot}%{_sysconfdir}/%{name}/nagios.cfg.tmp
mv %{buildroot}/%{nagios_sysconfdir}/nagios.cfg.tmp %{buildroot}%{_sysconfdir}/%{name}/nagios.cfg
#
# install SuSE specials
#
# README.SuSE file
sed -e 's@DATADIR@%{_datadir}/%{name}@g' -e 's@SYSCONFDIR@%{nagios_sysconfdir}@g' %{S:10} > %_builddir/%{name}/README.SuSE
# init-script
%{__install} -D -m 0755 %{S:1} %{buildroot}%{_sysconfdir}/init.d/%{name}
ln -sf ../../etc/init.d/%{name} %{buildroot}%{_sbindir}/rc%{name}
# sysconfig script
%{__install} -D -m 0644 %{S:3} %{buildroot}%{_localstatedir}/adm/fillup-templates/sysconfig.%{name}
# install cronjob (gzip' the logfiles)
%{__install} -D -m 0755 %{S:4} %{buildroot}%{_sysconfdir}/cron.weekly/%{name}
# install htpasswd file
%{__install} -m 0640 %{S:7} %{buildroot}%{_sysconfdir}/%{name}/htpasswd.users
# important ghost files
touch %{buildroot}%{nagios_state_retention_file}
touch %{buildroot}%{nagios_status_file}
touch %{buildroot}%{nagios_logdir}/config.err
touch %{buildroot}%{nslockfile}
# install manpages
install -Dm644 %{S:5} %{buildroot}%{_mandir}/man8/%{name}.8
install -Dm644 %{S:6} %{buildroot}%{_mandir}/man8/nagiostats.8
install -Dm644 %{S:8} %{buildroot}%{_mandir}/man8/mini_epn.8
install -Dm644 %{S:9} %{buildroot}%{_mandir}/man8/new_mini_epn.8
install -Dm644 %{S:2} %{buildroot}%{_mandir}/man8/convertcfg.8
# fixing permissions the dirty way....
for file in "README sample-config/README sample-config/template-object/README"; do
chmod 644 $RPM_BUILD_DIR/%{name}/$file
done
# we use nagios_spooldir for this
test -d %{buildroot}%{nagios_localstatedir}/rw && rmdir %{buildroot}%{nagios_localstatedir}/rw
%clean
%{__rm} -rf %{buildroot}
%pre
# Create user and group on the system if necessary
# default group: nagios
if
getent group %{nagios_group} >/dev/null
then
: OK group %{nagios_group} already present
else
groupadd -r %{nagios_group} 2>/dev/null || :
%{nnmmsg} "Added group %{nagios_group} for package %{name}"
fi
# default group: nagcmd
if
getent group %{nagios_command_group} >/dev/null
then
: OK group %{nagios_command_group} already present
else
groupadd -r %{nagios_command_group} 2>/dev/null || :
%{nnmmsg} "Added group %{nagios_command_group} for package %{name}"
fi
# default user: nagios
if
id %{nagios_user} > /dev/null 2>&1
then
: OK user %{nagios_user} already present
else
useradd -r -o -g %{nagios_group} -s /bin/false -c "User for Nagios" -d %{nagios_localstatedir} %{nagios_user} 2> /dev/null || :
%{nnmmsg} "Added user %{nagios_user} for package %{name}"
fi
# update?
if [ ${1:-0} -gt 1 ]; then
# in the past, group www was used as nagios_command_group - now we use the default: nagcmd
if id -Gn %{nagios_user} 2>/dev/null | grep -q %{nagios_command_group} >/dev/null 2>&1 ; then
: # %%{nagios_user} is already in %%nagios_command_group group
else
# Add %%{nagios_user} to %%nagios_command_group.
groupmod -A %{nagios_user} %{nagios_command_group} 2>/dev/null
%{nnmmsg} "Added %{nagios_user} to %{nagios_command_group}"
fi
fi
%post
%{fillup_and_insserv nagios}
# Update ?
if [ ${1:-0} -gt 1 ]; then
if [ -f %{nagios_sysconfdir}/nagios.cfg ]; then
DATE=$(date "+%Y-%m-%d-%H:%M")
TMPFILE=$(mktemp /tmp/%{name}-XXXXXX)
NAGIOS_CFG=%{nagios_sysconfdir}/nagios.cfg
cp -f $NAGIOS_CFG ${NAGIOS_CFG}_${DATE}
if ! grep -q ^lock_file=%{nslockfile} $NAGIOS_CFG ; then
echo "- updating pid lock_file= to %{nslockfile} in $NAGIOS_CFG" >> $TMPFILE
sed -i "s@^lock_file=.*@lock_file=%{nslockfile}@" $NAGIOS_CFG
fi
if grep -q ^service_reaper_frequency $NAGIOS_CFG ; then
echo "- renaming service_reaper_frequency to check_result_reaper_frequency in $NAGIOS_CFG" >> $TMPFILE
sed -i "s@service_reaper_frequency@check_result_reaper_frequency@" $NAGIOS_CFG
fi
if grep -q ^aggregate_status_updates $NAGIOS_CFG ; then
echo "- aggregate_status_updates option has been removed from $NAGIOS_CFG" >> $TMPFILE
sed -i "s@^aggregate_status_updates@# aggregate_status_updates@" $NAGIOS_CFG
fi
if grep -q ^downtime_file $NAGIOS_CFG ; then
set -- $(grep ^downtime_file $NAGIOS_CFG | sed 's@=@ @')
shift
file=$(echo $*)
if [ -n "$file" ]; then
if [ -f "$file" ]; then
set -- $(grep ^state_retention_file $NAGIOS_CFG | sed 's@=@ @')
shift
state_retention_file=$(echo $*)
echo "- adding the content of of $file to $state_retention_file" >> $TMPFILE
cat "$file" >> "$state_retention_file"
fi
fi
echo "- removing downtime_file variable (no longer supported) in $NAGIOS_CFG" >> $TMPFILE
sed -i "s@^downtime_file@# downtime_file@" $NAGIOS_CFG
fi
if grep -q ^comment_file $NAGIOS_CFG ; then
set -- $(grep ^comment_file $NAGIOS_CFG | sed 's@=@ @')
shift
file=$(echo $*)
if [ -n "$file" ]; then
if [ -f "$file" ]; then
echo "- adding the content of $file to $state_retention_file" >> $TMPFILE
cat "$file" >> "$state_retention_file"
fi
fi
echo "- removing comment_file variable (no longer supported) in $NAGIOS_CFG" >> $TMPFILE
sed -i "s@^comment_file@# comment_file@" $NAGIOS_CFG
fi
%{nnmmsg} $(cat $TMPFILE)
rm $TMPFILE
fi
else
# First installation: create an alias for the default nagiosadmin user
if [ -r etc/aliases ]; then
if ! grep -q "^nagiosadmin:" etc/aliases; then
echo -e "nagiosadmin:\troot" >> etc/aliases
%{nnmmsg} "Added alias for user nagiosadmin to /etc/aliases"
if [ -x usr/bin/newaliases ]; then
usr/bin/newaliases &>/dev/null || true
else
%{nnmmsg} "Cannot execute newaliases. Please run it manually."
fi
fi
fi
fi
%preun
%stop_on_removal %{name}
%postun
if [ -f %nslockfile ]; then
chown -v %{nagios_user} %{nslockfile}
fi
%restart_on_update %{name}
%{insserv_cleanup}
%post www
wwwusr=""
if [ -f etc/apache2/uid.conf ]; then
# If apache is installed, and we can find the apache user, set a shell var
wwwusr=$(awk '/^[ \t]*User[ \t]+[a-zA-Z0-9]+/ {print $2}' etc/apache2/uid.conf)
fi
if [ "z" = "z$wwwusr" ]; then # otherwise, use the default
wwwusr=%{nagios_command_user}
fi
# if apache user is not in nagios_command_group, add it
if id -Gn $wwwusr 2>/dev/null | grep -q %{nagios_command_group} >/dev/null 2>&1 ; then
: # $wwwusr (default: %%nagios_command_user) is already in Nagios cmd group
else
# modify apache user, adding it to nagios_command_group
groupmod -A $wwwusr %{nagios_command_group} 2>/dev/null
%nnmmsg "User $wwwusr added to group %{nagios_command_group} so sending commands to Nagios from the CGI is possible."
fi
# Update ?
if [ ${1:-0} -eq 1 ]; then
if [ -x %{_sbindir}/a2enmod ]; then
# enable authentification in apache config
%{_sbindir}/a2enmod authn_file >/dev/null
%{_sbindir}/a2enmod auth_basic >/dev/null
%{_sbindir}/a2enmod authz_user >/dev/null
# enable php5 in apache config
%{_sbindir}/a2enmod php5
fi
fi
%restart_on_update apache2
%preun www
%restart_on_update apache2
%files
%defattr(-,root,root)
%doc Changelog LEGAL LICENSE README README.SuSE sample-config/
%{_mandir}/man8/convertcfg*
%{_mandir}/man8/%{name}*
%{_mandir}/man8/*mini_epn*
%_sysconfdir/init.d/%name
%ghost %config(missingok,noreplace) %{nagios_logdir}/config.err
%config(noreplace) %{nagios_sysconfdir}/*.cfg
%config(noreplace) %{nagios_sysconfdir}/objects/*.cfg
%{_localstatedir}/adm/fillup-templates/sysconfig.%{name}
%{_sysconfdir}/cron.weekly/*
%{nagios_localstatedir}
%attr(0755,root,root) %{nagios_libdir}/p1.pl
%exclude %{nagios_cgidir}/*
%{_sbindir}/convertcfg
%{_sbindir}/mini_epn
%{_sbindir}/new_mini_epn
%{_sbindir}/rc%name
%dir %{nagios_libdir}
%dir %{nagios_plugindir}
%dir %{nagios_eventhandlerdir}
%{nagios_eventhandlerdir}/*
# defattr change
%defattr(-,%{nagios_user},%{nagios_command_group})
%dir %{nagios_sysconfdir}
%dir %{nagios_sysconfdir}/objects
%dir %{nagios_spooldir}
# defattr change
%defattr(-,%{nagios_user},%nagios_group)
%dir %{nagios_localstatedir}
%dir %{nagios_logdir}
%dir %{nagios_logdir}/archives
%ghost %dir %nslockfile_dir
%attr(0644,%nagios_user,%nagios_group) %verify(not md5 size mtime) %ghost %config(missingok,noreplace) %{nslockfile}
%attr(0600,%nagios_user,%nagios_group) %verify(not md5 size mtime) %ghost %config(missingok,noreplace) %{nagios_state_retention_file}
%attr(0664,%nagios_user,%nagios_group) %verify(not md5 size mtime) %ghost %config(missingok,noreplace) %{nagios_status_file}
%attr(0750,root,%{nagios_command_group}) %{_sbindir}/%{name}
%attr(0750,root,%{nagios_command_group}) %{_sbindir}/nagiostats
%files www
%defattr(755,root,root)
%dir %{nagios_cgidir}
%{nagios_cgidir}/*
# defattr change
%defattr(-,root,root)
%{nagios_datadir}
%config(noreplace) %{apache2_sysconfdir}/%{name}.conf
%attr(0640,root,%nagios_command_group) %config(missingok,noreplace) %{_sysconfdir}/%{name}/htpasswd.users
%files devel
%defattr(-,root,root)
%{_includedir}/%{name}/
%changelog