File python3-psycopg2.spec of Package python-psycopg2

#
# spec file for package python3-psycopg2
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           python3-psycopg2
Version:        2.4.5
Release:        0
License:        LGPL-3.0+ or ZPL-2.0
Summary:        Python-PostgreSQL Database Adapter
Url:            http://initd.org/psycopg/
Group:          Development/Languages/Python
Source:         http://pypi.python.org/packages/source/p/psycopg2/psycopg2-%{version}.tar.gz
BuildRequires:  fdupes
BuildRequires:  postgresql-devel
BuildRequires:  python3-devel
BuildRequires:	python3-2to3
Suggests:       postgresql-server
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%if 0%{?suse_version} <= 1140
%{!?python3_sitearch: %global python3_sitearch %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
%{!?py3_ver: %global py3_ver %(python3 -c "import sys; version=str(sys.version_info[0]) + '.' + str(sys.version_info[1]); print(version)")}
%endif
Requires:       python(abi) = %{py3_ver}
%if 0%{?suse_version} && 0%{?suse_version} > 1140
BuildRequires:  python3-base
%endif

%description
psycopg2 is a PostgreSQL database adapter for the Python programming
language.  psycopg2 was written with the aim of being very small and fast,
and stable as a rock.

psycopg2 is different from the other database adapter because it was
designed for heavily multi-threaded applications that create and destroy
lots of cursors and make a conspicuous number of concurrent INSERTs or
UPDATEs. psycopg2 also provide full asycronous operations and support
for coroutine libraries.

%package doc
Summary:        Documentation for psycopg python PostgreSQL database adapter
Group:          Documentation/HTML
Requires:       %{name} = %{version}

%description doc
Documentation and example files for the psycopg python PostgreSQL database adapter.

%prep
%setup -q -n psycopg2-%{version}

%build
CFLAGS="%{optflags} -fno-strict-aliasing" python3 setup.py build
rm -rf doc/src doc/html/.buildinfo # Remove junk

%install
python3 setup.py install --prefix=%{_prefix} --root=%{buildroot}
rm -rf %{buildroot}%{python_sitearch}/psycopg2/tests # Don't package testsuite
%fdupes -s %{buildroot}/%{_mandir}  # Create symlinks for man pages
%fdupes %{buildroot}                # Create hardlinks for the rest

%files
%defattr(-,root,root,-)
%doc AUTHORS ChangeLog LICENSE NEWS PKG-INFO README
%{python3_sitearch}/psycopg2
%{python3_sitearch}/psycopg2-%{version}-py%{py3_ver}.egg-info
%files doc
%defattr(-,root,root)
%doc doc/html examples/

%changelog
openSUSE Build Service is sponsored by