File sblim-cmpi-network.spec of Package sblim-cmpi-network
#
# spec file for package sblim-cmpi-network
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: sblim-cmpi-network
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: gcc-c++
BuildRequires: libtool
BuildRequires: openssl-devel
BuildRequires: pam-devel
BuildRequires: sblim-cmpi-base-devel
BuildRequires: sblim-indication_helper-devel
BuildRequires: sblim-sfcb
BuildRequires: sblim-testsuite
%if 0%{?suse_version}
BuildRequires: openslp-devel
%endif
Version: 1.4.0
Release: 0
BuildRoot: %{_tmppath}/%{name}-%{version}-build
Requires: cim-schema
Requires: cim-server
Requires: sblim-cmpi-base
Url: http://sblim.wiki.sourceforge.net/
Source: http://prdownloads.sourceforge.net/sblim/%{name}-%{version}.tar.bz2
Summary: SBLIM Network Instrumentation
License: EPL-1.0
Group: System/Management
#!BuildIgnore: tog-pegasus
%description
Standards Based Linux Instrumentation Network Providers. The Network
Instrumentation allows you to get information about the network
configuration of a system via CIMOM technology/infrastructure.
Authors:
--------
SBLIM Project
%package devel
Summary: SBLIM Network Provider Development Package
Group: System/Management
Requires: %{name} = %{version}
%description devel
SBLIM Network Instrumentation Header Development Files
Authors:
--------
SBLIM Project
%prep
%setup
%build
autoreconf -f -i
%configure --disable-static
%{__make}
%install
%if 0%{?suse_version}
%makeinstall docdir=%{_docdir}/%{name}
%else
make install DESTDIR=%{buildroot} docdir=%{_docdir}/%{name}-%{version}
%endif
rm %buildroot%_libdir/cmpi/*.la
rm %buildroot%_libdir/*.la
%clean
%{__rm} -rf %{buildroot}
%define PEGASUS_MOF CIM_IPProtocolEndpoint,CIM_NetworkPort,CIM_EthernetPort,CIM_TokenRingPort,CIM_PortImplementsEndpoint
%pre
if [ "$1" -gt 1 ]; then
d=%{_datadir}/%{name}
$d/provider-register.sh -d -r $d/*.registration -m $d/*.mof
fi
%post
# compile MOF
/sbin/ldconfig
# Register Schema and Provider - this is higly provider specific
# tog-pegasus needs some schemes registered first
if [ -x /usr/bin/peg-loadmof.sh ]; then
peg-loadmof.sh -n root/cimv2 /usr/share/mof/cim-current/*/{%{PEGASUS_MOF}}.mof
rctog-pegasus try-restart
fi
# and then following script can handle registration for various providers
d=%{_datadir}/%{name}
$d/provider-register.sh -r $d/*.registration -m $d/*.mof
%preun
if [ "$1" = "0" ]; then
d=%{_datadir}/%{name}
$d/provider-register.sh -d -r $d/*.registration -m $d/*.mof
fi
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_libdir}/cmpi/*.so*
%{_libdir}/*.so.*
%if 0%{?suse_version}
%doc %{_docdir}/%{name}
%else
%doc %{_docdir}/%{name}-%{version}
%endif
%{_datadir}/%{name}
# XXX: split -test and -devel?
%{_datadir}/sblim-testsuite/*
%files devel
%defattr(-,root,root)
%{_libdir}/*.so
%{_includedir}/sblim/*
%changelog