File sblim-cmpi-nfsv4.spec of Package sblim-cmpi-nfsv4
#
# spec file for package sblim-cmpi-nfsv4
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: sblim-cmpi-nfsv4
BuildRequires: bison
BuildRequires: flex
BuildRequires: gcc-c++
BuildRequires: openssl-devel
BuildRequires: pam-devel
BuildRequires: sblim-cmpi-base-devel
BuildRequires: sblim-indication_helper-devel
BuildRequires: sblim-sfcb
BuildRequires: sblim-testsuite
%if 0%{?suse_version}
BuildRequires: openslp-devel
%endif
Url: http://sblim.wiki.sourceforge.net/
Summary: SBLIM CMPI NFSv4 Instrumentation
License: EPL-1.0
Group: System/Management
Version: 1.1.0
Release: 0
Requires: sblim-cmpi-base >= 1.2.3, cim-server
Source0: http://prdownloads.sourceforge.net/sblim/sblim-cmpi-nfsv4-%{version}.tar.bz2
BuildRoot: %{_tmppath}/%{name}-%{version}-build
#!BuildIgnore: tog-pegasus
%description
Standards Based Linux NFSv4 Instrumentation Providers
Authors:
--------
SBLIM Project
%prep
%setup
%build
%configure --disable-static
%{__make}
%install
%if 0%{?suse_version}
%makeinstall docdir=%{_docdir}/%{name}
%else
make install DESTDIR=%{buildroot} docdir=%{_docdir}/%{name}-%{version}
%endif
rm %buildroot%_libdir/cmpi/*.la
rm %buildroot%_libdir/*.la
%clean
%{__rm} -rf $RPM_BUILD_ROOT
%post
%define mofs Linux_NFSv4SystemSetting,Linux_NFSv4SystemConfiguration
%define PEGASUS_MOF CIM_SystemSetting,CIM_NFS,CIM_SystemConfiguration,CIM_SystemSettingContext
# compile MOF
/sbin/ldconfig
# Register Schema and Provider - this is higly provider specific
# tog-pegasus needs some schemes registered first
if [ -x /usr/bin/peg-loadmof.sh ]; then
peg-loadmof.sh -n root/cimv2 /usr/share/mof/cim-current/*/{%{PEGASUS_MOF}}.mof
rctog-pegasus try-restart
fi
# and then following script can handle registration for various providers
d=%_datadir/%name
$d/provider-register.sh -r $d/{%{mofs}}.registration -m $d/{%{mofs}}.mof
%preun
if [ "$1" = "0" ]; then
d=%_datadir/%name
$d/provider-register.sh -d -r $d/{%{mofs}}.registration -m $d/{%{mofs}}.mof
fi
%files
%defattr(-,root,root)
%if 0%{?suse_version}
%doc %{_docdir}/%{name}
%else
%doc %{_docdir}/%{name}-%{version}
%endif
%{_libdir}/cmpi/*.so
%{_libdir}/*.so
%{_datadir}/%{name}
%{_datadir}/sblim-testsuite/*
%changelog