File smpppd.spec of Package smpppd
#
# spec file for package smpppd
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%if 0%{?suse_version < 1120}
%bcond_with policykit
%else
%bcond_without policykit
%endif
Name: smpppd
BuildRequires: gcc-c++
BuildRequires: openslp-devel
BuildRequires: openssl-devel
%if %{with policykit}
BuildRequires: PolicyKit-devel
%endif
Summary: SuSE Meta PPP Daemon
License: GPL-2.0+
Group: Productivity/Networking/PPP
Requires: /usr/bin/killall
Requires: ppp
Version: 1.60.56
Release: 0
Source0: smpppd-%version.tar.bz2
Patch0: smpppd-gcc47.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-build
PreReq: %fillup_prereq %insserv_prereq
Recommends: wvdial
Recommends: pptp
Url: https://gitorious.org/opensuse/smpppd
%description
The SuSE Meta PPP Daemon is the back-end for kinternet. It is required
for modem, ISDN, and DSL connections.
Authors:
--------
Arvin Schnell
Ludwig Nussel
%prep
%setup -q
%patch0 -p1
%if 0
if [ -e $RPM_SOURCE_DIR/devel.diff ]; then
patch -p1 < $RPM_SOURCE_DIR/devel.diff
fi
%endif
%build
export CXXFLAGS="$RPM_OPT_FLAGS -DNDEBUG"
export CFLAGS="$RPM_OPT_FLAGS -DNDEBUG"
test configure -nt configure.in || autoreconf -i
./configure \
--prefix=%_prefix \
--sysconf=/etc \
--mandir=%{_mandir} \
%if %{with policykit}
--without-polkit1 \
--with-policykit \
%endif
--docdir=%_defaultdocdir/%name
make %{?_smp_mflags}
%check
make check
%install
make install DESTDIR=%{buildroot}
mkdir -p %{buildroot}/etc/init.d
install misc/smpppd.conf %{buildroot}/etc/
install misc/smpppd-c.conf %{buildroot}/etc/
install misc/rc.smpppd %{buildroot}/etc/init.d/smpppd
ln -sf ../../etc/init.d/smpppd %{buildroot}/usr/sbin/rcsmpppd
install -d %{buildroot}/var/lib/smpppd
install -d %{buildroot}/var/log/smpppd
install -d %{buildroot}/var/run/smpppd
%clean
rm -rf %{buildroot}
%files
%defattr (-, root, root)
%attr (600, root, root) %config(noreplace) /etc/smpppd.conf
%attr (644, root, dialout) %config(noreplace) /etc/smpppd-c.conf
%config /etc/init.d/smpppd
%{_bindir}/cinternet
%{_bindir}/accounting
%{_sbindir}/smpppd
%{_sbindir}/smpppd-ifcfg
%{_sbindir}/smpppd-dhcp
%{_sbindir}/rcsmpppd
%if %{with policykit}
%dir %{_datadir}/PolicyKit
%dir %{_datadir}/PolicyKit/policy
%{_datadir}/PolicyKit/policy/org.opensuse.smpppd.policy
%{_prefix}/lib/smpppd
%else
%dir %{_datadir}/polkit-1
%dir %{_datadir}/polkit-1/actions
%{_datadir}/polkit-1/actions/org.opensuse.smpppd.policy
%endif
%attr (700, root, root) %dir /var/lib/smpppd
%attr (750, root, dialout) %dir /var/log/smpppd
%ghost %attr (755, root, root) %dir /var/run/smpppd
%{_mandir}/man?/*
%doc %_defaultdocdir/smpppd
%post
%{fillup_and_insserv smpppd}
%preun
%{stop_on_removal smpppd}
%postun
%{insserv_cleanup}
%{restart_on_update smpppd}
%changelog