File ppl-testsuite.spec of Package ppl-testsuite
#
# spec file for package ppl-testsuite
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: ppl-testsuite
Version: 0.11.2
Release: 0
Summary: The Parma Polyhedra Library
License: GPL-3.0+
Group: Development/Libraries/C and C++
Url: http://www.cs.unipr.it/ppl/
Source: ppl-%{version}.tar.bz2
Source1: baselibs.conf
BuildRequires: c++_compiler
BuildRequires: gmp-devel >= 4.1.3
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
The Parma Polyhedra Library (PPL) is a library for the manipulation of
(not necessarily closed) convex polyhedra and other numerical
abstractions. The applications of convex polyhedra include program
analysis, optimized compilation, integer and combinatorial optimization
and statistical data-editing. The Parma Polyhedra Library comes with
several user friendly interfaces, is fully dynamic (available virtual
memory is the only limitation to the dimension of anything), written in
accordance to all the applicable standards, exception-safe, rather
efficient, thoroughly documented, and free software. This package
provides all what is necessary to run applications using the PPL
through its C and C++ interfaces.
%package devel
Summary: Development tools for the Parma Polyhedra Library C and C++ interfaces
Group: Development/Libraries/C and C++
Requires: libppl9 = %{version}-%{release}
Requires: libppl_c4 = %{version}-%{release}
Requires: gmp-devel >= 4.1.3
%if 0%{suse_version} > 1000
Recommends: ppl-doc = %{version}-%{release}
%endif
%description devel
The header files, Autoconf macro, and ppl-config tool for developing
applications using the Parma Polyhedra Library through its C and C++
interfaces.
%package devel-static
Summary: Static libraries for the Parma Polyhedra Library C and C++ interfaces
Group: Development/Libraries/C and C++
Requires: ppl-devel = %{version}-%{release}
%if 0%{suse_version} > 1000
Recommends: ppl-doc = %{version}-%{release}
%endif
%description devel-static
Static libraries for the Parma Polyhedra Library C and C++ interfaces.
%package -n libppl9
Summary: Shared library for the Parma Polyhedra Library
Group: Development/Libraries/C and C++
%description -n libppl9
Shared library for the Parma Polyhedra Library.
%package -n libppl_c4
Summary: Shared library for the Parma Polyhedra Library C bindings
Group: Development/Libraries/C and C++
%description -n libppl_c4
Shared library for the Parma Polyhedra Library C bindings.
%package doc
Summary: Documentation for the Parma Polyhedra Library
Group: Development/Libraries/C and C++
%if 0%{?suse_version} >= 1120
BuildArch: noarch
%endif
%description doc
This package contains all the documentations required by programmers
using the Parma Polyhedra Library (PPL). Install this package if you
want to program with the PPL.
%prep
%setup -q -n ppl-%{version}
%build
%configure --enable-shared --with-pic --disable-rpath \
--disable-watchdog
#sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
#sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
make %{?_smp_mflags}
%if "%{name}" == "ppl-testsuite"
%check
make %{?_smp_mflags} check
%install
%else
%install
make DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -p" install
# We don't build the binary, so delete its manpage
rm -f %{buildroot}%{_mandir}/man1/ppl_lpsol.1
# We don't build pwl
rm -Rf %{buildroot}%{_datadir}/doc/pwl
# The pdf is enough
rm -f %{buildroot}%{_datadir}/doc/%{name}/ppl-user-*.ps.gz
rm -f %{buildroot}%{_datadir}/doc/%{name}/ChangeLog
rm -f %{buildroot}%{_datadir}/doc/%{name}/TODO
rm -f %{buildroot}%{_datadir}/doc/%{name}/gpl.*
rm -f %{buildroot}%{_datadir}/doc/%{name}/fdl.ps.gz
rm -f %{buildroot}%{_datadir}/doc/%{name}/fdl.pdf
rm -Rf %{buildroot}%{_datadir}/doc/%{name}/ppl-user-prolog-interface-%{version}*
rm -Rf %{buildroot}%{_datadir}/doc/%{name}/ppl-user-ocaml-interface-%{version}*
rm -Rf %{buildroot}%{_datadir}/doc/%{name}/ppl-user-java-interface-%{version}*
# %name == ppl
%endif
%post -n libppl9 -p /sbin/ldconfig
%postun -n libppl9 -p /sbin/ldconfig
%post -n libppl_c4 -p /sbin/ldconfig
%postun -n libppl_c4 -p /sbin/ldconfig
%if "%{name}" == "ppl"
%files
%defattr(-,root,root,-)
%dir %{_datadir}/doc/%{name}
%doc %{_datadir}/doc/%{name}/BUGS
%doc %{_datadir}/doc/%{name}/COPYING
%doc %{_datadir}/doc/%{name}/CREDITS
%doc %{_datadir}/doc/%{name}/NEWS
%doc %{_datadir}/doc/%{name}/README
%{_bindir}/ppl_lcdd
%{_bindir}/ppl_pips
%{_mandir}/man1/ppl_lcdd.1.gz
%{_mandir}/man1/ppl_pips.1.gz
%files -n libppl9
%defattr(-,root,root,-)
%{_libdir}/libppl.so.*
%files -n libppl_c4
%defattr(-,root,root,-)
%{_libdir}/libppl_c.so.*
%files devel
%defattr(-,root,root,-)
%doc %{_datadir}/doc/%{name}/README.configure
%{_includedir}/ppl.hh
%{_includedir}/ppl_c.h
%{_libdir}/libppl.so
%{_libdir}/libppl_c.so
%{_bindir}/ppl-config
%{_mandir}/man1/ppl-config.1.gz
%{_mandir}/man3/libppl.3.gz
%{_mandir}/man3/libppl_c.3.gz
%{_datadir}/aclocal/ppl.m4
%{_datadir}/aclocal/ppl_c.m4
%files devel-static
%defattr(-,root,root,-)
%{_libdir}/libppl.a
%{_libdir}/libppl.la
%{_libdir}/libppl_c.a
%{_libdir}/libppl_c.la
%files doc
%defattr(-,root,root,-)
%doc %{_datadir}/doc/%{name}/README.doc
%doc %{_datadir}/doc/%{name}/fdl.txt
%doc %{_datadir}/doc/%{name}/ppl-user-%{version}-html/
%doc %{_datadir}/doc/%{name}/ppl-user-c-interface-%{version}-html/
%doc %{_datadir}/doc/%{name}/ppl-user-%{version}.pdf
%doc %{_datadir}/doc/%{name}/ppl-user-c-interface-%{version}.pdf
%endif
%clean
rm -rf $RPM_BUILD_ROOT
%changelog