File perl-Test-Class.spec of Package perl-Test-Class

#
# spec file for package perl-Test-Class
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#



Name:           perl-Test-Class
Version:        0.36
Release:        1
Summary:        Easily create test classes in an xUnit/JUnit style
Source:         http://search.cpan.org/CPAN/authors/id/A/AD/ADIE/Test-Class-%{version}.tar.gz
Url:            http://search.cpan.org/dist/Test-Class
Group:          Development/Libraries/Perl
License:        Artistic-1.0 or GPL-1.0+
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%{perl_requires}
BuildRequires:  perl
BuildRequires:  perl-macros
BuildRequires:  perl(Test::Exception) >= 0.25
BuildRequires:  perl(IO::File) >= 1.09
BuildRequires:  perl(Module::Build) >= 0.36
BuildRequires:  perl(Module::Build)
BuildRequires:  perl(Attribute::Handlers) >= 0.77
BuildRequires:  perl(Storable) >= 2.04
BuildRequires:  perl(Test::Simple) >= 0.78
BuildRequires:  perl(Test::Builder::Tester) >= 1.02
BuildRequires:  perl(Test::More) >= 0.78
BuildRequires:  perl(Test::Builder) >= 0.78
BuildRequires:  perl(MRO::Compat) >= 0.11
BuildRequires:  perl(Contextual::Return)
Requires:       perl(Attribute::Handlers) >= 0.77
Requires:       perl(Storable) >= 2.04
Requires:       perl(Test::Simple) >= 0.78
Requires:       perl(Test::Builder::Tester) >= 1.02
Requires:       perl(Test::More) >= 0.78
Requires:       perl(Test::Builder) >= 0.78
Requires:       perl(MRO::Compat) >= 0.11

%description
Test::Class provides a simple way of creating classes and objects to test
your code in an xUnit style.
Built using Test::Builder, it was designed to work with other
Test::Builder based modules (Test::More, Test::Differences,
Test::Exception, etc.).
*Note:* This module will make more sense, if you are already familiar with
the "standard" mechanisms for testing perl code. Those unfamiliar with
Test::Harness, Test::Simple, Test::More and friends should go take a look
at them now. Test::Tutorial is a good starting point.

%prep
%setup -q -n "Test-Class-%{version}"
# fix 0755 perms
%__chmod 0644 Changes

%build
%__perl ./Build.PL
./Build

%install
./Build pure_install --destdir "%{buildroot}" --installdirs vendor
%perl_process_packlist

%check
./Build test

%clean
%{?buildroot:%__rm -rf "%{buildroot}"}

%files
%defattr(-,root,root)
%doc Changes README
%dir %{perl_vendorlib}/Test
%{perl_vendorlib}/Test/Class.pm
%{perl_vendorlib}/Test/Class
%dir %{perl_vendorarch}/auto/Test
%{perl_vendorarch}/auto/Test/Class
%doc %{perl_man3dir}/Test::Class.%{perl_man3ext}%{ext_man}
%doc %{perl_man3dir}/Test::Class::*.%{perl_man3ext}%{ext_man}
%changelog
openSUSE Build Service is sponsored by