File qscintilla.spec of Package qscintilla
#
# spec file for package qscintilla
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: qscintilla
BuildRequires: libdrm-devel
BuildRequires: libqt4-devel
Url: http://www.riverbankcomputing.co.uk/software/qscintilla/intro
Summary: C++ Editor Class Library
License: GPL-2.0+
Group: Development/Libraries/C and C++
BuildRoot: %{_tmppath}/%{name}-%{version}-build
Version: 2.6.1
Release: 0
%define scintilla_version %version
Source: http://www.riverbankcomputing.co.uk/static/Downloads/QScintilla2/QScintilla-gpl-%{version}.tar.gz
Patch: %name.diff
%define debug_package_requires libqscintilla2-8 = %version-%release
%description
QScintilla is a Qt port of Neil Hodgson's Scintilla C++ editor class.
This is a Qt port from the original Scintilla class
(http://www.scintilla.org/).
This package is mainly used by eric, the Python IDE.
Authors:
--------
Riverbank Computing Limited <info@riverbankcomputing.co.uk>
%package -n libqscintilla2-8
Summary: C++ Editor Class Library
Group: Development/Libraries/C and C++
Provides: qscintilla = %{version}
%description -n libqscintilla2-8
QScintilla is a Qt port of Neil Hodgson's Scintilla C++ editor class.
This is a Qt port from the original Scintilla class
(http://www.scintilla.org/).
This package is mainly used by eric, the Python IDE.
Authors:
--------
Riverbank Computing Limited <info@riverbankcomputing.co.uk>
%package -n libqscintilla-devel
Summary: C++ Editor Class Library Development Files
Group: Development/Libraries/C and C++
Requires: libqscintilla2-8 = %{version}
Requires: libqt4-devel >= %( echo `rpm -q --queryformat '%{VERSION}' libqt4-devel`)
# openSUSE 10.3
Provides: qscintilla-devel = %{version}
Obsoletes: qscintilla-devel <= %{version}
%description -n libqscintilla-devel
QScintilla is a Qt port of Neil Hodgson's Scintilla C++ editor class.
This is a Qt port from the original Scintilla class
(http://www.scintilla.org/).
This package is mainly used by eric, the Python IDE.
Authors:
--------
Riverbank Computing Limited <info@riverbankcomputing.co.uk>
%prep
%setup -q -n QScintilla-gpl-%scintilla_version
%patch
%build
pushd Qt4
qmake
make %{?jobs:-j %jobs}
popd
pushd designer-Qt4
qmake
make %{?jobs:-j %jobs}
popd
%install
pushd Qt4
make INSTALL_ROOT=$RPM_BUILD_ROOT install
popd
pushd designer-Qt4
make INSTALL_ROOT=$RPM_BUILD_ROOT install
popd
%post -n libqscintilla2-8 -p /sbin/ldconfig
%postun -n libqscintilla2-8 -p /sbin/ldconfig
%clean
rm -rf $RPM_BUILD_ROOT
%files -n libqscintilla2-8
%defattr(-,root,root)
%doc NEWS README LICENSE.GPL2 LICENSE.GPL3
/usr/share/qt4/qsci
/usr/share/qt4/translations/qscintilla_*.qm
%_libdir/libqscintilla2.so.8*
%files -n libqscintilla-devel
%defattr(-,root,root)
/usr/include/Qsci
/usr/include/Qsci/*
%_libdir/libqscintilla2.so
%_libdir/qt4/plugins/designer/libqscintillaplugin.so
%changelog