File libserf.spec of Package libserf
#
# spec file for package libserf
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: libserf
%define soname 0
%define major 1
Version: 1.1.1
Release: 0
Summary: High-Performance Asynchronous HTTP Client Library
License: Apache-2.0
Group: System/Libraries
Source: https://serf.googlecode.com/files/serf-%{version}.tar.bz2
Url: https://serf.googlecode.com
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: gcc
BuildRequires: glibc-devel
BuildRequires: libapr-util1-devel
BuildRequires: libapr1-devel
BuildRequires: libexpat-devel
BuildRequires: libopenssl-devel
BuildRequires: libtool
BuildRequires: make
BuildRequires: openldap2-devel
BuildRequires: pkgconfig
BuildRequires: zlib-devel
%description
The serf library is a C-based HTTP client library built upon the Apache
Portable Runtime (APR) library. It multiplexes connections, running the
read/write communication asynchronously. Memory copies and transformations are
kept to a minimum to provide high performance operation.
Authors:
--------
Greg Stein <serf-dev@googlegroups.com>
Justin Erenkrantz <serf-dev@googlegroups.com>
%package -n libserf-1-0
Summary: High-Performance Asynchronous HTTP Client Library
Group: Development/Libraries/C and C++
%description -n libserf-1-0
The serf library is a C-based HTTP client library built upon the Apache
Portable Runtime (APR) library. It multiplexes connections, running the
read/write communication asynchronously. Memory copies and transformations are
kept to a minimum to provide high performance operation.
Authors:
--------
Greg Stein <serf-dev@googlegroups.com>
Justin Erenkrantz <serf-dev@googlegroups.com>
%package -n libserf-devel
Summary: High-Performance Asynchronous HTTP Client Library
Group: Development/Libraries/C and C++
Requires: libapr-util1-devel
Requires: libapr1-devel
Requires: libexpat-devel
Requires: libopenssl-devel
Requires: libserf-1-0 = %{version}
Requires: openldap2-devel
Requires: zlib-devel
%description -n libserf-devel
The serf library is a C-based HTTP client library built upon the Apache
Portable Runtime (APR) library. It multiplexes connections, running the
read/write communication asynchronously. Memory copies and transformations are
kept to a minimum to provide high performance operation.
Authors:
--------
Greg Stein <serf-dev@googlegroups.com>
Justin Erenkrantz <serf-dev@googlegroups.com>
%prep
%setup -q -n "serf-%{version}"
%build
%configure \
--includedir=%{_includedir}/serf-%{major}
make %{?_smp_mflags}
%install
%makeinstall
%__rm -f "%{buildroot}%{_libdir}"/lib*.a
%__rm "%{buildroot}%{_libdir}"/lib*.la
%check
%__make check
%post -n libserf-1-0 -p /sbin/ldconfig
%postun -n libserf-1-0 -p /sbin/ldconfig
%files -n libserf-1-0
%defattr(-,root,root)
%doc CHANGES LICENSE NOTICE README
%doc design-guide.txt
%{_libdir}/libserf-%{major}.so.%{soname}
%{_libdir}/libserf-%{major}.so.%{soname}.*.*
%files -n libserf-devel
%defattr(-,root,root)
%_includedir/serf-%major
%{_libdir}/libserf-%{major}.so
%{_libdir}/pkgconfig/serf-%{major}.pc
%changelog