File monodevelop.spec of Package monodevelop
#
# spec file for package monodevelop
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: monodevelop
BuildRequires: mono-data
BuildRequires: mono-data-postgresql
BuildRequires: pkgconfig(glade-sharp-2.0)
BuildRequires: pkgconfig(glib-sharp-2.0)
BuildRequires: pkgconfig(gnome-sharp-2.0)
BuildRequires: pkgconfig(gtk-sharp-2.0)
BuildRequires: pkgconfig(mono)
BuildRequires: pkgconfig(mono-addins)
BuildRequires: pkgconfig(mono-nunit)
BuildRequires: pkgconfig(monodoc)
BuildRequires: pkgconfig(wcf)
# Mono.Cecil.dll requires rsync after it's build
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: libtool
BuildRequires: rsync
Url: http://www.monodevelop.com/
Version: 3.0.6
Release: 0
Summary: A Full-Featured IDE for Mono and Gtk#
License: GPL-2.0+
Group: Development/Languages/Mono
Source: %{name}-%{version}.tar.bz2
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildArch: noarch
Requires: mono-basic
Requires: mono-devel
Requires: pkgconfig
Requires: xsp
%if 0%{?suse_version} > 1100
BuildRequires: pkgconfig(gconf-sharp-2.0)
BuildRequires: pkgconfig(gnome-print-sharp-2.18)
BuildRequires: pkgconfig(gtksourceview-sharp-2.0)
# TODO: Add build requirements for ASP.NET
#BuildRequires: pkgconfig(gecko-sharp-2.0)
#BuildRequires: pkgconfig(jscall-sharp)
%endif
BuildRequires: desktop-file-utils
%if 0%{?fedora} || 0%{?rhel_version}
%define env_options export MONO_SHARED_DIR=/tmp
%endif
%description
MonoDevelop is a full-featured integrated development
environment (IDE) for mono and Gtk#. It was originally a port of
SharpDevelop 0.98. See http://monodevelop.com/ for more information.
%prep
%setup -q
%build
autoreconf -f -i
%{?env_options}
%configure \
--enable-subversion \
--enable-git \
--enable-monoextensions \
--disable-update-mimedb \
--disable-update-desktopdb
make
%install
%{?env_options}
make install DESTDIR=%{buildroot} GACUTIL_FLAGS="/package monodevelop /root %{buildroot}%{_prefix}/%{_lib}"
#
mkdir -p %{buildroot}%{_prefix}/share/pkgconfig
mv %{buildroot}/usr/lib/pkgconfig/* %{buildroot}%{_datadir}/pkgconfig
desktop-file-install --dir=%{buildroot}/%{_datadir}/applications monodevelop.desktop
%find_lang %{name}
%files -f %{name}.lang
%defattr(-,root,root)
%{_bindir}/*
%{_datadir}/applications/monodevelop.desktop
%{_datadir}/icons/hicolor/*/apps/monodevelop.png
%{_datadir}/icons/hicolor/scalable/apps/monodevelop.svg
%{_prefix}/lib/monodevelop
%{_datadir}/pkgconfig/monodevelop.pc
%{_datadir}/pkgconfig/monodevelop-core-addins.pc
%{_mandir}/man1/mdtool.1%ext_man
%{_mandir}/man1/monodevelop.1%ext_man
%{_datadir}/mime/packages/monodevelop.xml
%post
update-mime-database /usr/share/mime >/dev/null || :
%postun
update-mime-database /usr/share/mime >/dev/null || :
%define __find_provides env sh -c 'filelist=($(cat)) && { printf "%s\\n" "${filelist[@]}" | /usr/lib/rpm/find-provides && printf "%s\\n" "${filelist[@]}" | /usr/bin/mono-find-provides ; } | sort | uniq'
%define __find_requires env sh -c 'filelist=($(cat)) && { printf "%s\\n" "${filelist[@]}" | /usr/lib/rpm/find-requires && printf "%s\\n" "${filelist[@]}" | /usr/bin/mono-find-requires ; } | sort | uniq'
%changelog