File quilt.spec of Package quilt

#
# spec file for package quilt
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           quilt
BuildRequires:  diffstat
BuildRequires:  ed
BuildRequires:  emacs-nox
BuildRequires:  procmail
Summary:        A Tool for Working with Many Patches
License:        GPL-2.0+
Group:          Productivity/Text/Utilities
Version:        0.60
Release:        0
Requires:       bzip2
Requires:       coreutils
Requires:       diffstat
Requires:       diffutils
Requires:       file
Requires:       findutils
Requires:       gzip
Requires:       mktemp
Requires:       patch
Requires:       perl
%if %{suse_version} > 910
Recommends:     procmail
%endif
%if %{suse_version} > 1120
Recommends:     xz
%endif
AutoReqProv:    off
Source:         %{name}-%{version}.tar.bz2
Source1:        suse-start-quilt-mode.el
Patch1:         expand.diff
patch2:         quilt-support-vimdiff.patch
Patch3:         patch-wrapper-rpm.diff
Patch5:         suse-workaround-pseudo-release.patch
Patch6:         quilt-stable-rebuild.patch
Patch7:         quilt-setup-01-check-existing-files-after-unpack.patch
Patch8:         quilt-setup-02-try-alternative-names.patch
Patch9:         quilt-setup-03-remember-alternative-names.patch
Patch10:        quilt-setup-04-handle-zip-files.patch
Patch11:        quilt-setup-05-fix-check_for_existing_files.patch
Patch12:        quilt-setup-06-check-for-directories-too.patch
Url:            http://savannah.nongnu.org/projects/quilt
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildArch:      noarch

%description
Quilt allows you to easily manage large numbers of patches by keeping
track of the changes each patch makes. Patches can be applied,
un-applied, refreshed, and more.

Quilt originally was based on Andrew Morton's patch scripts found at
http://www.zip.com.au/~akpm/linux/patches/.



Authors:
--------
    Andreas Gruenbacher <agruen@suse.de>
    Jean Delvare <jdelvare@suse.de>

%prep
%setup -q
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch5 -p1
%patch6 -p1
%patch7 -p1
%patch8 -p1
%patch9 -p1
%patch10 -p1
%patch11 -p1
%patch12 -p1

%build
# --with-rpmbuild=/usr/lib/rpm/rpmb:
#
#   SUSE Autobuild uses a version of /usr/bin/rpmbuild that sources
#   /etc/profile to reset the PATH. We must not do that: the
#   inspect script needs to pass an additional path component to
#   rpmbuild for the tar and patch wrappers.
CFLAGS="$RPM_OPT_FLAGS" \
./configure --prefix=/usr \
    --mandir=%{_mandir} \
    --docdir=%{_docdir}/%{name} \
    --with-sendmail=/usr/sbin/sendmail \
    --with-diffstat=/usr/bin/diffstat \
    --with-patch-wrapper \
    --with-patch=/usr/bin/patch \
    --with-rpmbuild=/usr/lib/rpm/rpmb
make %{?jobs:-j%jobs} RELEASE=%release
# Compile quilt.el for faster emacs startup (bnc#617673)
pushd lib
emacs -batch -q --no-site -f batch-byte-compile quilt.el
popd

%check
make check

%install
# /usr/share/quilt/compat/mta will be a stale symlink: we don't want to add
# sendmail to neededforbuild just because of this.
export NO_BRP_STALE_LINK_ERROR=yes
make install BUILD_ROOT=$RPM_BUILD_ROOT
install -m 644 lib/quilt.elc \
	$RPM_BUILD_ROOT/usr/share/emacs/site-lisp/
mv $RPM_BUILD_ROOT/etc/bash_completion.d/quilt{,.sh}
# We only needed the /usr/bin/patch compatibility symlink for the
# test suite.
[ $RPM_BUILD_ROOT/usr/share/quilt/compat/patch -ef /usr/bin/patch ] \
    && rm -f $RPM_BUILD_ROOT/usr/share/quilt/compat/patch
[ $RPM_BUILD_ROOT/usr/share/quilt/compat/awk -ef /usr/bin/awk ] \
    && rm -f $RPM_BUILD_ROOT/usr/share/quilt/compat/awk
%{find_lang} %{name}
# Make "vi" an alias for the edit command
ln -s edit $RPM_BUILD_ROOT/usr/share/quilt/vi
# Autoload quilt-mode in the SuSE emacs package
install -m 644 %_sourcedir/suse-start-quilt-mode.el \
	$RPM_BUILD_ROOT/usr/share/emacs/site-lisp/

%clean
rm -rf $RPM_BUILD_ROOT

%files -f %{name}.lang
%defattr(-, root, root)
/usr/bin/guards
/usr/bin/quilt
/usr/share/quilt/
/usr/share/emacs/
%config /etc/quilt.quiltrc
%config /etc/bash_completion.d/quilt.sh
%doc %{_mandir}/man1/guards.1.gz
%doc %{_mandir}/man1/quilt.1.gz
%doc doc/README
%doc doc/README.MAIL
%doc doc/quilt.pdf

%changelog
openSUSE Build Service is sponsored by