File ccrtp.spec of Package ccrtp

#
# spec file for package ccrtp
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#



Name:           ccrtp
%define lname libccrtp2
Version:        2.0.1
Release:        9
License:        SUSE-GPL-2.0+-with-openssl-exception
Summary:        A Common C++ Class Framework for RTP Packets
Url:            http://www.gnu.org/software/ccrtp/
Group:          System/Libraries
Source0:        %{name}-%{version}.tar.bz2
Patch1:         ccrtp-ppc64.patch
BuildRequires:  cmake
BuildRequires:  gcc-c++
BuildRequires:  libgcrypt-devel
BuildRequires:  libstdc++-devel
BuildRequires:  pkgconfig
BuildRequires:  ucommon-devel >= 5.0.0
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
The ccrtp package offers a generic framework for sending and receiving
real-time streaming data over UDP packets using sending and receiving
packet queues.

%package -n %lname
Summary:        A Common C++ Class Framework for RTP Packets
Group:          System/Libraries

%description -n %lname
The ccrtp package offers a generic framework for sending and receiving
real-time streaming data over UDP packets using sending and receiving
packet queues.

%package devel
License:        SUSE-GPL-2.0+-with-openssl-exception
Summary:        Include-files and documentation for ccrtp
Group:          Development/Libraries/Other
PreReq:         %install_info_prereq
Requires:       %{lname} = %{version}
Requires:       libgcrypt-devel
Requires:       ucommon-devel >= 5.0.0
Provides:       libccrtp-devel = %version
Provides:       %lname-devel = %version
Obsoletes:      libccrtp-devel < %version

%description devel
This package contains files needed when developing applications using
ccrtp

%prep
%setup -q -n ccrtp-%{version}
%patch1 -p1

%build
mkdir build
cd build
cmake -DCMAKE_INSTALL_PREFIX=%{_prefix} \
      -DSYSCONFDIR=%{_sysconfdir} \
      -DMANDIR=%{_mandir} \
      -DCMAKE_VERBOSE_MAKEFILE=TRUE \
      -DCMAKE_C_FLAGS_RELEASE:STRING="%{optflags}" \
      -DCMAKE_CXX_FLAGS_RELEASE:STRING="%{optflags}" \
      ..

make %{?_smp_mflags} VERBOSE=1

%install
cd build
%make_install

%clean
rm -rf %{buildroot};

%post -n %lname -p /sbin/ldconfig

%postun -n %lname -p /sbin/ldconfig

%files -n %lname
%defattr(-,root,root,0755)
%{_libdir}/libccrtp*.so.*

%files devel
%defattr(-,root,root,0755)
%doc AUTHORS COPYING NEWS README TODO ChangeLog
%{_libdir}/libccrtp*.so
%{_libdir}/pkgconfig/libccrtp.pc
%dir %{_includedir}/ccrtp
%{_includedir}/ccrtp/*.h
%{_infodir}/ccrtp.info*

%post devel
%install_info --info-dir=%{_infodir} %{_infodir}/ccrtp.info.gz

%postun devel
%install_info_delete --info-dir=%{_infodir} %{_infodir}/ccrtp.info.gz

%changelog
openSUSE Build Service is sponsored by