File giflib.spec of Package giflib

#
# spec file for package giflib
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           giflib
%define lname	libgif6
Version:        5.0.5
Release:        0
Summary:        A Library for Working with GIF Images
License:        MIT
Group:          Development/Libraries/C and C++
Url:            http://giflib.sf.net/

#Git-Clone:	git://git.code.sf.net/p/giflib/code
#Freecode-URL:	http://freecode.com/projects/giflib
Source:         http://downloads.sf.net/giflib/%name-%version.tar.bz2
Source2:        baselibs.conf
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Patch1:         giflib-visibility.patch
Patch2:         giflib-automake-1_13.patch
BuildRequires:  libtool >= 2
BuildRequires:  xorg-x11-libICE-devel
BuildRequires:  xorg-x11-libSM-devel
BuildRequires:  xorg-x11-libX11-devel
BuildRequires:  xorg-x11-libXau-devel
BuildRequires:  xorg-x11-libXdmcp-devel
BuildRequires:  xorg-x11-libXt-devel

%description
This Library allows manipulating GIF Image files. Since the LZW patents
have expired, giflib can again be used instead of libungif.

%package -n %lname
Summary:        A Library for Working with GIF Images
Group:          System/Libraries
# bug437293
%ifarch ppc64
Obsoletes:      giflib-64bit
%endif

%description -n %lname
This Library allows manipulating GIF Image files. Since the LZW patents
have expired, giflib can again be used instead of libungif.

%package progs
Summary:        Tools for Working with the GIF Library
Group:          Productivity/Graphics/Convertors
Provides:       ungif
Obsoletes:      ungif

%description progs
A tool for converting GIFs to various formats.

%package devel
Summary:        Library for Working with GIF Images - Files Mandatory for Development
Group:          Development/Libraries/C and C++
Requires:       %lname = %version
# bug437293
%ifarch ppc64
Obsoletes:      giflib-devel-64bit
%endif
#

%description devel
This Library allows manipulating GIF Image files. Since the LZW patents
have expired, giflib can again be used instead of libungif.

%prep
%setup -q
# LT_INIT requires libtool >= 2
%patch -P 1 -P 2 -p1

%build
# USE __TIMESTAMP__ instead of __DATE__ , __TIME__
# this change is pointless unless we preserve the original 
# file modification time
for file in `find util -name "*.c"`; do 
	touch -r $file $file.stamp; 
	sed -i -e s@'__DATE__ ",   " __TIME__'@__TIMESTAMP__@g $file; 
    touch -r $file.stamp $file;
    rm -v $file.stamp
done

mkdir -p m4; autoreconf -fiv
%configure --disable-static --with-pic --x-libraries=%{_libdir}
make %{?_smp_mflags} V=1

%install
make install DESTDIR=$RPM_BUILD_ROOT
#ln -sf libgif.a $RPM_BUILD_ROOT%{_libdir}/libungif.a
rm -f %{buildroot}%{_libdir}/*.la
find doc -name "Makefile*" -print -delete

%post -n %lname -p /sbin/ldconfig

%postun -n %lname -p /sbin/ldconfig

%files -n %lname
%defattr(-,root,root)
%doc COPYING
%{_libdir}/lib*.so.*

%files devel
%defattr(-,root,root)
%_includedir/gif_lib.h
%{_libdir}/lib*.so

%files progs
%defattr(-,root,root)
%doc COPYING NEWS README doc
%_bindir/*

%changelog
openSUSE Build Service is sponsored by