File horde5-imp.spec of Package horde5-imp
#
# spec file for package horde5-imp
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%define peardir %(pear config-get php_dir 2> /dev/null || echo %{_datadir}/pear)
%define xmldir /var/lib/pear
%define hordedir /usr/share/php5/PEAR/www/horde
%define pear_name imp
Summary: IMP - A web based webmailer
License: GPL-2.0
Group: Productivity/Networking/Web/Utilities
Name: horde5-imp
Version: 6.0.2
Release: 0
Source0: http://pear.horde.org/get/imp-%{version}.tgz
Source1: imp.conf
BuildRoot: %{_tmppath}/%{name}-%{version}-build
Url: http://pear.horde.org/package/imp
BuildRequires: horde5 >= 5.0.2
BuildRequires: php >= 5.3.0
BuildRequires: php-pear >= 1.7.0
Requires: horde5 >= 5.0.2
Requires: php >= 5.3.0
Requires: php-pear >= 1.7.0
BuildRequires: fdupes
BuildRequires: php5-pear-Horde_Role >= 1.0.1
BuildRequires: php5-pear-channel-horde
Requires: php5-pear-Horde_Auth >= 2.0.0
Requires: php5-pear-Horde_Browser >= 2.0.0
Requires: php5-pear-Horde_Compress >= 2.0.0
Requires: php5-pear-Horde_Core >= 2.0.0
Requires: php5-pear-Horde_Crypt >= 2.0.0
Requires: php5-pear-Horde_Date >= 2.0.0
Requires: php5-pear-Horde_Editor >= 2.0.0
Requires: php5-pear-Horde_Exception >= 2.0.0
Requires: php5-pear-Horde_Form >= 2.0.0
Requires: php5-pear-Horde_Icalendar >= 2.0.0
Requires: php5-pear-Horde_Image >= 2.0.0
Requires: php5-pear-Horde_Imap_Client >= 2.3.0
Requires: php5-pear-Horde_Itip >= 2.0.1
Requires: php5-pear-Horde_ListHeaders >= 1.0.0
Requires: php5-pear-Horde_LoginTasks >= 2.0.0
Requires: php5-pear-Horde_Mail >= 2.0.0
Requires: php5-pear-Horde_Mime >= 2.0.0
Requires: php5-pear-Horde_Mime_Viewer >= 2.0.0
Requires: php5-pear-Horde_Nls >= 2.0.0
Requires: php5-pear-Horde_Notification >= 2.0.0
Requires: php5-pear-Horde_Perms >= 2.0.0
Requires: php5-pear-Horde_Role >= 1.0.1
Requires: php5-pear-Horde_Serialize >= 2.0.0
Requires: php5-pear-Horde_SpellChecker >= 2.0.0
Requires: php5-pear-Horde_Support >= 2.0.0
Requires: php5-pear-Horde_Text_Filter >= 2.0.0
Requires: php5-pear-Horde_Text_Flowed >= 2.0.0
Requires: php5-pear-Horde_Token >= 2.0.0
Requires: php5-pear-Horde_Tree >= 2.0.0
Requires: php5-pear-Horde_Url >= 2.0.0
Requires: php5-pear-Horde_Util >= 2.0.0
Requires: php5-pear-Horde_View >= 2.0.0
Requires: php5-pear-channel-horde
Suggests: php5-pear-Horde_Text_Filter_Csstidy >= 2.0.1
Suggests: php5-pear-Horde_Vfs >= 2.0.0
Requires: horde5-content
Requires: horde5-timeobjects
Requires: php-dom
Requires: php-gettext
Requires: php-json
Requires: php-openssl
#php5-simplexml
BuildArch: noarch
%description
IMP, the Internet Mail Program, is one of the most popular and widely deployed open source webmail applications in the world.
It allows universal, web-based access to IMAP and POP3 mail servers and provides Ajax, mobile and traditional interfaces
with a rich range of features normally found only in desktop email clients.
%prep
%setup -c -T
pear -v -c pearrc \
-d php_dir=%{peardir} \
-d doc_dir=%{_docdir}/%{name} \
-d bin_dir=%{_bindir} \
-d data_dir=%{peardir}/data \
-d test_dir=%{peardir}/tests \
-d ext_dir=%{_libdir} \
-d horde_dir=%{hordedir} \
-s
%build
%install
pear -c pearrc install --nodeps --packagingroot %{buildroot} %{SOURCE0}
%fdupes %buildroot%{hordedir}/%{pear_name}
## configs written by the web configurator should go to etc
%{__mkdir_p} %{buildroot}/etc/horde/
%{__mv} %{buildroot}/%{hordedir}/imp/config %{buildroot}/etc/horde/imp
%{__ln_s} /etc/horde/imp %{buildroot}/%{hordedir}/imp/config
## we provide an own apache config and delete the htaccess files
%{__install} -m 0660 -D %{SOURCE1} %{buildroot}/etc/horde/apache-snippets.d/imp.conf
%{__rm} %{buildroot}/etc/horde/imp/.htaccess
%{__rm} %{buildroot}/%{hordedir}/imp/lib/.htaccess
%{__rm} %{buildroot}/%{hordedir}/imp/locale/.htaccess
%{__rm} %{buildroot}/%{hordedir}/imp/templates/.htaccess
%find_lang %{pear_name}
# Clean up unnecessary files
rm pearrc
rm %{buildroot}/%{peardir}/.filemap
rm %{buildroot}/%{peardir}/.lock
rm -rf %{buildroot}/%{peardir}/.registry
rm -rf %{buildroot}%{peardir}/.channels
rm %{buildroot}%{peardir}/.depdb
rm %{buildroot}%{peardir}/.depdblock
# Install XML package description
mkdir -p %{buildroot}%{xmldir}
tar -xzf %{SOURCE0} package.xml
cp -p package.xml %{buildroot}%{xmldir}/%{pear_name}.xml
%clean
rm -rf %{buildroot}
%post
pear install --nodeps --soft --force --register-only %{xmldir}/%{pear_name}.xml
%postun
if [ "$1" -eq "0" ]; then
pear uninstall --nodeps --ignore-errors --register-only pear.horde.org/%{pear_name}
fi
%files -f %{pear_name}.lang
%defattr(-,root,root)
%{peardir}/*
%{xmldir}/imp.xml
%{hordedir}/imp
%attr(0775,root,www) %{hordedir}/imp/config
%{_bindir}/imp-mailbox-decode
%{_bindir}/imp-bounce-spam
%{_bindir}/imp-query-imap-cache
%{_docdir}/horde5-imp/
%config /etc/horde/apache-snippets.d/imp.conf
%attr(0750,wwwrun,www) %dir /etc/horde/imp
%attr(0640,wwwrun,www) %config /etc/horde/imp/*
%changelog