File libqt5-qtdeclarative.spec of Package libqt5-qtdeclarative

#
# spec file for package libqt5-qtdeclarative
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%define libname libQtQuick5

Name:           libqt5-qtdeclarative
Version:        5.1.1
Release:        0
License:        SUSE-LGPL-2.1-with-digia-exception-1.1 or GPL-3.0
Summary:        Qt 5 Declarative Library
Url:            http://qt.digia.com
Group:          Development/Libraries/X11
Source:         %{tar_version}.tar.xz
BuildRequires:  fdupes
BuildRequires:  libQt5Svg-devel >= %{version}
BuildRequires:  libQt5V8-private-headers-devel >= %{version}
%define base_name libqt5
%define real_version 5.1.1
%define so_version 5.1.1
%define tar_version qtdeclarative-opensource-src-%{real_version}
BuildRequires:  libQt5XmlPatterns-devel >= %{version}
BuildRequires:  libqt5-qtbase-private-headers-devel >= %{version}
BuildRequires:  xz

BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
Qt is a set of libraries for developing applications.

This package contains base tools, like string, xml, and network
handling.

%prep
%setup -q -n qtdeclarative-opensource-src-%{real_version}

%package -n %libname
Summary:        Qt 5 Declarative Library
Group:          Development/Libraries/X11

%description -n %libname
Qt is a set of libraries for developing applications.

This package contains base tools, like string, xml, and network
handling.

%package -n libQt5Quick-devel
Summary:        Qt Development Kit
Group:          Development/Libraries/X11
Requires:       %libname = %{version}
Requires:       libQt5Svg-devel >= %{version}
Requires:       libQt5V8-devel >= %{version}
Requires:       libQt5XmlPatterns-devel >= %{version}
Requires:       libqt5-qtbase-devel >= %{version}

%description -n libQt5Quick-devel
You need this package, if you want to compile programs with qtdeclarative.

%package -n libQt5Quick-private-headers-devel
Summary:        Non-ABI stable experimental API
Group:          Development/Libraries/C and C++
Requires:       libQt5Quick-devel = %{version}
Requires:       libQt5V8-private-headers-devel >= %{version}
Requires:       libqt5-qtbase-private-headers-devel >= %{version}

%description -n libQt5Quick-private-headers-devel
This package provides private headers of libqt5-qtdeclarative that are normally
not used by application development and that do not have any ABI or
API guarantees. The packages that build against these have to require
the exact Qt version.

%post -n %libname -p /sbin/ldconfig

%postun -n %libname -p /sbin/ldconfig

%post -n libQt5Quick-devel -p /sbin/ldconfig

%postun -n libQt5Quick-devel -p /sbin/ldconfig

%build
export PATH=%{_libqt5_bindir}:$PATH
%ifarch ppc64
  RPM_OPT_FLAGS="%{optflags} -mminimal-toc"
%endif
export CXXFLAGS="$CXXFLAGS %{optflags} -DOPENSSL_LOAD_CONF"
export CFLAGS="$CFLAGS %{optflags} -DOPENSSL_LOAD_CONF"
export MAKEFLAGS="%{?_smp_mflags}"
qmake
make

%install
make INSTALL_ROOT=%{buildroot} install
find %{buildroot}/%{_libdir} -type f -name '*la' -print -exec perl -pi -e 's, -L%{_builddir}/\S+,,g' {} \;
find %{buildroot}/%{_libdir}/pkgconfig -type f -name '*pc' -print -exec perl -pi -e 's, -L%{_builddir}/\S+,,g' {} \;

# put all the binaries to %{_bindir}, add -qt5 suffix, and symlink them back to %_qt5_bindir
mkdir %{buildroot}%{_bindir}
pushd %{buildroot}%{_libqt5_bindir}
for i in * ; do
      mv $i ../../../bin/${i}-qt5
      ln -s ../../../bin/${i}-qt5 .
      ln -s ../../../bin/${i}-qt5 $i
done
popd

%fdupes %{buildroot}/%{_lib}qt5_includedir

%clean
rm -rf %{buildroot}

%files -n %libname
%defattr(-,root,root,755)
%{_libqt5_libdir}/libQt5Q*.so.*
%{_libqt5_archdatadir}/qml/QtQuick
%{_libqt5_archdatadir}/qml/QtQuick.2
%{_libqt5_archdatadir}/qml/QtQml/Models.2
%dir %{_libqt5_archdatadir}/qml
%dir %{_libqt5_archdatadir}/qml/Qt
%dir %{_libqt5_archdatadir}/qml/Qt/labs
%dir %{_libqt5_archdatadir}/qml/QtQml
%{_libqt5_archdatadir}/qml/Qt/labs/folderlistmodel
%{_libqt5_plugindir}/accessible
%{_libqt5_plugindir}/qmltooling

%files -n libQt5Quick-private-headers-devel
%defattr(-,root,root,755)
%{_libqt5_includedir}/Qt*/%{so_version}

%files -n libQt5Quick-devel
%defattr(-,root,root,755)
%{_bindir}/*
%{_libqt5_bindir}/*
%exclude %{_libqt5_includedir}/Qt*/%{so_version}
%{_libqt5_includedir}/Qt*
%{_libqt5_libdir}/cmake/Qt5Q*
%{_libqt5_libdir}/libQt5*.la
%{_libqt5_libdir}/libQt5*.prl
%{_libqt5_libdir}/libQt5Q*.so
%{_libqt5_libdir}/libQt5Q*.a
%{_libqt5_libdir}/pkgconfig/Qt5Q*.pc
%{_libqt5_archdatadir}/mkspecs/modules/qt_lib_*.pri
%{_libqt5_archdatadir}/qml/QtTest
%{_libqt5_libdir}/pkgconfig/Qt5QuickParticles.pc


%changelog
openSUSE Build Service is sponsored by