File multitail.spec of Package multitail
# vim: set ts=4 sw=4 et:
# Copyright (c) 2010-2012 Pascal Bleser <pascal.bleser@opensuse.org>
# 2004-2010 oc2pus
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
Name: multitail
Summary: Tail Multiple Files
Version: 5.2.12
Release: 0
Group: System/X11/Terminals
License: GPL-2.0+
URL: http://www.vanheusden.com/multitail/
Source: http://www.vanheusden.com/multitail/multitail-%{version}.tgz
Patch2: multitail-remove_date.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildRequires: ncurses-devel
BuildRequires: make
BuildRequires: gcc
%description
MultiTail lets you view one or multiple files like the original
tail program.
The difference is that it creates multiple windows on your console
(with ncurses). Merging of 2 or even more logfiles is possible.
It can also use colors while displaying the logfiles (through
regular expressions), for faster recognition of what is important
and what not. It can also filter lines (again with regular
expressions). It has interactive menus for editing given regular
expressions and deleting and adding windows. One can also have
windows with the output of shell scripts and other software. When
viewing the output of external software, MultiTail can mimic the
functionality of tools like 'watch' and such.
%prep
%setup -q
%patch2
%__sed -i 's/\r//g' manual.html
%__chmod 644 manual.html
%__sed -i 's|/etc/%{name}|%{_datadir}/%{name}|g' "%{name}.conf"
%build
export CFLAGS="%{optflags} -I%{_includedir}/ncurses"
%__make %{?_smp_mflags} DEBUG=""
%install
%__install -dm 755 %{buildroot}%{_sysconfdir}
%__install -m 644 %{name}.conf \
%{buildroot}%{_sysconfdir}
%__install -dm 755 %{buildroot}%{_bindir}
%__install -m 755 %{name} \
%{buildroot}%{_bindir}
%__install -dm 755 %{buildroot}%{_datadir}/%{name}
%__install -m 755 convert-* \
%{buildroot}%{_datadir}/%{name}
%__install -m 755 colors-* \
%{buildroot}%{_datadir}/%{name}
%__install -dm 755 %{buildroot}%{_mandir}/man1
%__install -m 644 %{name}.1 \
%{buildroot}%{_mandir}/man1
%clean
%{?buildroot:%__rm -rf "%{buildroot}"}
%files
%defattr(-, root, root)
%doc *.txt Changes manual*.html
%config(noreplace) %{_sysconfdir}/%{name}.conf
%dir %{_datadir}/multitail
%{_datadir}/multitail/*
%{_bindir}/multitail
%{_mandir}/man1/multitail.1%{ext_man}
%changelog