File netcfg.spec of Package netcfg

#
# spec file for package netcfg
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           netcfg
PreReq:         coreutils aaa_base
Summary:        Network Configuration Files in /etc
License:        BSD-3-Clause
Group:          System/Base
Version:        11.5
Release:        0
BuildArch:      noarch
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Source0:        defaultdomain
Source1:        exports
Source2:        ftpusers
Source3:        host.conf
Source4:        hosts
Source5:        hosts.allow
Source6:        hosts.deny
Source7:        hosts.equiv
Source8:        hosts.lpd
Source9:        networks
Source10:       protocols
Source11:       services.bz2
Source12:       HOSTNAME
Source13:       aliases
Source14:       ethers
Source15:       netgroup
Source16:       COPYING
Patch:          services-suse.diff

%description
All of the basic configuration files for the network programs including
/etc/aliases, /etc/protocols, and /etc/services.

These are often used by network routines in the C library and therefore
must be installed for all network programs.



%prep

%build
cp %{S:16} .

%install
mkdir -p $RPM_BUILD_ROOT/etc
for i in HOSTNAME aliases defaultdomain exports ftpusers host.conf hosts hosts.allow hosts.deny hosts.equiv hosts.lpd netgroup networks protocols services.bz2 ethers; do
  install $RPM_SOURCE_DIR/$i $RPM_BUILD_ROOT/etc
done
bunzip2 $RPM_BUILD_ROOT/etc/services.bz2
patch -p0 $RPM_BUILD_ROOT/etc/services < $RPM_SOURCE_DIR/services-suse.diff
rm -f $RPM_BUILD_ROOT/etc/services.orig

%pre
if [ "0$1" -ge "2" ]; then
# If we have a /etc/netgroup.rpmsave and no /etc/netgroup, copy
# /etc/netgroup.rpmsave and use it later instead of the new one.
   if [ -f /etc/netgroup.rpmsave -a ! -e /etc/netgroup ]; then
      cp /etc/netgroup.rpmsave /etc/...netgroup.new.rpmnew
   fi
fi

%post
test -f etc/defaultdomain.rpmnew -a ! -s etc/defaultdomain.rpmnew && rm -f etc/defaultdomain.rpmnew
if [ -f etc/...netgroup.new.rpmnew ]; then
  test ! -f etc/netgroup.rpmnew && cp etc/netgroup etc/netgroup.rpmnew
  mv etc/...netgroup.new.rpmnew etc/netgroup
fi
exit 0

%files
%defattr(644,root,root,755)
%verify(not md5 size mtime) %config(noreplace) /etc/HOSTNAME
%verify(not md5 size mtime) %config(noreplace) /etc/aliases
%verify(not md5 size mtime) %config(noreplace) /etc/defaultdomain
%verify(not md5 size mtime) %config(noreplace) /etc/ethers
%verify(not md5 size mtime) %config(noreplace) /etc/exports
%verify(not md5 size mtime) %config(noreplace) /etc/ftpusers
%config(noreplace) /etc/host.conf
%verify(not md5 size mtime) %config(noreplace) /etc/hosts
%verify(not md5 size mtime) %config(noreplace) /etc/hosts.allow
%verify(not md5 size mtime) %config(noreplace) /etc/hosts.deny
%verify(not md5 size mtime) %config(noreplace) /etc/hosts.equiv
%verify(not md5 size mtime) %config(noreplace) /etc/hosts.lpd
%config(noreplace) /etc/netgroup
%config(noreplace) /etc/networks
%config(noreplace) /etc/protocols
%config(noreplace) /etc/services
%doc COPYING

%changelog
openSUSE Build Service is sponsored by