File python-ctypes.spec of Package python-ctypes
#
# spec file for package python-ctypes
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: python-ctypes
Version: 1.0.2
Release: 0
Summary: Create and manipulate C data types in Python
License: MIT
Group: Development/Languages/Python
Url: http://pypi.python.org/pypi/ctypes/
Source0: http://downloads.sourceforge.net/project/ctypes/ctypes/%{version}/ctypes-%{version}.tar.gz
Patch0: ctypes-libffi-aarch64.patch
BuildRequires: python-devel
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%{!?python_sitearch: %global python_sitearch %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
%endif
%description
python-ctypes is a python module to create and manipulate C data types in
Python, and to call functions in dynamic link libraries/shared dlls. It
allows wrapping these libraries in pure Python.
%prep
%setup -n ctypes-%{version}
%patch0 -p1
%build
python setup.py build
%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
rm -rf %{buildroot}%{python_sitearch}/{ctypes/test,_ctypes_test.so} # Don't ship tests
%check
#python ctypes/test/runtests.py
%files
%defattr(-,root,root)
%doc LICENSE.txt README.txt
%{python_sitearch}/*
%changelog