File rubygem-rubyforge.spec of Package rubygem-rubyforge

#
# spec file for package rubygem-rubyforge
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           rubygem-rubyforge
Version:        2.0.4
Release:        0
%define mod_name rubyforge
%define mod_full_name %{mod_name}-%{version}

BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  ruby-macros >= 1
BuildRequires:  rubygem(rdoc) > 3.10
Url:            http://codeforpeople.rubyforge.org/rubyforge/
Source:         http://rubygems.org/gems/%{mod_full_name}.gem
Summary:        A script which automates a limited set of rubyforge operations
License:        GPL-2.0+ or Ruby
Group:          Development/Languages/Ruby
%define mod_branch -2.0.4
%define mod_weight 2
PreReq:         update-alternatives

%description
A script which automates a limited set of rubyforge operations.
* Run 'rubyforge help' for complete usage.
* Setup: For first time users AND upgrades to 0.4.0:
* rubyforge setup (deletes your username and password, so run sparingly!)
* edit ~/.rubyforge/user-config.yml
* rubyforge config
* For all rubyforge upgrades, run 'rubyforge config' to ensure you have
latest.

%package doc
Summary:        RDoc documentation for %{mod_name}
Group:          Development/Languages/Ruby
Requires:       %{name} = %{version}

%description doc
Documentation generated at gem installation time.
Usually in RDoc and RI formats.

%package testsuite
Summary:        Test suite for %{mod_name}
Group:          Development/Languages/Ruby
Requires:       %{name} = %{version}

%description testsuite
Test::Unit or RSpec files, useful for developers.

%prep
#gem_unpack
#if you need patches, apply them here and replace the # with a % sign in the surrounding lines
#gem_build

%build

%install
%gem_install -f
mv %{buildroot}%{_bindir}/rubyforge{,%{mod_branch}}
ln -s rubyforge%{mod_branch} %{buildroot}%{_bindir}/rubyforge

%post
/usr/sbin/update-alternatives --install \
    %{_bindir}/rubyforge rubyforge %{_bindir}/rubyforge%{mod_branch} %{mod_weight}

%preun
if [ "$1" = 0 ] ; then
    /usr/sbin/update-alternatives --remove rubyforge %{_bindir}/rubyforge%{mod_branch}
fi

%files
%defattr(-,root,root,-)
%{_bindir}/rubyforge%{mod_branch}
%ghost %{_bindir}/rubyforge
%{_libdir}/ruby/gems/%{rb_ver}/cache/%{mod_full_name}.gem
%{_libdir}/ruby/gems/%{rb_ver}/gems/%{mod_full_name}/
%exclude %{_libdir}/ruby/gems/%{rb_ver}/gems/%{mod_full_name}/test
%{_libdir}/ruby/gems/%{rb_ver}/specifications/%{mod_full_name}.gemspec

%files doc
%defattr(-,root,root,-)
%doc %{_libdir}/ruby/gems/%{rb_ver}/doc/%{mod_full_name}/

%files testsuite
%defattr(-,root,root,-)
%{_libdir}/ruby/gems/%{rb_ver}/gems/%{mod_full_name}/test

%changelog
openSUSE Build Service is sponsored by