File yast2-bootloader.spec of Package yast2-bootloader
#
# spec file for package yast2-bootloader
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: yast2-bootloader
Version: 3.0.3
Release: 0
BuildRoot: %{_tmppath}/%{name}-%{version}-build
Source0: yast2-bootloader-%{version}.tar.bz2
BuildRequires: update-desktop-files
BuildRequires: yast2-devtools
PreReq: /bin/sed %fillup_prereq
# Installation::*version variables
# Wizard::SetDialogTitleAndIcon
Requires: parted
Requires: perl-Bootloader >= 0.5.4
Requires: perl-Compress-Zlib
Requires: yast2 >= 2.21.22
Requires: yast2-core >= 2.18.7
Requires: yast2-packager >= 2.17.24
Requires: yast2-pkg-bindings >= 2.17.25
Requires: yast2-storage >= 2.18.18
%ifarch %ix86 x86_64
Requires: syslinux
%endif
Provides: yast2-config-bootloader
Provides: yast2-config-lilo
Obsoletes: yast2-config-bootloader
Obsoletes: yast2-config-lilo
Provides: yast2-agent-liloconf
Provides: yast2-agent-prom
Obsoletes: yast2-agent-liloconf
Obsoletes: yast2-agent-prom
Provides: yast2-trans-boot
Provides: yast2-trans-inst-bootloader
Provides: yast2-trans-lilo
Obsoletes: yast2-trans-boot
Obsoletes: yast2-trans-inst-bootloader
Obsoletes: yast2-trans-lilo
Provides: y2c_boot
Provides: y2t_boot
Obsoletes: y2c_boot
Obsoletes: y2t_boot
Provides: y2t_inst-bootloader
Provides: yast2-agent-liloconf-devel
Provides: yast2-agent-prom-devel
Obsoletes: y2t_inst-bootloader
Obsoletes: yast2-agent-liloconf-devel
Obsoletes: yast2-agent-prom-devel
Requires: yast2-ruby-bindings >= 1.0.0
Summary: YaST2 - Bootloader Configuration
License: GPL-2.0+
Group: System/YaST
%description
This package contains the YaST2 component for bootloader configuration.
%package devel-doc
Requires: yast2-bootloader = %version
Summary: YaST2 - Bootloader Configuration - Development Documentation
Group: System/YaST
%description devel-doc
This package contains development documentation for using the API
provided by yast2-bootloader package.
%prep
%setup -n yast2-bootloader-%{version}
%build
%{_prefix}/bin/y2tool y2autoconf
%{_prefix}/bin/y2tool y2automake
autoreconf --force --install
export CFLAGS="$RPM_OPT_FLAGS -DNDEBUG"
export CXXFLAGS="$RPM_OPT_FLAGS -DNDEBUG"
./configure --libdir=%{_libdir} --prefix=%{_prefix} --mandir=%{_mandir}
# V=1: verbose build in case we used AM_SILENT_RULES(yes)
# so that RPM_OPT_FLAGS check works
make %{?jobs:-j%jobs} V=1
%install
make install DESTDIR="$RPM_BUILD_ROOT"
[ -e "%{_prefix}/share/YaST2/data/devtools/NO_MAKE_CHECK" ] || Y2DIR="$RPM_BUILD_ROOT/usr/share/YaST2" make check DESTDIR="$RPM_BUILD_ROOT"
for f in `find $RPM_BUILD_ROOT/%{_prefix}/share/applications/YaST2/ -name "*.desktop"` ; do
d=${f##*/}
%suse_update_desktop_file -d ycc_${d%.desktop} ${d%.desktop}
done
%clean
rm -rf "$RPM_BUILD_ROOT"
%post
%{fillup_only -n bootloader}
%files
%defattr(-,root,root)
# menu items
%dir %{_prefix}/share/applications/YaST2
%{_prefix}/share/applications/YaST2/bootloader.desktop
%dir /usr/share/YaST2/include
%dir /usr/share/YaST2/include/bootloader
/usr/share/YaST2/include/bootloader/*
%dir /usr/share/YaST2/modules
/usr/share/YaST2/modules/*
%dir /usr/share/YaST2/clients
/usr/share/YaST2/clients/bootloader*.rb
/usr/share/YaST2/clients/print-product.rb
/usr/share/YaST2/clients/inst_*.rb
%dir %{_prefix}/lib/YaST2/bin
%{_prefix}/lib/YaST2/bin/*
%dir /usr/lib/YaST2/servers_non_y2
/usr/lib/YaST2/servers_non_y2/ag_*
%dir /usr/share/YaST2/scrconf
/usr/share/YaST2/scrconf/*.scr
%dir /var/adm/fillup-templates
/var/adm/fillup-templates/*
%dir /usr/share/YaST2/schema
%dir /usr/share/YaST2/schema/autoyast
%dir /usr/share/YaST2/schema/autoyast/rnc
/usr/share/YaST2/schema/autoyast/rnc/bootloader.rnc
%dir %{_prefix}/share/doc/packages/yast2-bootloader
%doc %{_prefix}/share/doc/packages/yast2-bootloader/README
%doc %{_prefix}/share/doc/packages/yast2-bootloader/COPYING
%files devel-doc
%doc %{_prefix}/share/doc/packages/yast2-bootloader/autodocs
%changelog